1. rosebud09's Avatar
    Hey everyone,
    I've just bought a blackberry curve 8520. However it was to pleace an old Nokia N97 which was the worst phone ever so I just moved my sim card from this to the blackberry. However now the Bbm doesn't work and it won't let me set up any email account it doesn't even have the option of setting up a personal email account it will only to the blackberry enterprise server option.

    I am currently on Orange contract with unlimited internet would I really have to pay the extra five pounds? there must be someway to set this up!

    Any responses would be greatly greatly appreciated because i'm stressing out!
    09-09-10 05:40 PM
  2. rosebud09's Avatar
    Hello thankyou very much for the swift responnse


    It just says not connected? and so does the blackberry enterprise server.... what should I do about this?
    09-09-10 06:06 PM
  3. mangcool's Avatar
    When you switched phones, Orange probably change your data service to "generic" data service. BIS is different from the regular data service, but I'm not sure if that's the case. I would call Orange and ask them about BIS.
    09-09-10 06:22 PM
  4. rosebud09's Avatar
    thankyou very much for your help! I will try it tomorrow!
    09-09-10 06:24 PM
  5. maxiang's Avatar
    Hey everyone,
    I've just bought a blackberry curve 8520. However it was to pleace an old Nokia N97 which was the worst phone ever so I just moved my sim card from this to the blackberry. However now the Bbm doesn't work and it won't let me set up any email account it doesn't even have the option of setting up a personal email account it will only to the blackberry enterprise server option.

    I am currently on Orange contract with unlimited internet would I really have to pay the extra five pounds? there must be someway to set this up!

    Any responses would be greatly greatly appreciated because i'm stressing out!
    You need to have a BlackBerry data plan for the BIS services to work (BBM, email, etc.)
    I would have thought that the N97 data price would be the same as the BB data price
    09-09-10 06:40 PM
  6. mangcool's Avatar
    You need to have a BlackBerry data plan for the BIS services to work (BBM, email, etc.)
    I would have thought that the N97 data price would be the same as the BB data price
    I don't think so. For most carriers, BIS is an add-on package, meaning it's optional when you get a phone. I think only Sprint (I'm not sure) is the only carrier that has BIS included into their data plan. For some carriers, however (like T-mo), they have two different data services. "Regular" data service, and a smartphone data service. If you're getting a BlackBerry, obviously, you would get the smartphone data service (this also implies to other smartphones like Nokia, Samsung, HTC, and all that).
    09-09-10 06:48 PM
  7. maxiang's Avatar
    I don't think so. For most carriers, BIS is an add-on package, meaning it's optional when you get a phone. I think only Sprint (I'm not sure) is the only carrier that has BIS included into their data plan. For some carriers, however (like T-mo), they have two different data services. "Regular" data service, and a smartphone data service. If you're getting a BlackBerry, obviously, you would get the smartphone data service (this also implies to other smartphones like Nokia, Samsung, HTC, and all that).
    On AT&T, the smartphone ( not counting feature phone ) data plans all have the same price as a BIS BlackBerry plan and are mandatory. If you're using BES, it carries an extra charge.
    I assumed the OP was using the Nokia N97 that runs on Symbian Series 60, which is a smartphone to carriers, and that is why I'm surprised that Orange would charge extra for BIS
    09-09-10 06:59 PM
  8. nothappy54321's Avatar
    I brought a blackberry its the touch one non key pad just touch unlocked brand new I put my contract Sim in it and 1the number shows up unknown 2 I can't contact anyone unless they contacted me first calling and texting and 3 my blackberry messenger don't work it succesfully installs but just keeps going blank or says its just still setting up but its been saying thtat now for over 24 hrshelp
    05-29-13 09:23 PM
LINK TO POST COPIED TO CLIPBOARD