1. Laiith's Avatar
    Ok so I've had my 9700 for over a year now and never had any problems with it until one day my screen went white and had a little error message : 507 ... So I ended up fixing it I just updated it to the newest OS.. So my problem is BBM doesn't work ...? And yes I do have a data plan I even called in to double check 3 times ! Fido(my carrier) couldn't even help me they had no idea what to do ... I even contacted Blackberry over the phone and they couldn't help me either..

    My bbm opens fine but I have 0 contacts in there .. I cant add anyone nor can anyone add me :S ... I also noticed that my facebook app doesnt work for some odd reason says I don't have a service plan.... Well yes I do and I had them remove it and re-add it but still same issue. My internet browser works perfectly fine.

    I'm guessing the issue is I don't have the " service books " for it :S I checked my service books and there is only 7 service books in there .. the guy from blackberry told me there should be more.. So then I went into Host Routing Table and clicked Register Now .. It said their was something sent to me, ya well I didnt recieve anything and i've tried it over 10 times.

    Ive tried battery pulls and all that simple stuff, I've checked to see if my data roaming and all that crap is on... yes it is. IM GOING CRAZY !

    The only reason I purchased a blackberry is because of bbm <3 and its not even working :'( someone please help me with this issue ! I don't know what to do !
    11-16-11 03:42 PM
  2. Bla1ze's Avatar
    It's a carrier issue / connection issue, despite what Fido is telling you... it's their problem if the service books aren't getting to your device. If you have full signal, and 3G showing.. the issue is on their end. There really isn't much you personally or anyone here can do really.
    11-16-11 03:55 PM
  3. Laiith's Avatar
    Any idea of what I should tell them? I've honestly sat on the phone with them for over an hour trying new things .. They've reset everything on their end, took off my data plan then put it back on .. Lots more but nothings worked !
    11-16-11 04:01 PM
  4. Bla1ze's Avatar
    Any idea of what I should tell them? I've honestly sat on the phone with them for over an hour trying new things .. They've reset everything on their end, took off my data plan then put it back on .. Lots more but nothings worked !
    Aside from the telling them their customer service sucks? lol. No idea what to say to them, if they aren't seeing the issue then they should be offering to escalate it or offer something else. They can't just say, "Hmm.. everything looks fine to us.. sorry... bye".. keep calling back till you get a rep who actually cares abt their job and is willing to help.
    11-16-11 04:05 PM
LINK TO POST COPIED TO CLIPBOARD