1. TallyHo's Avatar
    Trying to set up a new gmail account on my berry this morning and it keeps saying account/password invalid.

    1. I know the account is valid, I can log in to it on my pc.
    2. I have tried through BIS on my PC
    3. I have tried through my phone email setup
    4. No cap-lock is not on
    5. Yes, I checked the "show password" box on the phone
    6. Yes, IMAP is enabled on gmail

    I'm at a total loss here. Is there some sort of issue right now with BIS and Gmail? Could it be due to the 2-way sync they are setting up?

    ugh.....I need my email.
    10-19-09 09:11 AM
  2. ekyle125's Avatar
    I'm having some issues with Gmail too. I can get it set up and on the BB but if I put in the wrong password to go to the advanced settings like I could before it won't let me. I want IMAP! haha. I still don't have the option for the contact sync either. Maybe they are having issues implementing this sync like you suggested.
    10-19-09 09:14 AM
  3. jbs-horn's Avatar
    If you have gmail "labs" activated, make sure that your "All Mail" folder is checked to show up in IMAP. If it's not, the standard gmail setup won't work.

    You can also try the old workaround from before BIS 2.6, but with a twist. Rather than giving the setup screen your email address and a fake password, give it a fake address such as user@blah.com. When it complains, it will give you the opportunity to give it the specific settings.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-19-09 09:20 AM
  4. TallyHo's Avatar
    If you have gmail "labs" activated, make sure that your "All Mail" folder is checked to show up in IMAP. If it's not, the standard gmail setup won't work.

    You can also try the old workaround from before BIS 2.6, but with a twist. Rather than giving the setup screen your email address and a fake password, give it a fake address such as user@blah.com. When it complains, it will give you the opportunity to give it the specific settings.

    Posted from my CrackBerry at wapforums.crackberry.com
    I don't have labs activated, so that's not the issue.

    I have tried everything. It must be an issue with gmail at this point. Of course, they don't officially support IMAP on Blackberries, so they won't help you either.....nice!!!
    10-19-09 09:34 AM
  5. ekyle125's Avatar
    If you have gmail "labs" activated, make sure that your "All Mail" folder is checked to show up in IMAP. If it's not, the standard gmail setup won't work.

    You can also try the old workaround from before BIS 2.6, but with a twist. Rather than giving the setup screen your email address and a fake password, give it a fake address such as user@blah.com. When it complains, it will give you the opportunity to give it the specific settings.

    Posted from my CrackBerry at wapforums.crackberry.com
    Its strange. To do a test, I sent myself an email form my work address right. I opened GMail on my browser and opened the email on my phone. I hit refresh on the PC browser and it was marked as read, similar situation when I deleted the email on my BB, it deleted from the server. I'm pretty sure POP3 doesn't do that. Does this mean that GMail is set up as IMAP as default.

    It also prompted me to download a GMail plugin (not an app) when I added the account again.
    10-19-09 09:36 AM
  6. TallyHo's Avatar
    Its strange. To do a test, I sent myself an email form my work address right. I opened GMail on my browser and opened the email on my phone. I hit refresh on the PC browser and it was marked as read, similar situation when I deleted the email on my BB, it deleted from the server. I'm pretty sure POP3 doesn't do that. Does this mean that GMail is set up as IMAP as default.

    It also prompted me to download a GMail plugin (not an app) when I added the account again.
    yeah, GMAIL is IMAP now. POP3 doesn't work with the newer BIS. Yes, there is also a gmail plugin, gives you more functionality in the native BB email program.

    My problem is that I can not even add the account again....ugh.
    10-19-09 09:41 AM
  7. TallyHo's Avatar
    Side note:

    I have just tried to add another one of my email accounts that is on YAHOO and it worked just fine. Seems to be an issue with gmail and not BIS.
    10-19-09 09:46 AM
  8. TallyHo's Avatar
    update:

    I guess it's not gmail either as I just added another gmail account to my Berry.............great, looks like an issue with one account.
    Last edited by TallyHo; 10-19-09 at 10:32 AM.
    10-19-09 09:51 AM
  9. ekyle125's Avatar
    Side note:

    I have just tried to add another one of my email accounts that is on YAHOO and it worked just fine. Seems to be an issue with gmail and not BIS.
    I did some Googling for you and can't seem to find anything pointing to your problem and I can't seem to find anything. Wish I could help more.
    10-19-09 09:55 AM
  10. TallyHo's Avatar
    yeah, seems to be related to this one account. I have no idea. I've tried changing the password and everything. I can login to the account just fine on the PC, just can't add it through BIS or through "Email Setup" on my Berry.

    Thanks for trying!
    10-19-09 10:05 AM
  11. TallyHo's Avatar
    Holy Cow!!!!!!!!!!!!

    I finally figured it out thanks to someone on cellphoneforums.net.

    I guess it turns out you must have CAPTCHA unlocked on your account. I guess this somehow was turned on on my account after I had already added it the first time.

    Here is the link to unlock captcha.

    https://www.google.com/accounts/UnlockCaptcha

    w00t!!!!!
    10-19-09 10:22 AM
  12. Denise in Los Angeles's Avatar
    Holy Cow!!!!!!!!!!!!

    I finally figured it out thanks to someone on cellphoneforums.net.

    I guess it turns out you must have CAPTCHA unlocked on your account. I guess this somehow was turned on on my account after I had already added it the first time.

    Here is the link to unlock captcha.

    https://www.google.com/accounts/UnlockCaptcha

    w00t!!!!!
    Very interesting. I've never seen that before.
    10-19-09 01:34 PM
  13. naman919's Avatar
    Holy Cow!!!!!!!!!!!!

    I finally figured it out thanks to someone on cellphoneforums.net.

    I guess it turns out you must have CAPTCHA unlocked on your account. I guess this somehow was turned on on my account after I had already added it the first time.

    Here is the link to unlock captcha.

    https://www.google.com/accounts/UnlockCaptcha

    w00t!!!!!
    how did you proceed to setup your imap gmail through BIS. i unlocked captcha but still can't set it up.....
    10-19-09 01:43 PM
  14. naman919's Avatar
    If you have gmail "labs" activated, make sure that your "All Mail" folder is checked to show up in IMAP. If it's not, the standard gmail setup won't work.

    Posted from my CrackBerry at wapforums.crackberry.com
    can you elaborate on how to make sure that all mail folder is checked? where?
    10-19-09 01:46 PM
  15. jbs-horn's Avatar
    You do it from your computer browser in gmail. Click "Settings," then "Labels." You will see all of the labels applicable to your gmail account, both the "system labels" and the labels you add. If you have enabled "advanced IMAP controls" in labs, there will be a checkbox next to each label. Any label with a check will be accessible from an IMAP client. Any label without a check will be invisible to an IMAP client.

    How I learned about this little wrinkle is a long story.

    The problem came up last Friday when I decided against my better judgment to try the gmail plugin. I deleted my old gmail account from BIS and re-added it. It authenticated successfully but I kept getting a message that my gmail messages could not be sent to my phone and that I should confirm that IMAP was enabled on my gmail account and then re-authenticate. I tried everything including the Capcha unlock and re-adding the account about 20 times, but to no avail. I called tech support at AT&T and got through four levels of support without an answer. Finally they forwarded me to RIM support. After thoroughly going over things with Sam, he asked me if I had "All Mail" checked in gmail. I looked at it and confirmed it wasn't checked. He told me to check it and re-add the account to BIS. I did, and it worked.

    Ironically, the plugin didn't work well on my 8310, so I deleted it. I didn't like how the standard IMAP setup worked (it absolutely refused to sync deleted items from gmail to the phone), so I deleted it and used the old workaround to set up gmail as a generic imap account. All is as well as it was before I tried to fix what wasn't broken.

    can you elaborate on how to make sure that all mail folder is checked? where?
    10-19-09 08:44 PM
  16. mightymikek83#IM's Avatar
    I'm having the same issue. I went to Verizon today and was in there for HOURS. They were with tech support the whole time and couldn't figure out the issue. I was only able to set up one gmail account while the other can't be set up. I enabled my IMAT or whatever thing and it still did nothing. The Verizon rep was lost and apologized for not being able to help.
    10-19-09 08:50 PM
  17. mightymikek83#IM's Avatar
    Thankyou So Much!!! This Worked Lol!!! Wow My Night Is So Good Now Hahaha Thank You Thank You!!!
    10-19-09 08:57 PM
  18. Jellybeangirl's Avatar
    Hello
    I am new to the blackberry world(like a week into it). I set up my gmail up with no problem. But my sister had trouble, basically the same situation as the person above said(that message came up about not able to activate gmail). So the people at verizon were like oh your typing in the wrong password, she said no. She logged onto gmail from a PC no problem. They thought oh maybe because the phone was just activated and told her to come back tomorrow. Well the next day, same issue. I was in the local mall and asked the guy at the verizon store, if he could help with the situation. He asked if I could give him everything(e-mail, password, pin) because he was going to try doing it on the back end. He comes back out 5mins later and told, me he has never had that problem before, and doesn't know how to solve it. He said I should get in touch with google and see what they can do. Tallyho mentioned to unlock captcha (which I have never heard of prior to this post). That is what I did and it worked!!
    THANK YOU!
    10-24-09 07:22 PM
  19. naman919's Avatar
    You can also try the old workaround from before BIS 2.6, but with a twist. Rather than giving the setup screen your email address and a fake password, give it a fake address such as user@blah.com. When it complains, it will give you the opportunity to give it the specific settings.

    Posted from my CrackBerry at wapforums.crackberry.com
    Works perfectly. Thanks!
    11-02-09 09:04 AM
  20. ekyle125's Avatar
    anyone able to get the contact sync working?
    11-02-09 10:40 AM
  21. surfgeek's Avatar
    Holy Cow!!!!!!!!!!!!

    I finally figured it out thanks to someone on cellphoneforums.net.

    I guess it turns out you must have CAPTCHA unlocked on your account. I guess this somehow was turned on on my account after I had already added it the first time.

    Here is the link to unlock captcha.

    https://www.google.com/accounts/UnlockCaptcha

    w00t!!!!!
    Thanks for this info. I thought Google was screwing with Blackberry access to get people on the Android bandwagon.
    11-06-09 01:57 PM
LINK TO POST COPIED TO CLIPBOARD