1. perrello's Avatar
    Hi,

    Just setup the new Blackberry and made sure it has the latest updates.

    When I try to add memopad using the synchronization button, it lets me check the box, select Microsoft Outlook and the direction of synchronization, the Outlook user profile and when I click "Finish", it brings up this error:

    "Microsoft Outlook Connector Error"
    "Function OpenMsgStore failed."

    I am not using wireless, just want it to sync through the wire and have had no problem with contacts, calendar and tasks.

    Thanks,
    Mike
    11-24-09 04:12 PM
  2. clitrenta's Avatar
    Try this. I found it "out there" :

    Reset the Intellisync configuration by completing the following steps:
    On the computer, open BlackBerry Desktop Manager.
    Double-click the Synchronize icon.
    Select the Configuration tab.
    In the Advanced section, click Reset configuration.

    I don't think there is actually a syncronization "tab" but there is a button to reset the synchronization
    11-24-09 05:52 PM
  3. perrello's Avatar
    Already did this and didn't work.
    Mike
    11-24-09 08:24 PM
  4. Duard_F's Avatar
    I'd post a link to the other thread where I documented this but I'm not senior enough to post links yet, so I'll just repeat the whole thing.

    Like many of you, I have this problem for memopad only, and it happens at setup time, not sync time. I have tried all of the solutions in these forums like resetting to default sync, creating a new MAPI profile, and downgrading to a prior DM with no success. But it's fixed now, based on what I learned at www{dot}blackberryforums{dot}com{dot}au{slash}foru ms{slash}bis-blackberry-desktop-manager{slash}602-function-openmsgstore-failed-during-synchronization{dot}html

    As nearly as I can tell, there's a design flaw in DM - under some circumstance sync setup for memopad cannot succeed until a remapping of folders is done, however remapping of folders cannot be done until there is a completed sync setup. Catch 22.

    The solution is to set up a bogus memopad sync setup, add the actual target file containing the memopad entries, do the folder remap and then drop the bogus file.

    1. Create a new mail profile. Windows>ControlPanel>Mail>ShowProfile>Add. I named my new profile "Bogus"

    2. You don't want this bogus profile linked to any real email account. This is a little tricky. I checked the "manually configure" box on the auto account setup page, picked internet email from the choose email service page, then typed "bogus@bogus.org" as the email address on the internet email settings, and "bogus" in all of the other blanks, then click "next" and "finish". Back on the "mail" page, be sure "prompt for a profile to be used" is set, and click "ok"

    3. close outlook if it's open, then open it. in the "choose profile" window, pick the "bogus" profile.

    4. In outlook, add your real data file to the bogus profile. Tools>Options>MailSetup>DataFiles>Add - select Office Outlook Personal Files>OK - select your file and click OK

    5. Setup Desktop Manager Sync - DesktopManager>Synchronize>ConfigureSynchronizatio n>Synchronization

    6. Select the Memopad row and select Setup. You have probably been through this many times already, do whatever you normally do except that two pages in where you select a profile, take the bogus profile. On the last page, click Finish. This is where you would normally get the OpenMsgStore failure but you should not get it this time. Congratulations, you have successfully set up MemoPad sync again! But it's with the wrong profile and the wrong data file, we have to fix these two problems.

    7. To go back tot he correct profile, select the Memopad row again and select Setup. This time, do not specify your bogus profile. Instead, select the normal profile (Mine's called "Outlook"). After you select "Finish" you will probably get the OpenMsgStore error again. But this time there is a memopad sync setup on record, so you have access to folder mapping

    8. Select memopad one last time and click the "Advanced" button. select the Memopad tab, and click the Map Folder button. On the left, find your primary file and expand it to show the folders, select the Notes folder and click Add. on the right, find the bogus folder, select it and click Remove. Your Selected Folders should now show only one folder, the Notes folder in your primary data file. Click OK

    Done
    Edit/Delete Message
    02-13-11 10:56 AM
LINK TO POST COPIED TO CLIPBOARD