1. drsatan's Avatar
    Hi all,

    I have searched through the message boards and couldn't find the right answer.

    I have a Bold 9700 with BIS, SW v5.0.0.423

    My company recently moved to Google apps for our email system. Our email addresses are @companyname.com, however through Google.

    On my BB, I have my personal gmail (@gmail.com) and my work email accounts set up. They both work fine (except the two way syncing issue that we all want fixed!).

    My issue is that my work account does not have the inbuilt Gmail features, such as add star, archive, etc.

    I assume it is because the BB doesn't realise that my account is a gmail account. Perhaps it is treating the email account as standard. (Note: In the advanced options when setting up the email account, I needed to enter the gmail imap server for my work email to work.)

    Is there a way of configuring my work email so I get the gmail features?

    Sorry if I have posted this in the wrong place.
    05-03-10 10:10 PM
  2. Eric The Duke's Avatar
    You have to delete your account from BIS and then add it back. It should then be recognized as a google apps account.
    05-04-10 10:26 AM
  3. drsatan's Avatar
    You have to delete your account from BIS and then add it back. It should then be recognized as a google apps account.
    I tried this but it doesn't seem to work. I removed the account, reset it up and it is still not recognizing it as a Google Apps account.

    Does anyone else have a Google Apps account working with the correct menu items (add star, report spam, etc.) on their email account that _does not_ end with @gmail.com?

    Thanks in advance!
    05-04-10 04:27 PM
  4. lairdb's Avatar
    I tried this but it doesn't seem to work. I removed the account, reset it up and it is still not recognizing it as a Google Apps account.

    Does anyone else have a Google Apps account working with the correct menu items (add star, report spam, etc.) on their email account that _does not_ end with @gmail.com?

    Thanks in advance!
    Yes; my GAFYD account shows those menu choices (within the gmail plugin view; not within the combined messages view.)

    See my post here for further sync discussion.
    05-04-10 05:55 PM
  5. drsatan's Avatar
    Yes; my GAFYD account shows those menu choices (within the gmail plugin view; not within the combined messages view.)

    See my post here for further sync discussion.
    How do you have your account GAFYD set up on you BB? I presume the email address is <name>@<domain>.com. Account the same as the email, and the incoming sever imap.gmail.com?

    Glad to hear it is working for someone else. Now I just need to work out how to set it up for me!
    05-04-10 06:08 PM
  6. lairdb's Avatar
    How do you have your account GAFYD set up on you BB? I presume the email address is <name>@<domain>.com. Account the same as the email, and the incoming sever imap.gmail.com?

    Glad to hear it is working for someone else. Now I just need to work out how to set it up for me!
    I set mine up via the web interface; I did not trick it into giving me the "advanced settings", just entered <name>@<domain>.com and <password> where expected, and it appears to autodetect that it's a GAFYD account.
    05-04-10 06:27 PM
  7. drsatan's Avatar
    I set mine up via the web interface; I did not trick it into giving me the "advanced settings", just entered <name>@<domain>.com and <password> where expected, and it appears to autodetect that it's a GAFYD account.
    I have been doing some reading and it appears that RIM may need to add my domain to their MX records to realize that the domain is actually a google apps domain. Because you didn't need to add any credentials, I would assume that is because your domain is already registered with RIM as a google apps domain, hence the server knew what to do to set it up.

    At least - that all makes sense in theory. Will see if I can determine how to raise this with RIM.

    Thanks for your help so far.
    05-04-10 06:30 PM
  8. Eric The Duke's Avatar
    I tried this but it doesn't seem to work. I removed the account, reset it up and it is still not recognizing it as a Google Apps account.

    Does anyone else have a Google Apps account working with the correct menu items (add star, report spam, etc.) on their email account that _does not_ end with @gmail.com?

    Thanks in advance!
    I use Google apps for education and it works with my non gmail.com address. One thing I would try is downloading the gmail application for Blackberry. The gmail app works with google hosted e-mail addresses.
    05-04-10 10:27 PM
LINK TO POST COPIED TO CLIPBOARD