1. sadaluc22's Avatar
    on the appworld site it says that the new blackberry messenger is compatible with all blackberry devices, but when i go on app world on my phone, blackberry messenger isn't there. every time i email the download link to my phone, the "download" option isn't there.. how can i get the new bbm?!!?!?
    01-10-10 02:04 PM
  2. Dubbin1's Avatar
    What firmware do you have on the phone?
    01-10-10 02:09 PM
  3. dslocumb's Avatar
    The newest version of BB Messenger is compatible with BlackBerry OS versions 4.7 and higher.
    01-10-10 02:14 PM
  4. Dubbin1's Avatar
    The newest version of BB Messenger is compatible with BlackBerry OS versions 4.7 and higher.
    Make that 4.5 and later.
    01-10-10 02:19 PM
  5. sadaluc22's Avatar
    what is firmware? i thought that my phone was too old to download it, but then i read that the new bbm is compatible with any blackberry phone
    01-10-10 04:14 PM
  6. Dubbin1's Avatar
    I guess I should have said Operating System. Go to Options then Then About and tell us what version you have. It should be the 3rd line and starts with a v
    01-10-10 04:43 PM
LINK TO POST COPIED TO CLIPBOARD