1. cooljomark's Avatar
    I have a hotmail account and a gmail account set up on my blackberry. I use the hotmail for my main email and the gmail as my main calendar. The problem is whenever I set up a new appointment using my gmail on my bb it will show up twice once as a gmail event and once as a hotmail event, even though I didn't use hotmail to make the appointment. How can I stop this? Right now I use the option to only view gmail within the calendar view but I really want to figure out how to stop this. Thanks for your help!
    07-05-09 11:10 PM
  2. cooljomark's Avatar
    the crazy thing is that the hotmail appointments that show up after I have used my gmail calendar to set up, don't even show up in my hotmail calendar when I sign into my account from a computer! It is so strange
    07-05-09 11:27 PM
  3. cavingjan's Avatar
    What is your default calendar email address? gmail or hotmail?
    07-06-09 06:59 AM
  4. cooljomark's Avatar
    the default calendar is gmail
    07-06-09 09:56 AM
  5. cooljomark's Avatar
    anyone out there?! please help
    07-06-09 04:05 PM
  6. greydarrah's Avatar
    A new calendar is created every time you add a new email address. The extra addresses create extra calendar entries. To delete these:

    ***Backup phone before making any changes***

    - From the main screen, hit the BB button.
    - Go to Options
    - Go to Advanced Options
    - Go to Service Book
    - Find your email address (for the calendar you want to delete). There should be two listings your_name@example.com[CMIME] and your_name@example.com[CICAL]. The CICAL one is the calendar. Simply scroll over this one (the CICAL) and hit the BB button. Click delete. Voila! If you delete all calendars, you will have just one default calendar, or you can just delete all but the one that you consider to be your primary email entry.

    Just make sure you don't delete the CMIME ones, as these are the actualy email books.
    07-06-09 05:02 PM
  7. cooljomark's Avatar
    A new calendar is created every time you add a new email address. The extra addresses create extra calendar entries. To delete these:

    ***Backup phone before making any changes***

    - From the main screen, hit the BB button.
    - Go to Options
    - Go to Advanced Options
    - Go to Service Book
    - Find your email address (for the calendar you want to delete). There should be two listings your_name@example.com[CMIME] and your_name@example.com[CICAL]. The CICAL one is the calendar. Simply scroll over this one (the CICAL) and hit the BB button. Click delete. Voila! If you delete all calendars, you will have just one default calendar, or you can just delete all but the one that you consider to be your primary email entry.

    Just make sure you don't delete the CMIME ones, as these are the actualy email books.

    Grey,
    thanks for your help, although I did everything you said and the entries are still showing up twice. Now instead of them showing up as gmail and hotmail...there are appearing as gmail and default device
    07-06-09 10:17 PM
  8. cavingjan's Avatar
    At this point in time, you can go into your calendar and filter to the default device calendar. Then just purge old entries. It will at least get rid of most of them.
    07-07-09 06:53 AM
  9. mallinj's Avatar
    Same problem. Same issue with default calendar. Newbie question.. how do I delete all items from the Calendar?
    07-08-09 07:48 AM
  10. tomasjdaniel's Avatar
    bumping the question
    07-08-09 12:02 PM
  11. mstechdiva's Avatar
    I'm having the same issue...only worse because I have several email accounts. I also went thru the steps posted and the calendar entries remain. Any other suggestions? Thanks!
    03-30-10 11:39 PM
  12. jbonnot03's Avatar
    I'm having the same issue...only worse because I have several email accounts. I also went thru the steps posted and the calendar entries remain. Any other suggestions? Thanks!
    There are a couple of options to clear out your calendar.

    Option 1 -- Use if you have access to a wirelessly synced calendar (These steps are for Google)
    Make sure you have the correct calendar selected under Default Services.
    Connect BB to PC and open DM.
    Go to Backup/Restore and then Advanced
    Find the Calendar databases (should be 2) and clear them.
    Go to your Google Sync and sign out and then sign in.
    All appointments should have reappeared in the proper default calendar.

    Option 2--Does not require PC
    Decide which calendar will be your default and make sure that is correct in Options, Advanced Options, Default Services
    Go to your calendar and hit Menu, Select Calendar.
    Select the unwanted calendar that has entries in it.
    Menu Go to Date and go to some date in 2099.
    Be sure your cursor is now highlighting a date and not an appointment.
    Menu, Delete Prior.
    This should delete all entries prior to 2099.
    Repeat for each calendar that has unwanted appointments.
    03-31-10 06:34 AM
LINK TO POST COPIED TO CLIPBOARD