1. Elenafox's Avatar
    I recently bought a 9700 in Taiwan; it's unlocked and I am using it with AT&T in the US. BBM and PIN messaging don't work (all attempts show as pending with the clock icon) and in the diagnostic test 'ping' fails. Internet etc works fine and I have wifi+3G. BBM was working fine in Asia but not here. Called AT&T support who didn't help much; wondering if there is something embedded in Asian phone's that prevent them from fully working here or what could the cause be? Thanks!
    10-23-11 05:29 AM
  2. Rootbrian's Avatar
    Did you change the IMEI? That's illegal. Also, if your IMEI/PIN is on your old carrier, you'll need to have it removed and then added to the at&t BIS. I'm a bit confused myself.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-23-11 10:52 AM
  3. Elenafox's Avatar
    I didn't change the IMEI; I bought the phone in a store; I did use a prepaid local SIM; when I came back to NY I used my US SIM and AT&T can't explain why it's not working.
    10-24-11 02:45 AM
  4. Rootbrian's Avatar
    Okay maybe the blackberry might have been resold and the imei is still on the previous owner's account. Was it open box or sealed?

    Posted from my CrackBerry at wapforums.crackberry.com
    10-24-11 08:33 AM
  5. fusioncal's Avatar
    It's strange. Your phone if unlocked should work on any carriers. Were you able to make phone calls? Or is it just BIS service you are having problems with? If that's the case, perhaps you need to subscribe to BIS plan instead of only data plan?
    10-25-11 01:12 AM
  6. Capitan Totti's Avatar
    Its because BBs need a BIS or BES data plan to work 100%, meaning BBM email etc. Your BB might still be "stuck" to your old Asian carrier, and not on your new AT&T one. Simple.
    10-25-11 05:28 AM
  7. dougsorensen's Avatar
    I recently bought a 9700 in Taiwan; it's unlocked and I am using it with AT&T in the US. BBM and PIN messaging don't work (all attempts show as pending with the clock icon) and in the diagnostic test 'ping' fails. Internet etc works fine and I have wifi+3G. BBM was working fine in Asia but not here. Called AT&T support who didn't help much; wondering if there is something embedded in Asian phone's that prevent them from fully working here or what could the cause be? Thanks!
    Assuming you have BB plan on your AT&T account, try updating the Host Routing Table (Options>Device>Advanced System Settings>Host Routing Table, select "Register Now" on the menu).
    10-26-11 04:31 PM
LINK TO POST COPIED TO CLIPBOARD