1. wout000's Avatar
    I just downloaded the latest Blackberry Travel and when i try opening it, I get an error saying

    "Oops, it seems the version installed is not compatible with your device."

    I have a torch 9810 running 7.1.

    Previous version of Blackberry travel worked perfectly...
    02-25-12 11:05 AM
  2. raino's Avatar
    That sucks. If you're looking to downgrade, you can get the previous version(s) OTA from rroyy.com/otaarchive
    02-27-12 08:20 PM
LINK TO POST COPIED TO CLIPBOARD