1. Onica's Avatar
    I tried downloading the app from the BB App World link and it stated my device is not compatible with the app. I have friends that have the new version and I just can't seem to figure out why it won't work on my device. Please help! Thanks!!!
    10-17-09 09:29 PM
  2. jlsparks's Avatar
    Try getting it from RIM's site: BlackBerry - BlackBerry App World Download
    10-17-09 09:30 PM
  3. amazinglygraceless's Avatar
    From your phone browser try:

    10-17-09 09:35 PM
  4. Onica's Avatar
    @ amazinglygraceless...Thanks...I tried the link and unfortunately it stated my :device doesn not meet the system requirements. In system requirements it stated it supports "OS 4.5 and higher"? Not sure what that means. I yried looking in my tools to find out what version I have but unable to locate anything w OS.
    10-17-09 09:48 PM
  5. TheSultan's Avatar
    You can locate your OS by going to "Options" and then "About". If your Curve is really old it might have 4.3 on it.
    10-17-09 09:55 PM
  6. Onica's Avatar
    @ TheSultan....Thanks a million..It is 4.3...at least I know now exactly why it wasn't downloading.

    Do you know if I can get a newer version or my only option at this point will be to get a newer phone?
    10-17-09 10:01 PM