1. wig2ish's Avatar
    I've looked all over the Storm for settings to address this and I'm at a loss.

    I'm seeing birthday calendar entries that span two days in the Storm. The entry appears on the correct day and the next day. If I delete one entry it goes away from both days. The birthdays are set in the individuals contact info. When the birthday is selected in each day it shows the correct day even on the wrong day (if the birthday is on the 3rd it will show the 3rd even on the 4th). It shows an all day event and for the event to just be one day (not spanning two days).

    I do not wireless sync. I do my data entry on my Storm and when I sync I have it set to overwrite Outlook. Outlook displays the birthday spanning over two days as well.

    Any thoughts or suggestions?
    05-25-09 09:53 AM
  2. Craterz's Avatar
    Ensure that your timezones are correct on both your pc as well as your Storm. This is most likely the issue.
    05-25-09 09:57 AM
  3. wig2ish's Avatar
    Time Zones are identical and correct.
    05-25-09 10:01 AM
  4. Craterz's Avatar
    Time Zones are identical and correct.
    Hmmm... don't know then. The only instance that it shows spanned over two days for me, is when I enter in a Birthday (or Anniversary, or "All day event" directly in the calendar) when my Storm timezone differs than my pc time zone. For example... When I am traveling, I may enter a Birthday (Anniversary, "All day event") for a contact when my Storm timezone is set to GMT+8 (which is the current timezone for where I am at), but when I sync to my pc it will be displayed as spanning over two days since my pc timezone is still set to GMT-5 (home). At the same time, my Storm will sync the time to whatever my pc is currently set at and then show the Birthday as spanning over two days, since it was originally entered in on a different timezone.
    05-25-09 10:20 AM
  5. credo's Avatar
    Do you have the FaceBook app? This issue started for me when I downloaded FB 1.5. It syncs the birthdays for 8 pm to 8 pm. Thus, creating a two day entry.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-25-09 11:28 AM
  6. arcanexvi's Avatar
    facebook has its own calendar and should not affect the regular bb one. also, i don't have 2 day spanning issues on mine with FB 1.5
    05-25-09 11:32 AM
  7. Morf32's Avatar
    I've looked all over the Storm for settings to address this and I'm at a loss.

    I'm seeing birthday calendar entries that span two days in the Storm. The entry appears on the correct day and the next day. If I delete one entry it goes away from both days. The birthdays are set in the individuals contact info. When the birthday is selected in each day it shows the correct day even on the wrong day (if the birthday is on the 3rd it will show the 3rd even on the 4th). It shows an all day event and for the event to just be one day (not spanning two days).

    I do not wireless sync. I do my data entry on my Storm and when I sync I have it set to overwrite Outlook. Outlook displays the birthday spanning over two days as well.

    Any thoughts or suggestions?
    Are you sure that the time zone is set correctly in Outlook? You have to have the time zone set correctly in Outlook (not the PC), or the calendar entries will overlap two days. To set your time zone in Outlook, go to Tools, Options, and in the menu that pops up, under the Preferences tab, there will be a button labeled "Calendar Options"-- click on that. At the bottom of the window that pops up, click on the Time Zone button. That is where you can change the time zone for Outlook. Make sure that is set correctly.
    05-25-09 11:33 AM
  8. jeffmik's Avatar
    I get this problem occasionally when I upgrade OS. My time zones are set correctly in both the phone and Outlook but the start times gets changes from 12 to 5am or 6am which makes the event span 2 days. Its almost certainly a timezone problem but I haven't figured the problem out - I fix it by deleting the calendar on my BB then resyncing.
    05-25-09 11:38 AM
  9. DeaconBlue's Avatar
    Do you have the FaceBook app? This issue started for me when I downloaded FB 1.5. It syncs the birthdays for 8 pm to 8 pm. Thus, creating a two day entry.

    Posted from my CrackBerry at wapforums.crackberry.com
    +1 to the Facebook suggestion. I noticed several appointments/birthdays in my calendar turned to 8AM Day 1-8AM Day 2 also. Go into the event, reset it to "All day event", change the ending date back to the correct date, and re-synch.

    Also, go into Options | Advanced | Default Services and make sure your calendar is not set for Faceboox (unless of course you want Facebook to be your default calendar).
    05-25-09 12:06 PM
  10. wig2ish's Avatar
    Do you have the FaceBook app? This issue started for me when I downloaded FB 1.5. It syncs the birthdays for 8 pm to 8 pm. Thus, creating a two day entry.

    Posted from my CrackBerry at wapforums.crackberry.com
    I have the icon to download the facebook app but do not use it.
    05-25-09 12:29 PM
  11. Morf32's Avatar
    I have the icon to download the facebook app but do not use it.
    Then just follow some of the other advice... make sure your time zone is set correctly in Outlook, and make sure your days are set to start and end at 12am.
    05-25-09 12:31 PM
  12. wig2ish's Avatar
    Are you sure that the time zone is set correctly in Outlook? You have to have the time zone set correctly in Outlook (not the PC), or the calendar entries will overlap two days. To set your time zone in Outlook, go to Tools, Options, and in the menu that pops up, under the Preferences tab, there will be a button labeled "Calendar Options"-- click on that. At the bottom of the window that pops up, click on the Time Zone button. That is where you can change the time zone for Outlook. Make sure that is set correctly.
    Thanks. It is set correctly ... the Storm, PC and Outlook have been and are currently all set to Eastern Time Zone with daylight savings time checked.
    05-25-09 12:34 PM
  13. wig2ish's Avatar
    Then just follow some of the other advice... make sure your time zone is set correctly in Outlook, and make sure your days are set to start and end at 12am.
    Is there another location for start / end date besides in the calendar? I thought this option is for the calendar display times.
    05-25-09 12:38 PM
  14. Morf32's Avatar
    Is there another location for start / end date besides in the calendar? I thought this option is for the calendar display times.
    No... it's only in the calendar. I just remember that when I used to sync with Yahoo, the start/end times in the Yahoo calendar were all screwed up, and it was giving me calendar entries that spanned over two days. Once I fixed the time zone in Yahoo, and the start/end times of the day, everything started syncing correctly.
    05-25-09 12:46 PM
  15. Adn1015#CB's Avatar
    i had this problem, and finally found that if i had set the time zone on the phone to the +0 GMT for each instance, it fixed the calendar dates. but i had to go through each one individually. Not sure if there is an easier way. but just fixing it on my phone and then pairing with Outlook took care of it
    05-25-09 03:56 PM
  16. mentul77's Avatar
    I'd been having this problem and use google calendar not outlook and everything was set to eastern. What fixed it was Morf32's suggestion. Make sure the day start and end times are 12:00am. I had them set to 7a-9p to show a smaller time period and it was really messing with my all day appointments but changing that fixed it! Thank you guys!
    06-24-09 11:14 PM
  17. wig2ish's Avatar
    What I've done to solve this problem is to set the amount of days the event (birthday) occurs to '0' which limits it to one day. The problem is I have to go through each birthday and make the adjustment.

    It's not a great solution but it works.
    06-27-09 12:42 PM
  18. joosya's Avatar
    I cant pair my berry with outlook, i have a mac. any other suggestions?
    06-27-09 12:44 PM
  19. Clyde67's Avatar
    I had the same thing happen to me after I came back from china a few weeks ago. Not sure if it was the time zone difference but I can say that I do NOT have the facebook app.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-27-09 01:44 PM
  20. soapsudz's Avatar
    Actually, ...the problem is with how dates are formatted on the !%$#% Blackberry, after an OS upgrade or reinstall. The Calendar sets dates to begin at 8am, and Google, Outlook, etc., use reoccurring appointments with the 12am - 12am (all day) time setting. Blackberry, in it's screwed up 'wisdom' converts all of those reoccurring appointments to start at a different time, to coincide with Blackberry. MORONS!!! They've successfully f'd-up over 300 reoccurring appointments for me with that 'FEATURE'! If your BB calendar is not your default calendar... meaning, that you have Outlook, Google, etc., disable sync both ways, and re-enable to sync in one direction Computer --> Mobile the first time. That will fix the problem and sync correctly from there on. I'm using the BB Bold 2 (9700) and Outlook 2007.

    Ps. It's not the Facebook app, unless you have it synch with your calendar. The problem is with how the Blackberry calendar processes entries.
    11-05-10 08:07 PM
  21. jonraw's Avatar
    I too have struggled with the duplicate calendar entries, always after a sync or build upgrade. I'm glad to finally know a few reasons why this can happen.

    I have maybe 30-40 birthdays in my calendar and deleting the dupes is usually very tedious. Thanks for the information, everyone.
    11-05-10 11:19 PM
LINK TO POST COPIED TO CLIPBOARD