1. duckduke's Avatar
    Problem is not with my phone.........someone I'm attempting to assist.

    TMobile OS6 Telus Official .461
    BB 9700

    BBMaps is not showing up. I asked him to check servicebooks and he was not finding a Blackberry Maps servicebook.

    So......I had him push servicebooks from TMobile web site.....he did....no BB Maps servicebook.
    He also tried a servicebook request from his phone.....still no servicebook for Blackberry Maps.

    My initial thought was that he did not get the BBMaps box checked when he loaded the Telus OS6...461...........and......that he would have to reinstall OS6 and make sure the box was checked. But, it appears that he does not have a servicebook.

    BBMaps will not work without the servicebook.........correct??

    Trying to figure out which direction to head him in........thanks for any help!!
    03-15-11 09:49 PM
  2. duckduke's Avatar
    Today I suggested he simply try downloading/installing BBMaps directly from mobile.blackberry.com . He had already tried.

    But.....when he goes to Options>Device>Application Management.......he does not see a Blackberry Maps.......he sees a Blackberry Install file.

    I have no clue what this means.
    03-16-11 10:55 PM
  3. Lucky45's Avatar
    Problem is not with my phone.........someone I'm attempting to assist.

    TMobile OS6 Telus Official .461
    BB 9700

    BBMaps is not showing up. I asked him to check servicebooks and he was not finding a Blackberry Maps servicebook.

    So......I had him push servicebooks from TMobile web site.....he did....no BB Maps servicebook.
    He also tried a servicebook request from his phone.....still no servicebook for Blackberry Maps.

    My initial thought was that he did not get the BBMaps box checked when he loaded the Telus OS6...461...........and......that he would have to reinstall OS6 and make sure the box was checked. But, it appears that he does not have a servicebook.

    BBMaps will not work without the servicebook.........correct??

    Trying to figure out which direction to head him in........thanks for any help!!
    Correct - you need the service book in order for BBMaps to work...


    Today I suggested he simply try downloading/installing BBMaps directly from mobile.blackberry.com . He had already tried.
    This site is a bit misleading - the only thing you can download from the Blackberry site is a 'ribbon' to enable the BBMaps icon when blocked by the carrier. The only way to load the BBMaps app is through AppLoader and/or Desktop Manager...

    But.....when he goes to Options>Device>Application Management.......he does not see a Blackberry Maps.......he sees a Blackberry Install file.

    I have no clue what this means.
    If BBMaps doesn't show up in the "Application Management" list then the app isn't loaded on the device. Connect the device to AppLoaded and check BBMaps to load and you should be all set.

    I'm not sure if T Mobile blocks the BBMaps icon like AT&T - if they do then read this post on a little launcher icon you can use instead:
    http://forums.crackberry.com/f152/bb...cher-t-369440/
    Last edited by lucky45; 03-20-11 at 06:28 PM.
    duckduke likes this.
    03-20-11 06:25 PM
  4. duckduke's Avatar
    Thank you very much for taking the time to post this info.

    I received a message from him today........somehow.......I don't know how.......he finally got servicebooks to include BBMaps.

    Obviously........he still did not have BBMaps.

    I gave him some of the .cod files to look to make sure BBMaps in is OS6 folder.

    I suggested he wipe and reinstall OS.........making sure BBMaps was checked on his loader. (overkill but it should work).

    I figured the ribbon was the only thing loading at mobile.blackberry.com. But it was an easy attempt

    I am very familiar with the link you provided......its book marked in my browser. I have not read anywhere about TMobile customers fighting the same issue as AT&T customers with BBMaps. I keep that launcher on my phone but I use QuickLaunch so I rarely use the launcher.

    Again.........I really appreciate you taking the time to post the info. I guess I needed confirmation that I was providing some useful assistance. Thanks again!!
    03-20-11 10:27 PM
LINK TO POST COPIED TO CLIPBOARD