1. Gee2285's Avatar
    hey guys. i'm new to the BB and on BBM i notice at times my messages are delayed. usually i see the check mark wit the lil "D" on it but other times i see a clock icon... stays for a couple minutes and then the checkmark but no "D" on it. my question is what can be the cause for this. is it my service provider?
    12-09-10 08:56 PM
  2. karwilliams's Avatar
    Well a check mark means your device successfully sent the message. If the 'D' doesn't appear, the person you're messaging may have their phone turned off or may be in a call (Verizon/Sprint phones can't receive data while on a call without Wi-Fi).
    12-09-10 09:20 PM
  3. sam81's Avatar
    I have that happen, too, sometimes. It always goes thru eventually so I don't worry too much about it. I figure one of a couple things are responsible for this: either the system is overloaded temporarily, I'm not in an area that can handle data, the person I am bbm'ing with is on the phone or is somewhere that they're not getting a signal. Who knows for sure?
    12-09-10 09:22 PM
  4. Gee2285's Avatar
    oh ok. kool so im guessing it's the system from the provider then. thanks
    12-09-10 09:28 PM
  5. Rootbrian's Avatar
    Might want to give the provider a phone call, or check to see if the data plan is fully setup.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-09-10 10:02 PM
  6. Gee2285's Avatar
    well what I found out is that it's a 2G network and they're currently upgrding to 4G.
    12-10-10 05:30 AM
  7. Rootbrian's Avatar
    well what I found out is that it's a 2G network and they're currently upgrding to 4G.
    It's either LTE or really just 3G.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-10-10 06:03 AM
  8. Gee2285's Avatar
    Well it aint 3G for sure. Lol

    Posted from my CrackBerry at wapforums.crackberry.com
    12-10-10 06:06 AM
LINK TO POST COPIED TO CLIPBOARD