1. noriblue's Avatar
    Hello, I had Blackberry Internet Service for 1 month overseas (south east Asia) but I canceled it (went back to the US).

    A few months later, just yesterday actually, got the Blackberry Unlimited Web from TMOBILE but... some stuff doesn't work

    I have a couple of problems:
    1) My BBM is not working. I tried to send msgs but they weren't delivered. They didn't have the "D" with checkmark on it. I tried to delete my friends from my bbm contact and readd them, but they didn't get my requests.

    2) The internet works, I could browse the internet, but the IMs don't. I keep getting error when trying to login to ym or gtalk.

    3) When I check my status: Manage Connections>>Service Status>> The Blackberry Internet service: NOT CONNECTED. Is this right???

    4)When i go to "Manage Internet Email" it takes me to web browser that list: weather, espn, CNN, facebook, yahoo mail, Tmobile more sites.
    Is this right?

    Steps that I've done:
    1) Hard Reboot.

    2) Register on network using the Host Routing Table.
    (Options>>Advanced Options>>Host Routing Table>> 'Register Now' )
    I got a txt msg from Blackberry said "your handheld has been registered with the wireless network"

    3) Send service book
    I logged into tmobile, under Settings>>Service Books>>send service books
    But I didn't receive any msg from this.
    -----------------------
    From tmobile site:
    Services on <myname>'s line

    In addition to the shared plan and services on this account (detailed above), this line also has the following services:

    BlackBerry Feature Enabler
    BlackBerry Unlimited Web

    Any help will be greatly appreciated. Thanks.
    --------------------------------------------

    OS: 4.6
    BBM 5.0
    Blackberry curve 8900
    Tmobile
    01-16-10 06:11 PM
  2. Artemis68's Avatar
    You had BB service overseas? You need to have your PIN released from that carrier in order to use it on another carrier.

    Call up the last carrier you used your BB with and ask to have the PIN released so you can use BBM elsewhere.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-16-10 08:41 PM
  3. noriblue's Avatar
    I'm on the phone with Tmobile blackberry department, and it seems like everything is OK. She checked my PIN and IMEI and everything is OK.

    They still haven't figure out why my bbm or im is not working.

    01-16-10 09:22 PM
  4. Artemis68's Avatar
    T-Mobile isn't going to do anything about releasing your PIN from the other company. I would contact them first and see what they can do.
    01-16-10 10:39 PM
  5. noriblue's Avatar
    Hi, I used the prepaid blackberry IM plan overseas. No contract. I didn't go to blackberry website and registered it while I was there.

    I had no problem registering the PIN/IMEI on Tmobile site and the customer service didn't tell me if there's any problem with my pin/imei (didn't tell me that it was already registered).

    My internet works, just the BBM and IM didn't.

    4th phonecall: TMobile told me to wait 48 hours then call them back if the IM/BBM still doesnt work.

    Thanks.
    01-16-10 11:06 PM
  6. Artemis68's Avatar
    Okay thanks for clarifying. See, when you say that you used BB overseas with another company, it sounded like you used a BB data service and thus, needed to give your PIN and register. So this wasn't the case.

    You've done everything right so far...perhaps your tmo data plan wasn't provisioned properly? That happened to me once. I got on the TTW EM+ plan. Net worked but no BBM or email. :P I had to call to get them to provision/reset it properly.

    It happens. Good luck.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-17-10 01:11 AM
  7. noriblue's Avatar
    Hi Artemis68, thank you so much for your replies.

    I called TMobile again for the 5th time, asked them about the provisions. And they said the provisions are all correct...

    So then they told me to erase all application data, which I did, and still didn't work. So they're going to send me a new phone (by paying $9.99 shipping/handling).

    From what you said on your last post, it seems that a new phone won't make a difference.

    I'll let you know after I got the phone. It'll take 5-7 business days.

    I was thinking: maybe I should get a new sim card or reset all my plans? (delete data plan then add again)?

    I'm a bit tired for being on the phone all day yesterday and a couple more hours today. I don't know... maybe this new phone will work...
    01-18-10 10:58 PM
  8. Artemis68's Avatar
    I'm not sure if you could "delete" the plan if you're under contract. You could perhaps switch it to an enterprise BB plan for a minute and then switch back. I have a feeling it may not work but you can try it.

    If you have a tmo store nearby, getting a new SIM couldn't hurt. It's free anyway.

    At this point, I'm not sure what's going on. It *could* be the Blackberry but it could also be a network issue. It's hard to tell sometimes. So just try to fix what "could" be causing it and see what happens.

    Best of luck. Let me know what happens.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-19-10 02:10 AM
  9. noriblue's Avatar
    I got my new phone yesterday but the problem existed. Last night was the 7th call. They even told me to go into a TMOBILE store and the Tmobile store employees were pretty much "HUH? what can we do?"

    So I did my own research (all night pretty much). And found this article (see pdf attachment).

    Basically I had this BB feature enabler addon added into my account a while back. So what they supposed to do was to delete it once I signed up for BB data plan (I didn't have BB data plan before).

    So, I called them again and asked to have the feature enabler addon removed and... 30 mnts later, TA-DAAAHH... my bbm, im, etc works.

    So. YAY.
    Last edited by noriblue; 01-28-10 at 08:45 PM.
    01-28-10 08:39 PM
LINK TO POST COPIED TO CLIPBOARD