1. blue_rain's Avatar
    Alright, so heres my problem. I have a blackberry torch 9800 and am on the Bell network. I sent my original phone that I purchased in Jan. 2011 away for servicing a month ago and in return was sent a new phone and received it Tuesday of last week (October 11th). I am in an area where I am unable to receive 3G network at home but I know where to find it for a short period of time. When I received my phone, I automatically connected it to wifi and tried to use BBM, it didnt work. I tried FB and that didnt work either. I rebooted my phone and updated the software and facebook then when I entered the 3G network I updated my app world and my bbm. While on the 3G network I was able to send and receive msgs from BBM but facebook would send me an error saying you are currently on a service plan that does not support this application, please contact your service provider to upgrade your data plan and when I tried to add an email account it says your device had a problem connecting to the server. Today was my 4th phone call to Bell and they are of no help whatsoever. I explained my problems and they start off by saying BBM doesnt work on wifi so the first 3 phone calls I argued black and blue with them but they still kept saying it so during my 4th phone call I didnt put any emphasis on the BBM and told them about my problems while on the 3G network because they dont troubleshoot for wifi problems, you have to contact your internet provider for that and they were not able to help me. I have a service plan of 1GB of data monthly and they said everything should be working, no blocks on my account. I was also transferred to Blackberry and was given a ticket number but they werent able to help either. They kept telling me that they dont support help with wifi either and when I tried calling back after copying down the error messages I would get through and someone would hang up on me constantly. This is very frustrating! I really hope someone has an answer for me!
    10-14-11 05:03 PM
  2. SwitchBeach's Avatar
    Sounds like maybe your replacement device is not properly set up on the BIS.

    Is it possible for you to go somewhere that you can get a strong 3G signal for and extend period (not just for a "short period") and then log in to the Email Settings on the device and make sure that you are properly logged in with the BlackBerry ID and that your emails are set up properly on the BIS?
    10-14-11 10:59 PM
LINK TO POST COPIED TO CLIPBOARD