1. sonjat91's Avatar
    so i have a blackberry curve 8320 and my BBM doesn't work.
    ive tried to download it straight from the blackberry website but it says that "sorry, your device does not meet the system requirements that are needed to support Blackberry Messanger" but i don't understand why..
    does anyone have a clue?
    11-16-09 09:56 AM
  2. rachel0179's Avatar
    Which bbm are you trying to download.. whats your operating system (options, About, 3rd line down)
    11-16-09 09:58 AM
LINK TO POST COPIED TO CLIPBOARD