1. S_herman's Avatar
    So my phone froze yesterday, and when I rebooted it my BBM icon was gone, and it was deleted from my applications.

    I've attempted to download 5.0 but my device software has not been upgraded, and I don't have the ability to upgrade it at this time.

    So I've attempted to use desktop manager and the application loader to re-install the original blackberry messenger. When I enter into the applciation loader it only provides me with a listing of the applciations currently on my device and basically only allows me to remove the software. I've attached a friends phone, and the desktop manager lists all applications, so I'm lost as to what's wrong.

    Any help would be great. Thanks.
    10-19-09 12:45 PM
  2. thinkamp's Avatar
    What OS are you currently running?
    10-19-09 01:04 PM
  3. S_herman's Avatar
    It's a curve 8330 and the OS is 4.3.0.124
    10-19-09 01:15 PM
  4. thinkamp's Avatar
    Well if you have DM running on your PC why can't you just go ahead and upgrade your OS and run BBM 5.0?
    10-19-09 01:16 PM
  5. S_herman's Avatar
    my issue with upgrading to the newer OS, is that I've been told that it resets all of the settings on the phone. As my IT manger is away, I'm worried that upgrading the OS will remove me from the entrprise server. removing the BB connection to my work e-mail/calender.
    10-19-09 01:20 PM
  6. SevereDeceit's Avatar
    You need to be running at least 4.5.0.131 in order to run the new BBM 5.0
    10-19-09 01:21 PM
  7. thinkamp's Avatar
    you should be able to go to: BlackBerry Messenger and download the old 4.3 BBM.
    10-19-09 01:32 PM
  8. S_herman's Avatar
    When I attempt to download it, it always goes to version 5.0. There is no option to DL 4.3.

    It appears that the original OS informaiton wasn't included with the DM. So after downloading the OS info for what was on the curve, I was albe to have access to the additional applications to add the BBM from DM. Thanks for the help all!
    10-19-09 01:41 PM
  9. thinkamp's Avatar
    really because when i first downloaded 5.0 to my bb it said if you are running 4.3 click this link bla bla bla...it should promt your to DL the older bbm.
    10-19-09 01:44 PM
LINK TO POST COPIED TO CLIPBOARD