1. najifa's Avatar
    Hi All,
    I have an Unlocked ATT Torch that i'm using in Saudi Arabia with STC (Aljawal).

    For some reason my BBM would connect and work for a while then disconnect and i would have to turn all connections off then back On to get it to start working again. And it doesnt always work.

    Also, My browser 80% of the time would not work and i'd get the message "Unable to find the requested server".

    I dont think these 2 problems are related because sometimes BBM would work but browser wouldn't and viceversa.


    Any1 know why this is happening and could help? It's getting so frustrating to the point where im thinking of buying another one from here instead.
    03-20-11 09:26 PM
  2. tbrenn's Avatar
    Hi All,
    I have an Unlocked ATT Torch that i'm using in Saudi Arabia with STC (Aljawal).

    For some reason my BBM would connect and work for a while then disconnect and i would have to turn all connections off then back On to get it to start working again. And it doesnt always work.

    Also, My browser 80% of the time would not work and i'd get the message "Unable to find the requested server".

    I dont think these 2 problems are related because sometimes BBM would work but browser wouldn't and viceversa.


    Any1 know why this is happening and could help? It's getting so frustrating to the point where im thinking of buying another one from here instead.

    Do you have a bb data plan (you need BIS)?
    Are you using Wifi at all?
    What OS are you running?
    03-20-11 09:28 PM
  3. najifa's Avatar
    Do you have a bb data plan (you need BIS)?
    Are you using Wifi at all?
    What OS are you running?
    I do have a BB plan. However when i try to log in to BlackBerry Internet Service it wont let me register, i get the msg "Your account is not accessible Via HTML browser, please use your device to access Blackberry internt service". Even though I AM using my device browser.
    I was trying to log in, to maybe be able to send service books.

    I use Wifi when needed.

    I have V6.0.0.246
    03-20-11 09:43 PM
  4. tbrenn's Avatar
    I would recomend updating the OS to the newest one supported by your carrier (even though the phone isd unlocked, you should be able to install your carriers version of the OSY. If you are having trouble accessing your BIS account from your bb, try it on your computer. Push your service books after upgrading the OS.

    If there's still issues you might be able to call your carrier to push you the service books.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-20-11 09:46 PM
  5. najifa's Avatar
    I would recomend updating the OS to the newest one supported by your carrier (even though the phone isd unlocked, you should be able to install your carriers version of the OSY. If you are having trouble accessing your BIS account from your bb, try it on your computer. Push your service books after upgrading the OS.

    If there's still issues you might be able to call your carrier to push you the service books.

    Posted from my CrackBerry at wapforums.crackberry.com
    How do i update the OS to the newest one supported by my carrier? When i check for updates from my phone setup, it tells me there are NO updates.

    I already tried accessing BIS account from my Computer but its the same problem because its an HTML browser.
    03-20-11 09:49 PM
  6. tbrenn's Avatar
    Us.blackberry.com/support/downloads/download_sites.jsp

    Under "Middle East" find your carrier (listed as: (STC Saudi Arabia)

    Select your device

    Download the 6.0.0.862 package to your PC. This will give you OS version 6.0.0.284

    Run the application on the PC to update your BB's OS... Give it a shot, and if not, call your carrier to push the service books...

    Posted from my CrackBerry at wapforums.crackberry.com
    03-20-11 09:58 PM
  7. najifa's Avatar
    Us.blackberry.com/support/downloads/download_sites.jsp

    Under "Middle East" find your carrier (listed as: (STC Saudi Arabia)

    Select your device

    Download the 6.0.0.862 package to your PC. This will give you OS version 6.0.0.284

    Run the application on the PC to update your BB's OS... Give it a shot, and if not, call your carrier to push the service books...

    Posted from my CrackBerry at wapforums.crackberry.com
    How do i install it after downloading?
    03-20-11 10:44 PM
  8. fatih.kurnaz's Avatar
    Hello,
    I've read from news lately, that Saudi Government has banned BlackBerry Messenger and some BiS services..
    Could it be still ?

    Posted from my CrackBerry at wapforums.crackberry.com
    03-21-11 03:28 AM
  9. najifa's Avatar
    No, they were thinking about it. But never did.
    03-21-11 05:02 AM
  10. tbrenn's Avatar
    Run the package that you downloaded on your computer, it should walk you through it step by step...

    Posted from my CrackBerry at wapforums.crackberry.com
    03-21-11 05:16 AM
  11. najifa's Avatar
    Run the package that you downloaded on your computer, it should walk you through it step by step...

    Posted from my CrackBerry at wapforums.crackberry.com
    Ran it, nothing changed
    03-21-11 07:42 AM
  12. tbrenn's Avatar
    Then I would try calling your carrier to troubleshoot any network issues / maybe push new service books, or at least get access to your BIS account and push them yourself?

    Posted from my CrackBerry at wapforums.crackberry.com
    03-21-11 10:40 AM
  13. madoon's Avatar
    have a friend who has upgraded to os 6 on 9700, and was occasionally unable to browse the internet error message was "please use blackberry internet browser".
    everytime he called the company and complain they "re-register" the handset to the network. it has happened a few times when it seem they were facing problems, the issue is gone now. network was VIVA-bahrain
    as others pointed out best method is to call and ask support about the problem. i dont think your phone being a att phone has anything to do with it.
    but i also suggest you upgrade the phone to the newest software.
    03-21-11 07:46 PM
  14. najifa's Avatar
    i got access to my BIS and pushed the service books, i'm still having the same problem.

    When i check for updates through my phone or when connected to dekstop manager it tells me my software is up to date.

    This is driving me insane.
    03-21-11 08:49 PM
  15. tbrenn's Avatar
    Have you tried calling your phone provider?? It could be a netowrk issue on their end ??

    Posted from my CrackBerry at wapforums.crackberry.com
    03-21-11 09:23 PM
  16. tbrenn's Avatar
    BUMP

    OP-> Any Updates
    03-31-11 01:05 PM
  17. Mukhtalif's Avatar
    Hi I'm new here and this my first post. But this issue has driven me crazy.


    The issue is NOT with your device. It's because of the stupid BB system here. Since a full working BIS service has the power to technically "bypasses" internet censorship. Solution? They (apparently) screwed around with RIM and figured that they could allow BBM and email service and not browsing. So instead of accessing BIS browser service your phone will "switch" from BIS to WAP (not sure of the name) and you'd go online with a Saudi IP address instead of a RIM IP address (Thus your connection is filtered/censored).

    Anyway, the switch back and fourth between BIS and WAP is usually slow. Specially on the busy 3G network (the switch is usually faster when you're on 2G).

    I hope I can one day find a hack or something that could get me FULL BIS service instead of this BS service!!
    doconcrackberry likes this.
    04-05-11 06:56 AM
  18. doconcrackberry's Avatar
    Hi Mukhtalif,
    There are two issues with my BB service. (This is my first BB Device 9800)
    I activated STC BB service today and I could promptly use the BB Messenger. BUT....
    1. Tried to launch Facebook and it shows-You are currently on a service plan that does not support this application. If you want to use this application please contact your service provider to upgrade your data plan. Im absolutely new here so I really dont get this?
    2. Tried to activate an account on STC BIS but it wont even on my device sayin its a HTML browser
    Could you please tell me whats happening here?
    06-27-11 12:34 PM
LINK TO POST COPIED TO CLIPBOARD