1. IvPadilla's Avatar
    I'll tell you a story of something that happened me with a new OS install

    My nightmare came true:
    App World icon is missing ._.
    I've searched in the forums, google, etc. And found no solution

    When I upgraded the OS, *almost everything was fine (App World opened, but didn't update apps, the usual problem of "starts the download, but stops and says an error ocurred". I also couldn't update with the browser). When I connected the device to my PC, desktop manager upgraded App World, because it had been downgraded with the OS.

    After the usual reboot, the icon was missing =(

    Yes... It appears under Options-->Device-->Apps, but not on homescreen nor in Universal search. It's NOT hidden.

    All my other apps work fine, for now, I'm updating with desktop manager and BB App World browser plugin (PC website).

    I've tried untill now:
    -Downloading from browser (replace yes and no)
    -Deleted and reinstalled
    -Reinstalled with desktop manager
    -Reinstalled with App.loader
    -Security Wipe and Restore backup

    No sucess =/

    I have this options:
    -OS downgrade
    -BB App World downgrade (can somebody provide me an OTA link please?)
    -Delete cods and reinstall

    I'll accept any comments, tips, solutions (would really prefer this '-'), anything would help.

    Thanks =)

    November 29: Yeeesss!!!
    After downloading an app, I were browsing my files (Rock File Manager) and went to Store-->Blackberry-->App World-->Downloads-->(PIN)-->BlackBerry App World
    And copied one of the cods by error :P (i think it was "net_rim_bb_appworld_lib.cod.rem")
    And then pasted it in the previous folder (the one with the pin number). I deleted it, since i though it might harm the device, and after that, the icon appeared on my homescreen, just where i had it a few days ago before the update :-)

    Problem solved :-)
    Posted from my CrackBerry at wapforums.crackberry.com

    And this, is what happened me so:

    Failed:
    -Unhidding icons
    -Device reset (Software and hardware ones)
    Reinstalling from: Browser, Desktop Manager, AppLoader.exe, JAD files, etc
    -Security wipe and reload
    -New OS

    Worked
    1-Copying one of the cods from Store-->BlackBerry-->App World-->Downloads-->#Pin-->BlackBerry App World
    2-Pasting it on another folder
    3-Deleting the one you pasted (not the original)

    HOPE, this helps you, now I REALLY see how bothering this problem is and I'm happy to have solved it

    Try it, if it works, good for you and keep enjoying app world!

    Posted from my CrackBerry at wapforums.crackberry.com
    Russell Durose likes this.
    11-29-11 11:57 PM
  2. MaNu Chowdary's Avatar
    I didnt understand what u have done!!

    So please tell me in detail...Please so urgent!!
    11-17-12 06:36 AM
  3. neeravkaria's Avatar
    I m not able to find the access to modules the way you said in your thread.
    Indeed i couldn't find the store folder or the app world folder in my phone
    11-29-12 01:14 PM
  4. ettorwe's Avatar
    I have the same issue but with Z10. Any help or suggestion?
    03-04-13 04:30 PM
  5. judy_pk's Avatar
    On your phone go to your browser and type Download BlackBerry App World
    03-17-13 06:06 AM
LINK TO POST COPIED TO CLIPBOARD