1. DenTone's Avatar
    Hi I am a novice here. I am looking to buy this blackberry (8703e) to join a BBM group with my friends who have a Bold 9000, Curve 8330 and Tour... I'm not sure if this BB will be compatible for the BBM they use... Does anyone know? Thanks.
    06-26-10 06:56 PM
  2. tes5884's Avatar
    Hi I am a novice here. I am looking to buy this blackberry (8703e) to join a BBM group with my friends who have a Bold 9000, Curve 8330 and Tour... I'm not sure if this BB will be compatible for the BBM they use... Does anyone know? Thanks.
    For BBM groups you need BBM 5.0 which o don't think is compatible with your device, you can get a 83xx for under a hundred on eBay, that's probably your best bet.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-26-10 09:59 PM
  3. bobo_200_5's Avatar
    i am presently using 8703e with 4.5 and BBM 5.0. I was able to create a group, using my 8703e, and don't see why you couldn't join one. Not sure 100 percent, but give it a shot....can't hurt.
    06-28-10 05:42 PM
  4. HorizonStar's Avatar
    Yes you can. Before I got my Tour, I had a 8703e. I don't remember what version OS I had, but had downloaded the newest BBM after upgrading the OS and was able to use the newest BBM version. Just make sure you upgrade the OS to the best one available for the 8703....4.7 I think.
    06-29-10 02:02 PM
LINK TO POST COPIED TO CLIPBOARD