11-18-17 09:27 PM
87 123 ...
tools
  1. Leszek Lesner's Avatar
    Hi,

    as I wanted TextSecure for my BB10 and my Jolla Device I looked at the sources and found JavaJens version which uses WebSockets instead of GCM.
    As the SMS Verification does not work on the Android Runtime or ACL I patched the source to include a check if an BlackBerry or Jolla device is detected and skip the SMS verification.
    So basically you need to use the Phone/Call verification which works fine.

    You can find JavaJens Sourcecode here: https://github.com/JavaJens/TextSecure
    Update: Version 3.12
    Bugfixes and Speed improvements.
    You can get the APK from here: https://app.box.com/s/qq74upy5om47wy719mj7avxu3j456dds

    If someone knows and has the accounts to convert it to an bar file and put it into BlackBerry World I would be glad
    Last edited by Leszek Lesner; 02-25-16 at 01:38 PM. Reason: Update link to 3.12
    08-01-15 12:02 PM
  2. thejackson5's Avatar
    Is there any way for this to update on itself? The newer version adds animated .gif support and that's a biggie for me.

    Thanks!
    08-09-15 04:34 PM
  3. Leszek Lesner's Avatar
    It needs to be first also be supported by JavaJens version. Then I might create a new apk file.
    08-20-15 11:00 AM
  4. Leszek Lesner's Avatar
    08-24-15 07:00 AM
  5. avivo's Avatar
    Hello,

    since Textsecure merged with Redphone to Signal
    is it possible to get it run on BBOS10.3?

    Otherwise, there are some new Versions on Textsecure.

    Thanks in advance
    11-10-15 05:05 AM
  6. anon(8719892)'s Avatar
    Amazing! Thanks OP.

    Just what I was looking for. Still works the old apps havent been effected by the merging of Red Phone (as yet)
    11-10-15 12:06 PM
  7. avivo's Avatar
    Is there any working redphone apk out there?

    Thats why I am asking. A new working version of Signal would be very nice.
    Encrypted phone calls!

    Posted via CB10
    11-10-15 03:17 PM
  8. anon(8719892)'s Avatar
    No they are all linked to Google services. I got excited just there. I thought this was going to work on my Playbook but I am getting the usual Google Services request.
    11-10-15 03:43 PM
  9. werkregen's Avatar
    There's an experimental apk from a repo I found in the JavaJens issue boards.

    He calls it LibreSignal, it's basically a fork, I didn't check the code (I did send it to an online virus scanner) and I'm using it. Didn't have any problems with it yet and Pebble notifications work with it.
    11-19-15 02:16 PM
  10. avivo's Avatar
    Hello,

    Actually it isnt working. I got the message "This App cannot be installed."



    Posted via CB10
    11-21-15 02:27 AM
  11. werkregen's Avatar
    Hello,

    Actually it isnt working. I got the message "This App cannot be installed."



    Posted via CB10
    Weird. Did you check"allow apps from other sources to be installed?". I just did a reinstall with no problems.

    Posted via CB10
    11-21-15 06:34 PM
  12. avivo's Avatar
    Interesting. Of course other sources are allowed on my device running SW 10.3.2514.
    But I faced this message several Times, when I tried to update Apps from Playstore or Snap.
    Some of those refuse to get updated. I thought it is because they assume AndroidRuntime 5.x or so.
    Never the less, this new Signal version cannot be installed on my Device.
    11-22-15 03:48 AM
  13. Leszek Lesner's Avatar
    Update: 3.3.1 Apk now available

    The new version is necessary to send text messages again.
    The app has been renamed to Signal like the upstream version.

    I was not able to test yet if the encrypted call option works as it needs some days after upgrading before you can use it.

    Get the apk from here:
    https://app.box.com/s/0l48h01j368u43e7shfiwghld4dt9f9b
    werkregen likes this.
    11-22-15 07:49 AM
  14. avivo's Avatar
    Using F-Droid everything works fine.
    Encrypted Phomecalls do so too.

    Posted via CB10
    11-22-15 08:11 AM
  15. Leszek Lesner's Avatar
    Interesting I did not know that it is in F-droid. It needs a special repo I suppose the default ones don't provide it.
    11-22-15 08:14 AM
  16. werkregen's Avatar
    Interesting. Of course other sources are allowed on my device running SW 10.3.2514.
    But I faced this message several Times, when I tried to update Apps from Playstore or Snap.
    Some of those refuse to get updated. I thought it is because they assume AndroidRuntime 5.x or so.
    Never the less, this new Signal version cannot be installed on my Device.
    I don't have snap or google play services, and I never had that error (I sideload about 10 android apps). Maybe google is checking the apk like it does on vanilla Android and reporting it's a rogue app (considering it's a fork of Signal).

    I think you can install using F-droid if you add that dev's repo.

    Posted via CB10
    11-22-15 03:42 PM
  17. werkregen's Avatar
    Using F-Droid everything works fine.
    Encrypted Phomecalls do so too.

    Posted via CB10
    How did you install with f-droid?

    Posted via CB10
    anon(8719892) likes this.
    11-22-15 03:43 PM
  18. darnellkeith's Avatar
    Newest version isn't working for me. I keep getting failed to deliver message.

    Posted via CB10
    11-22-15 10:50 PM
  19. avivo's Avatar
    Phone calls does not work, something like "connection failed"- error.
    I just added the Mirrors provided by you and deleted my old version of Textsecure.

    Posted via CB10
    11-22-15 11:48 PM
  20. werkregen's Avatar
    Phone calls does not work, something like "connection failed"- error.
    I just added the Mirrors provided by you and deleted my old version of Textsecure.

    Posted via CB10
    Phone calls don't work for me either. Maybe calls rely heavily on google play and can't be ported easily to websockets.
    11-23-15 03:15 AM
  21. Leszek Lesner's Avatar
    I heard calls need a few days after upgrading from the older version for the server to allow it.
    Though as I also updated my personal version yesterday I cannot tell you more about it. Though others should get an error message when trying to call you saying not supported

    Posted via CB10
    11-23-15 09:12 AM
  22. anon(8719892)'s Avatar
    not working anymore

    Leszek I have faith in you bro
    Last edited by teknofish; 11-24-15 at 03:37 PM.
    11-24-15 12:16 PM
  23. Leszek Lesner's Avatar
    Working here.
    What does not work for you?

    Posted via CB10
    11-25-15 06:15 AM
  24. anon(8719892)'s Avatar
    Uninstalled and did a fresh install and it's working
    Thanks man!


    ps anyone having issues make sure you have uninstalled any previous installations before you install

    Posted via CB10
    Last edited by teknofish; 12-01-15 at 07:27 AM.
    12-01-15 06:48 AM
  25. immitchell's Avatar
    I keep having Google play services error when I enter my phone number and click "register "

    Posted via CB10
    12-02-15 10:52 PM
87 123 ...

Similar Threads

  1. (PENDING) Unlocked Blackberry Passport with Cases
    By thornburg24 in forum Buy, Sell, Trade - Sold / Archived
    Replies: 15
    Last Post: 08-10-15, 02:25 PM
  2. Which smart watch works great with Z10?
    By Abhishek Jaimini in forum Ask a Question
    Replies: 2
    Last Post: 08-02-15, 04:36 AM
  3. Unable to pair Mi Band with z10
    By SumitC in forum Ask a Question
    Replies: 3
    Last Post: 08-02-15, 02:56 AM
  4. Replies: 1
    Last Post: 08-01-15, 11:21 AM
  5. Replies: 1
    Last Post: 08-01-15, 03:37 AM
LINK TO POST COPIED TO CLIPBOARD