1. ChavaiotH's Avatar
    Downloaded the apk and installed without any problems. Signed in with my origin account and anything works fine.

    Love my Z30.

    Posted via CB10
    11-12-15 01:00 PM
  2. SpideysHero's Avatar
    Is it still working for you? I can't seem to find an apk that works entirely.

    Posted via CB10
    11-20-15 09:38 PM
  3. byex's Avatar
    Downloaded the apk and installed without any problems. Signed in with my origin account and anything works fine.

    Love my Z30.

    Posted via CB10
    Where did you download the apk?
    Can you post a link. Every apk I have tried has failed. Always says needs an update.

    Posted via CB10
    11-20-15 11:06 PM
  4. ChavaiotH's Avatar
    Where did you download the apk?
    Can you post a link. Every apk I have tried has failed. Always says needs an update.

    Posted via CB10
    Here: https://apkmirror.com/apk/electronic...-apk-download/
    Later I find out, that can download the apk's with android phone of my wife (with a free app downloaded from google store) and send them to my z30 over bbm. Works perfect.

    I've created a new thread how to do it the easy way. The CB need some time to post it.
    Last edited by ChavaiotH; 11-24-15 at 06:55 AM.
    11-24-15 02:06 AM
  5. Chris Murphy's Avatar
    That .apk works almost entirely fine. But the Play Base Command button just brings me to a black screen that it hangs in forever. Does this not happen to you?
    11-24-15 07:53 AM
  6. ChavaiotH's Avatar
    That .apk works almost entirely fine. But the Play Base Command button just brings me to a black screen that it hangs in forever. Does this not happen to you?
    No. I can play base command without any problems. Don't forget to login in the game with your origin account. Also anything works fine with the main game (Star Wars battlefront). All the stats, credits and anything else is showing well in the sw companion.
    11-24-15 09:44 AM
  7. Chris Murphy's Avatar
    No. I can play base command without any problems. Don't forget to login in the game with your origin account. Also anything works fine with the main game (Star Wars battlefront). All the stats, credits and anything else is showing well in the sw companion.
    Yes all the stats and every single other feature is working fine and connected to my account. It is just base command that refuses to work. It opens a black screen. The black screen cannot be exited and the app needs to be closed. I have uninstalled, reinstalled, rebooted. No go. This is on a Classic. Maybe I will try loading it on my old Z30 and see if it is a Classic problem.
    11-24-15 11:55 AM
  8. ChavaiotH's Avatar
    Yes all the stats and every single other feature is working fine and connected to my account. It is just base command that refuses to work. It opens a black screen. The black screen cannot be exited and the app needs to be closed. I have uninstalled, reinstalled, rebooted. No go. This is on a Classic. Maybe I will try loading it on my old Z30 and see if it is a Classic problem.
    Yeah, must be the screen resolution problem on classic. Try it on z30. It's older, but the performance is better then on classic.
    11-25-15 01:17 AM
  9. ChavaiotH's Avatar
    The new version 1.05 is out. Anything working.
    12-10-15 06:40 AM

Similar Threads

  1. Replies: 13
    Last Post: 11-13-15, 03:16 AM
  2. Replies: 5
    Last Post: 11-10-15, 03:49 PM
  3. i'll stay with my Passport SE, but Priv can success!
    By luigieagle in forum BlackBerry Priv
    Replies: 3
    Last Post: 11-09-15, 11:43 PM
  4. successful clash of clans village transfer
    By dbslider in forum Android Apps
    Replies: 1
    Last Post: 11-09-15, 05:27 PM
LINK TO POST COPIED TO CLIPBOARD