1. Dealz417's Avatar
    Can android apps currently utilise the NFC on our devices?

    If not does any one know of there is any plans for android apps to get access to the NFC api?

    Posted via CB10
    07-08-13 07:51 AM
  2. Lendo's Avatar
    Do you have a particular app in mind? I'll test it out on 10.2.0.483 for both the Q10 and Z10
    07-19-13 11:06 PM
  3. Steppschuh's Avatar
    BlackBerry Developer page states:

    The following hardware features are currently not supported, and usually do not work with the BlackBerry 10. If your app uses any of these features but you feel that it should still be functional on a BlackBerry 10, before submitting your app to BlackBerry World, fully test it to ensure that your app's usability and functionality are not affected.

    -Bluetooth is not supported (Audio playback through Bluetooth is supported)
    -NFC is not supported
    -Barometer sensor is not supported
    -No support for low-latency audio pipeline (android.hardware.audio.low_latency)
    -No support for 5 or more simultaneous independent touch events (android.hardware.touchscreen.multitouch.jazzhand)
    https://developer.blackberry.com/and..._features.html
    Lendo likes this.
    07-20-13 04:28 AM
  4. Dealz417's Avatar
    Do you have a particular app in mind? I'll test it out on 10.2.0.483 for both the Q10 and Z10
    Yeah the app is called Lastpass which uses NFC with a Yubikey Neo for multi/2-step authentication but because NFC isn't supported I guess the NFC functionality won't be active in the ported app, so I'm not sure how you could test it plus you'd need a Yubikey Neo.

    I guess you could test with any other android port that uses NFC to see if it works in the new runtime in build .483?

    Posted via CB10
    07-20-13 03:14 PM
  5. Lendo's Avatar
    Can't argue with cold hard facts. Guess I won't convert that one LOL
    07-20-13 03:15 PM
  6. Dealz417's Avatar
    But isn't that support referring to the GB runtime?

    I read this...

    The BlackBerry Runtime for Android apps supports Android 4.2.2 (BlackBerry 10.2 Beta) and 2.3.3 applications. API support information for Android 4.2.2 will be available soon.

    The following sections outline Android 2.3.3 features that are not supported by the BlackBerry Runtime for Android apps as well as those which are supported.
    Doesn't that mean that the NFC api could be supported in the JB runtime? Okay, maybe not in .483 as it's an early build still in beta.

    Posted via CB10
    07-20-13 03:23 PM
  7. Steppschuh's Avatar
    Doesn't that mean that the NFC api could be supported in the JB runtime?
    I'm sorry but.. more cold hard facts. Matt W. from the devblog states:

    Q: Are there any new APIs being supported with this release, ie. Bluetooth?
    A: We're focusing on making sure all previously supported features are available and working correctly. Once that's complete, we'll start to look at new API features.
    Sweet Candy! Android Runtime Jelly Bean Beta for BlackBerry 10.2 ęBlackBerry Developer Blog
    07-20-13 05:19 PM
  8. Dealz417's Avatar
    Thanks for the info, I didn't see this blog before but at least there is a chance once new api's are being looked into.

    Posted via CB10
    07-20-13 09:10 PM
  9. Iosif Hamlatzis's Avatar
    Yes I am interested for GalaRing
    02-16-14 12:55 PM
  10. Sniper535i's Avatar
    NFC works with NFC, so a samsung can communicate with a blackberry via NFC. I've tried it with a Note 2 and S3 from my 9900 and Q10

    Posted via CB10
    02-16-14 01:20 PM
  11. Vcek's Avatar
    NFC works with NFC, so a samsung can communicate with a blackberry via NFC. I've tried it with a Note 2 and S3 from my 9900 and Q10

    Posted via CB10
    You've got no clue

    Posted via CB10
    03-02-14 06:38 PM
  12. tiggy00's Avatar
    I'm also interested in finding out of there is a way to make the GalaRing work with the Z10. Currently, when the GalaRing App is launched, it issues a message stating:

    "Warning: Your phone is not NFC-enabled, the program will be shut down!"

    I have NFC enabled prior to launching the program.
    10-03-14 11:27 AM
  13. random11x's Avatar
    This thing says NFC is suppose to work for non secure NFC. I have a Z10 and I just can't get the amiiqo app to work? [the app is on their sites download page not in google store] I realize this might be hard for anyone else to test without the amiiqo but you say something about converting the app. I was hoping you could have a look at the app and maybe try and see why the NFC isnt working. To be clear when I scan my nfc tag the phone reads it as "empty or unsupported" but it seems to be a system wide nfc read and not the app that is giving the error.

    My guess is that the app isnt getting the NFC read properly. And according to the DOC (unsupported_api_jellybean_software) my interpretation is that it should work.
    09-17-15 12:53 PM
  14. fenasi's Avatar
    hello i know it's an old thread but..
    does it support nfc now?
    my android banking app seems it doesn't recognize nfc of my Q5. is there a special setting or something?
    09-23-16 02:22 AM

Similar Threads

  1. Need any free apk from Play Store converted?
    By TamamAlti in forum More for your BlackBerry 10 Phone!
    Replies: 2148
    Last Post: 10-03-15, 05:48 PM
  2. CB app read thread gesture...!
    By lerxster in forum BlackBerry 10 Apps
    Replies: 3
    Last Post: 07-08-13, 04:41 PM
  3. Youtube app
    By JBML007 in forum BlackBerry 10 Apps
    Replies: 5
    Last Post: 07-08-13, 11:54 AM
  4. One Useful App!
    By Carmels in forum BlackBerry 10 Apps
    Replies: 3
    Last Post: 07-08-13, 06:27 AM
  5. Q10 with android app
    By romen95 in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 07-08-13, 01:12 AM
LINK TO POST COPIED TO CLIPBOARD