09-20-14 09:24 AM
74 123
tools
  1. Ruslan Botsyurko's Avatar
    Hi folks!

    I know there's been a few other threads about Rdio, but since we have all the 1055 goodies, let's join our heads together and get it working.
    I've tried to install it from 1mobile market and later even downloaded the APK directly from Google Play, the app starts just fine, but I can't get past the login - after I enter my email and password I get a spinning wheel as if the collection was loading, but it never loads. I know Bla1ze has recommended to use Facebook to sign in, but I got the same results whether I'm logging in directly or via Facebook. In case anybody of you gets it up and running, please share your APK, maybe another version might work.

    Let's get the Rdio app working-img_20131188.png

    P.S.: I know about Forte.fm from BB World, but the app works even worse than Android ports, it's slow, I get authentification errors on every launch and it doesn't allow to save tracks for offline listening.
    11-21-13 07:28 AM
  2. moneytoo's Avatar
    Let's get the Rdio app working-img_00000002.png

    I applied a tiny bit of magic and it's working now ;-) Rdio 2.8.4 fixed.apk

    @Ruslan
    You owe me a beer cause you asked me to take a look at this :-D
    Ruslan Botsyurko and Jake2826 like this.
    11-21-13 11:14 AM
  3. rameok's Avatar
    Not working for me :-( even with downloading the 2.8.4 fixed apk above. I get the same message as the OP. I would LOVE to get this app working on my Z10.
    11-21-13 06:26 PM
  4. The_Adventist's Avatar
    When I download this file it fails to create a certain directory
    11-28-13 08:43 PM
  5. Ruslan Botsyurko's Avatar
    When I download this file it fails to create a certain directory
    How did you figure that out? Did you get any specific error? Maybe it doesn't load because of this problem and creating the directory manually might fix it. Though I guess it won't be that simple... Hope someone will figure it out, the version from moneytoo didn't work on my Z10 either.
    11-29-13 01:26 PM
  6. anon(8246551)'s Avatar
    I would be willing to donate if someone got it to work consistently. Please help!

    Posted via CB10
    12-06-13 06:00 AM
  7. FreddyE's Avatar
    Thanks Moneytoo the apk file you provided worked for me. I was able to sign in using my Rdio username and password.
    12-08-13 12:27 PM
  8. keyboard_cat's Avatar
    You guys should check out MOG if you're in the US. 320 kbit/s mp3 streamed, $5 per month to desktop or 10 for mobile. Seems better than Spotify to me. Anyway the app is working fine on 10.2.1055 right out of the apk



    Posted via CB10
    12-08-13 04:29 PM
  9. spiller's Avatar
    10.2.1.1925 and Rdio v 1.1.0.14 (fix apk) version from moneytoo is working for me. It was hanging before but now trying a week after the .1925 install is working! YMMV ???
    Ruslan Botsyurko likes this.
    01-04-14 07:23 PM
  10. dreondre's Avatar
    It's working for me now as well. The one thing I did different, to free up space on another device, was to reset my mobile sync. Not sure if it was trying to pull down that data..
    I also just updated to Rdio 2.8.9
    01-24-14 06:13 AM
  11. Ruslan Botsyurko's Avatar
    The moneytoo fixed version works now for me too on Z30STA100-2/10.2.1.1925, thanks guys for checking it

    Let's get the Rdio app working-img_20140126_094255.png
    Last edited by Ruslan Botsyurko; 01-26-14 at 08:16 AM.
    01-26-14 02:30 AM
  12. Technophil_ca's Avatar
    I cannot get it to work on my Z30/10.2.1.537. What am I doing wrong ?

    Posted via CB10
    01-29-14 07:14 AM
  13. rameok's Avatar
    The moneytoo version worked for me for a while, now it is not. Tried to upgrade to 2.8.9 version and that version not working either. Darn - it was sure nice to have (for about 8 hours)
    01-29-14 10:03 AM
  14. EauRouge's Avatar
    I downloaded the apk off snap and it works well!
    01-29-14 10:05 AM
  15. Ruslan Botsyurko's Avatar
    What OS version are you guys running? It worked fine for me on the latest leak, but since the official update installed two days ago it stopped working, will freeze after start.
    01-30-14 12:43 PM
  16. rameok's Avatar
    Odd - It was working for me with the leak as well, but now that you mention it, it seems to have stopped working coinciding with the official 10.2.1 update. I'm running the official .537 SW release and .1925 OS release.
    01-31-14 04:28 PM
  17. Ruslan Botsyurko's Avatar
    Yeah, quite a bummer, I even tried sideloading Android Runtime from the leak, but it didn't help :/
    02-01-14 11:25 AM
  18. pmachado's Avatar
    Anyone else have a link to the 'fixed' Rdio apk? The original link doesn't seem to be working for me.

    CB10 by Z30
    02-01-14 11:34 AM
  19. tbro89's Avatar
    I'm now experiencing a new problem... after having the app work then freeze (like everyone else), I discovered that the files are taking up over 4GB of my media card. Upon trying to delete the files, I'm getting the following error:

    "You don't have permission to make changes to this folder. You require permission from Unix User\102251000 to make changes to this folder."

    No matter what I try doing (deleting, moving, changing the owner, etc,) I'm denied access. Anyone have any ideas for a solution? I can't get these folders off my phone now...

    Posted via CB10
    02-01-14 02:51 PM
  20. Ruslan Botsyurko's Avatar
    Anyone else have a link to the 'fixed' Rdio apk? The original link doesn't seem to be working for me.

    CB10 by Z30
    Here's my link from Box
    https://app.box.com/s/miblk6gtlbqyrejp3li9

    Posted via CB10
    02-01-14 06:46 PM
  21. Cobalt232's Avatar
    Hi there

    I looked into Rdio and traced the android runtime with my Blackberry Android Runtime Logger to find out, what's going wrong. I'm not sure what MoneyToo patched though. There are a bunch of error messages and then it somehow crashes.

    If I had a tip that would point me in the right direction I could maybe redo the patch on a newer version.

    You can take a look at the logfile here
    Ruslan Botsyurko likes this.
    02-02-14 02:02 PM
  22. Technophil_ca's Avatar
    Rdio2.8.4fixed is working fine for me since about a week on BlackBerry Z30 OS 10.2.1.537.

    You need to delete the version you are running then reboot and install the fixed version.

    I also installed and logged in Facebook for Android prior to launch the Rdio app. I also changed the sync folder to the device memory.

    After 2 hours of syncing (+/- 6go) it's working very well, even in my car (bluetooth).

    I tried to change the sync folder to the SD card without success. The path I tried was "/ accounts/1000/removable/sdcard"

    Hope it helps !



    Posted via CB10
    02-02-14 03:00 PM
  23. willie44's Avatar
    Rdio started working for me with the 10.2.1.2102 build of the OS. I did download the Rdio app through Snap.
    Ruslan Botsyurko likes this.
    02-18-14 01:50 AM
  24. Ruslan Botsyurko's Avatar
    Rdio started working for me with the 10.2.1.2102 build of the OS. I did download the Rdio app through Snap.
    Thanks for your feedback Willie, now I'm even more eager for the update, but T-Mobile seems to be holding it back in my country, d'oh... Glad to hear the good news anyway

    Posted via CB10
    02-18-14 06:47 AM
  25. Jeffm63's Avatar
    Rdio finally works!
    After the 10.2.1.2102 update the amazon app store Rdio works great! A nice smooth and attractive interface.
    I'm very happy! I've been waiting a while for this one. Forte just wasn't cutting it anymore.
    BlackBerry must have fixed the issues in the android runtime that affected rdio.
    Keep it up!

    Posted via CB10
    Ruslan Botsyurko likes this.
    03-03-14 02:33 PM
74 123

Similar Threads

  1. bbm dosent work
    By samarth sinha in forum BlackBerry Bold Series
    Replies: 2
    Last Post: 12-02-13, 08:52 AM
  2. Anyone got Bitstrips to work on 10.2.1.1055?
    By Captain_L in forum More for your BlackBerry 10 Phone!
    Replies: 7
    Last Post: 11-24-13, 02:45 PM
  3. Has the new leaked OS fixed the reversed gravity sensor ?
    By Blackberrychen in forum BlackBerry 10 OS
    Replies: 16
    Last Post: 11-22-13, 03:21 PM
  4. Can't Open Work Browser and Work Drive in OS 10.2.1.1055.
    By marcelviabb in forum BlackBerry Secure UEM & Productivity Suites
    Replies: 2
    Last Post: 11-21-13, 08:54 AM
  5. Would love to see the Z30 in this test as well.
    By GiantSchnauzer in forum BlackBerry Z30
    Replies: 3
    Last Post: 11-21-13, 07:37 AM
LINK TO POST COPIED TO CLIPBOARD