1. z30_van's Avatar
    Hi All,

    Fitbit posted an update the other day so I updated via Google play store (cobalt for the win!). However when it went to update got the 'unable to install app' error near the end of the install. Tried a few things, with no luck. Anyone else have this issue? Wondering if it is just me?

    Thanks!

    Posted via CB10
    11-19-16 01:19 PM
  2. BigBadWulf's Avatar
    No problem after patching with Cobalt's 1.6, decompile checked and map API set.
    11-19-16 07:28 PM
  3. z30_van's Avatar
    No problem after patching with Cobalt's 1.6, decompile checked and map API set.
    Thanks! Will give that a shot! Previously didn't have to patch.

    Posted via CB10
    11-19-16 07:44 PM
  4. z30_van's Avatar
    No problem after patching with Cobalt's 1.6, decompile checked and map API set.
    Hey BadWulf I patched with 1.6, decompile ect. I can see that the min SDK version is higher than ours which I guess is what changed in this version. It seems to patch fine, but I'm still getting the same 'unable to install app' error. Any idea's.. I'm wondering if some part didn't get uninstalled properly of the last working version. Any ideas on how to clean?

    Thanks for any suggestions!

    Posted via CB10
    11-20-16 07:49 PM
  5. BigBadWulf's Avatar
    Hey BadWulf I patched with 1.6, decompile ect. I can see that the min SDK version is higher than ours which I guess is what changed in this version. It seems to patch fine, but I'm still getting the same 'unable to install app' error. Any idea's.. I'm wondering if some part didn't get uninstalled properly of the last working version. Any ideas on how to clean?

    Thanks for any suggestions!

    Posted via CB10
    I may or may not have unchecked the SDK before recompiling. It's my girlfriend's app, and between us both, one of many I seem to patch regularly.

    Whenever I do delete an app, I delete the cache first. Don't know if it makes any difference. Just personal habit.
    11-20-16 08:18 PM
  6. conite's Avatar
    Hey BadWulf I patched with 1.6, decompile ect. I can see that the min SDK version is higher than ours which I guess is what changed in this version. It seems to patch fine, but I'm still getting the same 'unable to install app' error. Any idea's.. I'm wondering if some part didn't get uninstalled properly of the last working version. Any ideas on how to clean?

    Thanks for any suggestions!

    Posted via CB10
    Delete the previous version of the app first.
    11-20-16 08:41 PM
  7. z30_van's Avatar
    Delete the previous version of the app first.
    Hi Conite,

    When I first tried to update from Google play, the update failed.. at which point the Fitbit app was no longer on the home screen. I'm guessing it was maybe half uninstalled or something of that nature. Tried looking in commander, es file, and Cc cleaner... can't find any reference to fitbit.????

    Posted via CB10
    11-20-16 08:55 PM
  8. z30_van's Avatar
    I may or may not have unchecked the SDK before recompiling. It's my girlfriend's app, and between us both, one of many I seem to patch regularly.

    Whenever I do delete an app, I delete the cache first. Don't know if it makes any difference. Just personal habit.
    Thanks Badwulf will try that and what you msg'd me. Guessing something got messed up when I first tried to update.. now even though no Fitbit icon, maybe it isn't fully deleted?

    Posted via CB10
    11-20-16 08:57 PM
  9. conite's Avatar
    Hi Conite,

    When I first tried to update from Google play, the update failed.. at which point the Fitbit app was no longer on the home screen. I'm guessing it was maybe half uninstalled or something of that nature. Tried looking in commander, es file, and Cc cleaner... can't find any reference to fitbit.????

    Posted via CB10
    What OS are you using? If 10.3.2.2888 or 10.3.2.2876, have you updated your Android Runtime from BBW to fix the uninstall bug?
    11-20-16 09:04 PM
  10. z30_van's Avatar
    What OS are you using? If 10.3.2.2888 or 10.3.2.2876, have you updated your Android Runtime from BBW to fix the uninstall bug?
    Hi Conite,

    Running 2876, had previously applied the art update from bbw. Able to uninstall other apps ect. Think I need to re-apply the art patch?

    Thanks

    Posted via CB10
    11-20-16 09:39 PM
  11. conite's Avatar
    Hi Conite,

    Running 2876, had previously applied the art update from bbw. Able to uninstall other apps ect. Think I need to re-apply the art patch?

    Thanks

    Posted via CB10
    If you already did it, you don't have to again. Can you see the app from inside Play Store app?
    11-20-16 10:00 PM
  12. z30_van's Avatar
    If you already did it, you don't have to again. Can you see the app from inside Play Store app?
    Fitbit doesn't show as installed from inside play store.

    Posted via CB10
    11-20-16 10:52 PM
  13. z30_van's Avatar
    Also just tried installing an older version of the Fitbit apk... same 'unable to install app' error... must be some corrupt or left over files preventing the install. Any ideas short of auto loading?

    Posted via CB10
    11-20-16 11:00 PM
  14. z30_van's Avatar
    Wanted to update with how I fixed this in case it can help someone else! I decided to restore an the older version of Fitbit app from a BlackBerry Link backup. This worked and the Fitbit app was back and functional. I then cleared data and deleted the app. Then I installed the patched version of the latest Fitbit app. Installed no issues!!! So somehow there must have been some corrupt Fitbit files and by restoring the Fitbit app this resolved it.

    Thanks Conite and Badwulf for your suggestions!

    Posted via CB10
    BigBadWulf likes this.
    11-22-16 10:05 PM

Similar Threads

  1. how to save txt message thread?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 11-19-16, 02:04 PM
  2. keyboard doesnt work , i how to i enter password
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 11-19-16, 01:50 PM
  3. Replies: 0
    Last Post: 11-19-16, 11:30 AM
  4. how to copy contacts from q10 to memory card ?
    By muhammed yehia in forum Ask a Question
    Replies: 1
    Last Post: 11-19-16, 10:02 AM
  5. Does the dtek60 need additional software to read emailed documents etc.?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 11-19-16, 07:22 AM
LINK TO POST COPIED TO CLIPBOARD