1. christian-georgescu's Avatar
    For all UNIX / MAC OS X fans out there, suffer no more! The gmaps-apk-patcher is here!

    I have prepared new packages for all platforms (yes, Windows also) of the command line only gmaps-apk-patcher (For WIN GUI version, see here).

    Original threads and more detailed info:
    How to patch Android Apps depending on Google Maps and Google Play Services - (Windows GUI version maintained by cobalt232)
    How to fix any Android app dependent on Google Maps API and make maps working - How all this started
    How to fix Gmail, Ingress and other Google Account dependent apps

    INSTALL INFO

    Please see the README.md from the package before proceeding.

    Make sure you have Java 1.7 or later installed and available on PATH. Open a terminal prompt and type:
    Code:
    java -version
    On Ubuntu / MacOS X make sure you have OPENSSL installed and available on PATH (by default should be) and do the following command before running the tool:
    Code:
    chmod +x patch.sh
    On Ubuntu x64, make sure you run the following command before running the tool:
    Code:
    sudo apt-get install ia32-libs
    SCREENSHOTS
    Windows 8 (x64)
    How to patch Android Apps depending on Google Maps and Google Play Services [terminal versions]-win.png
    OS X Mavericks
    How to patch Android Apps depending on Google Maps and Google Play Services [terminal versions]-osx.png
    Ubuntu 13.10 x64
    How to patch Android Apps depending on Google Maps and Google Play Services [terminal versions]-linux_x64.png
    DOWNLOAD v3.0.1:


    As cobalt232 said in his thread, my fellow patching experts cobalt232, dustmalik, Sally Mack and of course myself will be happy to answer your questions about patching, Google Maps or Google Play Services on Mac OS X, Linux and yes, if you insist, on Windows too.

    Enjoy!
    Last edited by christian-georgescu; 03-24-15 at 07:44 AM. Reason: Updated download links
    03-22-14 03:13 PM
  2. Cobalt232's Avatar
    Christian, that's cool. I'll cross link my tread to this one, so that people can easily find both version of the patcher.

    And a critical information concerning APKTool 2.0.0.9 beta:
    For some reason, it doesn't clean up the processing files in the temp folder. On windows, it produces a lot of garbage in the user\appdata\local\temp folder. I fixed that in the Windows version of the patcher. You may want to check that in your versions.

    Best regards!
    03-22-14 03:38 PM
  3. Bla1ze's Avatar
    Everything I try results in..

    Code:
    Exception in thread "main" java.lang.UnsupportedClassVersionError: brut/apktool/Main : Unsupported major.minor version 51.0
    07-09-14 04:29 PM
  4. Cobalt232's Avatar
    Everything I try results in..

    Code:
    Exception in thread "main" java.lang.UnsupportedClassVersionError: brut/apktool/Main : Unsupported major.minor version 51.0
    Looks like you don't have Java JRE 7 on your machine. If you are on PC, you may want to use the windows GUI version of the patcher. Link is in my signature.
    07-09-14 06:48 PM
  5. rajbir01's Avatar
    Everything I try results in..

    Code:
    Exception in thread "main" java.lang.UnsupportedClassVersionError: brut/apktool/Main : Unsupported major.minor version 51.0
    Bla1ze, do you know if the latest google play file works fine when patched? Or if anyone has shared the file? I'm in the old 4.4.52 patched one.

    Posted via CB10
    07-09-14 07:38 PM
  6. Gheorghe Plapandu's Avatar
    Hi Christian;

    Love this post, I think you know your stuff there; question: can you tell me if the patching issue could work on a blackberry Z3 OS 10.2 for the clash of clans game ?

    I would not want to waste time trying if there's no chance . . .
    02-06-15 01:44 PM
  7. ron_jeremy's Avatar
    I am having some issues trying to install this patch on OSX Yosemite.

    So far, I have:

    • Created a folder and downloaded all files to this folder
    • Downloaded and installed jre-8u31-macosx-x64.dmg
    • Downloaded and installed jdk-8u31-macosx-x64.dmg
    • Downloaded openssl-1.0.2.tar.gz and extracted to its own folder
    • Downloaded gmaps-apk-patcher-v3.01-osx.zip (cannot extract)

    The java check went fine:
    Code:
    Last login: Sat Feb  7 23:06:51 on ttys000
    ArthurAIR13:~ arthur$ java -version
    java version "1.8.0_31"
    Java(TM) SE Runtime Environment (build 1.8.0_31-b13)
    Java HotSpot(TM) 64-Bit Server VM (build 25.31-b07, mixed mode)
    ArthurAIR13:~ arthur$
    Any idea on how to install openssl? I extracted it to a folder (openssl-1.0.2) and terminaled to that folder, but:
    Code:
    ArthurAIR13:openssl-1.0.2 arthur$ chmod +x patch.sh
    chmod: patch.sh: No such file or directory
    ArthurAIR13:openssl-1.0.2 arthur$
    It seems patch.sh does not exist. Searching the folder confirms this.

    Also, when I try to unzip gmaps-apk-patcher-v3.01-osx.zip using Unarchiver I get this error: The contents of filegmaps-apk-patcher-v3.01-osx.zip cannot be extracted with this program.

    I am not an advanced user, and the instructions above aren't exactly crystal clear. Any help would be greatly appreciated.
    SunCoastBBGuy likes this.
    02-08-15 01:42 AM
  8. alaviss's Avatar
    It seems like you misread the instructions. Run chmod inside the patcher directory, not openssl.

    Z10STL100-1/10.3.1.2072
    02-11-15 06:22 AM
  9. badtoyz's Avatar
    download link does not work
    Salsabil likes this.
    02-27-15 04:24 PM
  10. SunCoastBBGuy's Avatar
    The Mac link doesn't work.
    How to patch Android Apps depending on Google Maps and Google Play Services [terminal versions]-404.jpg
    Salsabil likes this.
    03-11-15 10:06 AM
  11. csebibhu's Avatar
    Hi Cobalt,

    Please help me to install UBER CABS, OLA CABS and MERU CABS android APK. I used both Lucky Patcher and GMaps Patcher to Patch the APK. but the apps are not working and error showing as Unfortunately Google Play services Not working. I am using Google Play Services 6.6.03 pre patched by you. The apps use Google maps for booking Taxi services. I am using Google map patched version created by GMaps Patcher and its working. Can you please look into this.....
    03-12-15 04:13 AM
  12. ladeberry's Avatar
    [*]Mac OS X 64-bit - gmaps-apk-patcher-latest-osx.zip

    Download link isnt working , can you help update the link
    03-20-15 07:28 AM
  13. ladeberry's Avatar
    Hey Blaize, can you help re upload the since you likely downloaded it while the link was still active ? thank you.


    Everything I try results in..

    Code:
    Exception in thread "main" java.lang.UnsupportedClassVersionError: brut/apktool/Main : Unsupported major.minor version 51.0
    03-24-15 07:32 AM
  14. ladeberry's Avatar
    I Any help would be greatly appreciated.
    Hello Ron, i assume you downloaded the file successfully, can you please help re upload and provide the link, as the download link is no longer functioning.
    Thank you.
    03-24-15 07:40 AM
  15. christian-georgescu's Avatar

    Download link isnt working , can you help update the link
    I have updated the download links.

    Please note that this thread is old and dead and I no longer offer support for it. You can safely use cobalt's GMaps Patcher or Lucky Patcher. He did a great job and they work pretty well. More info here on the Patching section.

    Regards,
    Christian
    Last edited by christian-georgescu; 03-26-15 at 03:39 AM.
    forbid3n likes this.
    03-24-15 07:47 AM
  16. ladeberry's Avatar
    Thank you so much, Cobalt doesnt have an Mac version.

    I have updated the download links.

    Please note that this thread is old and dead and I no longer offer support for it. You can safely user cobalt's GMaps Patcher or Lucky Patcher. He did a great job and they work pretty well. More info here on the Patching section.

    Regards,
    Christian
    Salsabil likes this.
    03-26-15 02:35 AM
  17. Manish Bhatia2's Avatar
    Hello,
    Want one quick help on installing Google Play Services.
    I have installed google play store but when installing google play services it says getting initialised and then closes abrupty.
    In play store also its not showing under installed apps.
    Please suggest workaround for that.
    I am on Z10 with BB 10.3
    04-16-15 03:51 AM
  18. codestr0m's Avatar
    gmaps-apk-patcher-v3.0.1-linux_x64 fails - details below
    -------
    Distributor ID: openSUSE project
    Description: openSUSE 13.2 (Harlequin) (x86_64)
    Release: 13.2
    Codename: Harlequin

    This was tested with both JDK7-sun and JDK8 (system default)
    java -version
    java version "1.7.0_51"
    Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
    Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)

    /usr/lib64/jvm/jre-1.8.0/bin/java -version
    openjdk version "1.8.0_40"
    OpenJDK Runtime Environment (build 1.8.0_40-b10)
    OpenJDK 64-Bit Server VM (build 25.40-b14, mixed mode)

    Both produced the same effect

    [DECOMPILING APK]
    I: Using Apktool 2.0.0-Beta9 on com.supercell.clashofclans.apk
    I: Loading resource table...
    Exception in thread "main" brut.androlib.AndrolibException: Could not decode arsc file
    at brut.androlib.res.decoder.ARSCDecoder.decode(ARSCD ecoder.java:54)
    at brut.androlib.res.AndrolibResources.getResPackages FromApk(AndrolibResources.java:604)
    at brut.androlib.res.AndrolibResources.loadMainPkg(An drolibResources.java:74)
    at brut.androlib.res.AndrolibResources.getResTable(An drolibResources.java:66)
    at brut.androlib.Androlib.getResTable(Androlib.java:4 9)
    at brut.androlib.ApkDecoder.decode(ApkDecoder.java:93 )
    at brut.apktool.Main.cmdDecode(Main.java:169)
    at brut.apktool.Main.main(Main.java:85)
    Caused by: java.io.IOException: Expected: 0x001c0001, got: 0x00000000
    at brut.util.ExtDataInput.skipCheckInt(ExtDataInput.j ava:48)
    at brut.androlib.res.decoder.StringBlock.read(StringB lock.java:43)
    at brut.androlib.res.decoder.ARSCDecoder.readPackage( ARSCDecoder.java:95)
    at brut.androlib.res.decoder.ARSCDecoder.readTable(AR SCDecoder.java:81)
    at brut.androlib.res.decoder.ARSCDecoder.decode(ARSCD ecoder.java:49)
    ... 7 more
    Unable to decompile /home/asura/Downloads/gmaps-apk-patcher-v3.0.1-linux_x64/add_apk_here/com.supercell.clashofclans.apk.
    [CLEANING UP]
    (Done)

    [FINISHED]
    04-27-15 06:31 AM
  19. dileep021's Avatar
    Please help.

    Java: java version "1.7.0_67"
    Java(TM) SE Runtime Environment (build 1.7.0_67-b01)
    Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

    OS: Mac OSX 10.10.3

    [DECOMPILING APK]
    I: Using Apktool 2.0.0-Beta9 on com.olacabs.customer-30303.apk
    I: Loading resource table...
    Exception in thread "main" brut.androlib.AndrolibException: Could not decode arsc file
    at brut.androlib.res.decoder.ARSCDecoder.decode(ARSCD ecoder.java:54)
    at brut.androlib.res.AndrolibResources.getResPackages FromApk(AndrolibResources.java:604)
    at brut.androlib.res.AndrolibResources.loadMainPkg(An drolibResources.java:74)
    at brut.androlib.res.AndrolibResources.getResTable(An drolibResources.java:66)
    at brut.androlib.Androlib.getResTable(Androlib.java:4 9)
    at brut.androlib.ApkDecoder.decode(ApkDecoder.java:93 )
    at brut.apktool.Main.cmdDecode(Main.java:169)
    at brut.apktool.Main.main(Main.java:85)
    Caused by: java.io.IOException: Expected: 0x001c0001, got: 0x00000000
    at brut.util.ExtDataInput.skipCheckInt(ExtDataInput.j ava:48)
    at brut.androlib.res.decoder.StringBlock.read(StringB lock.java:43)
    at brut.androlib.res.decoder.ARSCDecoder.readPackage( ARSCDecoder.java:95)
    at brut.androlib.res.decoder.ARSCDecoder.readTable(AR SCDecoder.java:81)
    at brut.androlib.res.decoder.ARSCDecoder.decode(ARSCD ecoder.java:49)
    ... 7 more
    Unable to decompile /Users/dileep/Downloads/gmaps-apk-patcher-v3.0.1-osx/add_apk_here/com.olacabs.customer-30303.apk.
    [CLEANING UP]
    (Done)

    [FINISHED]
    05-17-15 09:39 AM
  20. alaviss's Avatar
    This patched is no longer being maintained. Please use Cobalt's GMaps Patcher instead

    Z10STL100-1/10.3.2.500
    05-17-15 10:12 AM
  21. Salsabil's Avatar
    Hello every one!
    First of all thank you very much for sharing such valuable information.
    I can't download the maps apk patcher for OS X though. The link isn't working any more. Does anyone have an available link to share ?
    Thank you by advance
    10-04-15 08:48 AM
  22. Julian Shaw's Avatar
    Check if patched ask YouTube works embedded


    Posted via CB10
    10-05-15 09:14 PM
  23. BBerrylife's Avatar
    Hey thanks for the good work!

    The link for Mac is no longer functional any ideas on where I can get this??

    Thanks
    10-23-15 09:04 PM
  24. JCMM's Avatar
    Hey thanks for the good work!

    The link for Mac is no longer functional any ideas on where I can get this??

    Thanks
    Need it too
    06-10-16 01:52 PM

Similar Threads

  1. Z10 trying to move up to Z30 on AT&T
    By abdalla889 in forum BlackBerry Z30
    Replies: 15
    Last Post: 04-24-14, 10:29 AM
  2. Z10 keeps dropping to GSM
    By nick944 in forum General Carrier Discussion
    Replies: 5
    Last Post: 04-04-14, 07:52 AM
  3. (10.2 and microphone issue)
    By bbryS in forum General BlackBerry News, Discussion & Rumors
    Replies: 4
    Last Post: 03-28-14, 03:40 AM
  4. Mobile hotspot "temporary network problem" on sprint
    By 9of13 in forum BlackBerry Q10
    Replies: 2
    Last Post: 03-22-14, 09:00 PM
  5. USB power on PlayBook question
    By tomorrowsphere in forum BlackBerry PlayBook
    Replies: 3
    Last Post: 03-22-14, 08:41 PM
LINK TO POST COPIED TO CLIPBOARD