03-24-19 02:56 AM
4,042 ... 7891011 ...
tools
  1. Sally Mack's Avatar
    A new version of the patcher (v0.6) is available!

    Changelog:
    • New: Patcher now removes Maps dependent permission signatures from AndroidManifest (Yelp patch)

    The original post has been updated with a new downloadlink.
    Just tested the new version with yelp and transit app... those 2 lines you said to remove still exist in v.0.6

    After some more testing:
    1. The line with google maps signature gets removed by the patcher.
    2. The C2DM line does not get removed by the patcher. (couldn't we just remove any line with "protectionLevel:signature"? Or get rid of the protectionLevel piece?)
    3. Now with your patched version of yelp I don't even get a gps lock with google maps running in the background! (if it makes any difference I'm running maps 6.14.4.2). This may just be my device though, so let's see what everyone else reports.
    Last edited by Sally Mack; 04-06-14 at 06:20 PM.
    04-06-14 05:35 PM
  2. Sally Mack's Avatar
    I tried a patch for Google maps (v7.7) using GMAPS Patcher. Still doesn't allow me to log on.

    Posted via CB10
    To log into google maps 7+, use this post as a reference (link wont bring you to the right post in the cb 10 app...open link with browser)
    How to patch Android Apps depending on Google Maps and Google Play Services - Page 5 - BlackBerry Forums at CrackBerry.com
    04-06-14 05:50 PM
  3. VLinSD's Avatar
    Using version 0.6, I tried to patch PayPal and received: Error: Decompilation of package com.paypal.android.p2pmobile-48 failed, aborting. I tried with Decompile and without, same error. I noticed from the Cobalt's original post that PayPal was patched successfully. Is there a trick I'm missing?

    I used the latest APK from SNAP, version 5.4.2.

    Thanks in advance.

    EDIT: nevermind, it worked after I closed and opened the patcher. Realized this after I got the same error trying to patch Yelp.
    Last edited by VLinSD; 04-06-14 at 08:58 PM.
    04-06-14 08:23 PM
  4. Sally Mack's Avatar
    Using version 0.6, I tried to patch PayPal and received: Error: Decompilation of package com.paypal.android.p2pmobile-48 failed, aborting. I tried with Decompile and without, same error. I noticed from the Cobalt's original post that PayPal was patched successfully. Is there a trick I'm missing?

    I used the latest APK from SNAP, version 5.4.2.

    Thanks in advance.

    EDIT: nevermind, it worked after I closed and opened the patcher. Realized this after I got the same error trying to patch Yelp.
    I sometimes get that random error as well. It doesn't even get into the decompiling process when I run it in debug mode, so it's not the apk or anything. It's tough to reproduce, so I haven't been able to submit anything of any use to cobalt.
    04-06-14 09:44 PM
  5. Cobalt232's Avatar
    Just tested the new version with yelp and transit app... those 2 lines you said to remove still exist in v.0.6

    After some more testing:
    1. The line with google maps signature gets removed by the patcher.
    2. The C2DM line does not get removed by the patcher. (couldn't we just remove any line with "protectionLevel:signature"? Or get rid of the protectionLevel piece?)
    3. Now with your patched version of yelp I don't even get a gps lock with google maps running in the background! (if it makes any difference I'm running maps 6.14.4.2). This may just be my device though, so let's see what everyone else reports.
    Thanks for reporting back. I did not remove the C2DM line by intention as I was sure It has no effect, but maybe I should retest that

    I tried to hunt down that decompiling bug for a while, as I also get it from time to time. I believe that the error occures when there is an open file somewhere in notepad (eg AndroidManifest). The file subsystem then somehow locks the folder and it can not be written.

    APKTool has a special behaviour when decompiling files. It first decompile content to user\local\temp folder and then copies the extracted content to the target destination (in our case \tmp). That's why you see the first part decompiling. Then, when trying to copy the files to tmp\folder it fails because the folder seems to be locked.

    My advice for now:

    1. Close all open files (Manifest, smali) in \tmp folder before trying to decompile new apk's
    2. If you get the error, just close the patcher
    04-07-14 01:16 AM
  6. Cobalt232's Avatar
    Dear donators!

    I just looked into my paypal account and saw that some of you dropped by and left a few $. This is what I love about the Blackberry Community. You give and people give back.

    So thank you so much for supporting my work!
    VLinSD and tryfe like this.
    04-07-14 06:41 AM
  7. Cobalt232's Avatar
    There is a new version of the patcher available (v0.6.1)

    Changelog:
    - Fix: Reworked cleanup function, the \tmp folder should not lock anymore (resulted in decompilation error of APK's)

    The original post has been updated with the new downloadlink.
    VLinSD and tryfe like this.
    04-08-14 04:47 PM
  8. geenaxion's Avatar
    Can someone patch the updated google play services?

    @geenaxion Keepin' it Chill Z10 (10.2.1.2228) BB10Store on Aptoide Subscribe "Dance for Life" C0029D483
    04-10-14 09:06 AM
  9. mathking606's Avatar
    So does quiz up not even rebuild. It keeps failing to rebuild for me
    04-10-14 07:21 PM
  10. WWBlondieDo's Avatar
    So does quiz up not even rebuild. It keeps failing to rebuild for me
    You can't log into QuizUp, even if you get it patched.

    Posted via CB10
    mathking606 likes this.
    04-10-14 07:56 PM
  11. oesje's Avatar
    Thank you so much for your work!

    I tried using the patcher to get Roamler to work, but have not succeeded so far. The patchers says it has nothing to patch. But an in-app part says that google play services are required. I have JRE 7, and I have the patcher on C:..

    This is the apk: Download Roamler,Roamler 1.2.8 Download | 1mobile.com
    04-11-14 06:09 AM
  12. Cobalt232's Avatar
    Thank you so much for your work!

    I tried using the patcher to get Roamler to work, but have not succeeded so far. The patchers says it has nothing to patch. But an in-app part says that google play services are required. I have JRE 7, and I have the patcher on C:..
    Not sure what causes the problem. I patched it with 0.6.1 and it worked. You'll find the patched APK file below. Please also install com.google.android.gms.apk on your device. The file is in the \lib folder of the patcher.

    Download Roamler patched

    Hope it works.
    04-11-14 06:56 AM
  13. C_McD's Avatar
    Might this solve the problem with Realtor.com app and RVAHomes app?

    Posted via CB10
    04-11-14 07:51 AM
  14. oesje's Avatar
    Thanks, I'll give it a go tonight

    Posted via CB10
    04-11-14 08:41 AM
  15. Cobalt232's Avatar
    Might this solve the problem with Realtor.com app and RVAHomes app?

    Posted via CB10
    Realtor uses Google Maps API v1 and v2 AND it uses Maps permissions. The patcher removed all dependencies. To run correctly, it requires installation of com.google.android.gms.apk. The file can be found in the \lib folder of the patcher.

    Did not try RVAHomes.

    Get Realtor patched here

    How to patch Android Apps depending on Google Maps and Google Play Services-img_20140411_154534.png
    04-11-14 08:49 AM
  16. SubbuTvl's Avatar
    Hi Cobalt, I used your 6.1 tool to patch latest gas buddy app on Z30. For some reason it crashed. Can you pls see, why it crashes.
    Both original and patched ask is here.
    Thanks for the help.


    https://dl-web.dropbox.com/get/gbis....OdfK-6ovDwSKNg

    https://dl-web.dropbox.com/get/gbis...._gI9n8hOtKqmJw

    Posted via awesome Z30 thru CB10
    04-11-14 10:21 AM
  17. oesje's Avatar
    Thanks! I can now see the map. Unfortunately, no locations, but I at least a big step closer to getting Roamler up and running. Big thank you!

    Posted via CB10
    04-11-14 10:31 AM
  18. atisvt99's Avatar
    So I downloaded the app (and sent a little $ via the donate button ) and ran it against the most recent APK for the Uber (taxi service) app. The patch seemed to work, and the app will now launch on my phone - but it still glitchy. Is it safe to assume that this neat little app of your is only to get the 'maps' portion working on the device? I also copied the 'com.google.android.gms.apk' file out of the 'output' folder and not the 'lib' folder onto my phone and ran it first... It's odd, but when I run the Uber app on my device, I always get an error that the Google Play Service has crashed?

    Anyways, keep up the good work fellas...

    - justin
    04-11-14 11:03 AM
  19. kfroese's Avatar
    Hi Cobalt, I used your 6.1 tool to patch latest gas buddy app on Z30. For some reason it crashed. Can you pls see, why it crashes.
    Both original and patched ask is here.
    Thanks for the help.

    Posted via awesome Z30 thru CB10
    Why not use the native, Built-For-Blackberry version? It would also let developers know we want and use native apps.

    Q10SQN100-1/10.2.1.2947
    04-11-14 11:05 AM
  20. Sally Mack's Avatar
    So I downloaded the app (and sent a little $ via the donate button ) and ran it against the most recent APK for the Uber (taxi service) app. The patch seemed to work, and the app will now launch on my phone - but it still glitchy. Is it safe to assume that this neat little app of your is only to get the 'maps' portion working on the device? I also copied the 'com.google.android.gms.apk' file out of the 'output' folder and not the 'lib' folder onto my phone and ran it first... It's odd, but when I run the Uber app on my device, I always get an error that the Google Play Service has crashed?

    Anyways, keep up the good work fellas...

    - justin
    I use uber, and it works quite well. The google play services error shouldn't occur of you installed cobalt's com.google.android.gms.apk. I'd say uninstall google play services, restart, then reinstall it again, and try uber then.
    04-11-14 11:11 AM
  21. SubbuTvl's Avatar
    Why not use the native, Built-For-Blackberry version? It would also let developers know we want and use native apps.

    Q10SQN100-1/10.2.1.2947
    That one gave the map view. Something I used to it with my old android device.
    Just downloaded native version. Looks nice. Will use it.

    Posted via awesome Z30 thru CB10
    04-11-14 12:29 PM
  22. WWBlondieDo's Avatar
    So I downloaded the app (and sent a little $ via the donate button ) and ran it against the most recent APK for the Uber (taxi service) app. The patch seemed to work, and the app will now launch on my phone - but it still glitchy. Is it safe to assume that this neat little app of your is only to get the 'maps' portion working on the device? I also copied the 'com.google.android.gms.apk' file out of the 'output' folder and not the 'lib' folder onto my phone and ran it first... It's odd, but when I run the Uber app on my device, I always get an error that the Google Play Service has crashed?

    Anyways, keep up the good work fellas...

    - justin
    No need to patch Uber - it works perfectly straight from Snap on my Z10 running 10.2.1.2947. :-)

    Posted via CB10
    04-11-14 12:47 PM
  23. atisvt99's Avatar
    No need to patch Uber - it works perfectly straight from Snap on my Z10 running 10.2.1.2947. :-)
    Hmm... I didn't have the same luck with a Q10 or my Z30. Let me try to remove/reinstall the play service and go from there. ?
    04-11-14 12:57 PM
  24. inked18's Avatar
    Anyone want to try patching Family Guy: The Quest For Stuff? I'm at work so can't do it right now if anyone has the time let me know how it goes! Family Guy: The Quest For Stuff Apk - Download Here | Techbeasts
    04-11-14 02:39 PM
  25. don_poky's Avatar
    Can someone share the patched version of Quizup apk?

    Posted via CB10
    04-12-14 01:23 AM
4,042 ... 7891011 ...

Similar Threads

  1. how do you clean install a BB10 device using Link?
    By gameson in forum BlackBerry 10 OS
    Replies: 14
    Last Post: 04-01-15, 07:54 AM
  2. Android Apps no Longer Working? Candy Crush?
    By raxamillion in forum More for your BlackBerry 10 Phone!
    Replies: 41
    Last Post: 05-05-14, 04:04 AM
  3. Best Remote desktop App?
    By alejandrohn5 in forum BlackBerry Z10
    Replies: 7
    Last Post: 04-01-14, 11:16 PM
  4. Can DLNA Rendering be Enabled by an APP?
    By Cynycl in forum BlackBerry PlayBook
    Replies: 4
    Last Post: 03-15-14, 02:25 PM
  5. Question about 10.2 and sim.
    By Watcher777 in forum BlackBerry Z10
    Replies: 1
    Last Post: 03-14-14, 03:00 PM
LINK TO POST COPIED TO CLIPBOARD