03-24-19 02:56 AM
4,042 ... 4647484950 ...
tools
  1. MichaelBberry's Avatar
    I have found .apk for uber, lyft, google play that are on this thread and others that are patched- these give me the 'failure 500 'Package-Id'.
    If I could solve this, it would be easiest- I dont know if my way of loading them doesn't work or if I missed a crucial step. My goal is to have Uber and Lyft functioning.

    If I can't just load them and be done with it, I guess I should get the apk's I have downloaded from Snap and patch them myself? I don't have snap set to do anything (I haven't read as much about it, it was just the only aspect of this process I could successfully download). But the apps do download and work but with the expected maps failures.

    Are you able to give me working patched links or clear instructions on how to solve this?
    (I have tried to read, I'm sorry for my questions redundancy, I've read enough to know how much it bothers you lol)
    Is the chrome app I've been using the issue? Do you know the reason I'd have that error message every time? Have I missed procedure needed for the errors not to occur? Thank you so much for taking the time to help me. I've spent the past 2 days and trying to figure this out.
    BB4matt likes this.
    09-06-14 09:31 PM
  2. MichaelBberry's Avatar
    I have found .apk for uber, lyft, google play that are on this thread and others that are patched- these give me the 'failure 500 'Package-Id'.
    If I could solve this, it would be easiest- I dont know if my way of loading them doesn't work or if I missed a crucial step. My goal is to have Uber and Lyft functioning.

    If I can't just load them and be done with it, I guess I should get the apk's I have downloaded from Snap and patch them myself? I don't have snap set to do anything (I haven't read as much about it, it was just the only aspect of this process I could successfully download). But the apps do download and work but with the expected maps failures.

    Are you able to give me working patched links or clear instructions on how to solve this?
    (I have tried to read, I'm sorry for my questions redundancy, I've read enough to know how much it bothers you lol)
    Is the chrome app I've been using the issue? Do you know the reason I'd have that error message every time? Have I missed procedure needed for the errors not to occur? Thank you so much for taking the time to help me. I've spent the past 2 days and trying to figure this out.
    09-06-14 09:31 PM
  3. jzajac's Avatar
    I have found .apk for uber, lyft, google play that are on this thread and others that are patched- these give me the 'failure 500 'Package-Id'.
    If I could solve this, it would be easiest- I dont know if my way of loading them doesn't work or if I missed a crucial step. My goal is to have Uber and Lyft functioning.

    If I can't just load them and be done with it, I guess I should get the apk's I have downloaded from Snap and patch them myself? I don't have snap set to do anything (I haven't read as much about it, it was just the only aspect of this process I could successfully download). But the apps do download and work but with the expected maps failures.

    Are you able to give me working patched links or clear instructions on how to solve this?
    (I have tried to read, I'm sorry for my questions redundancy, I've read enough to know how much it bothers you lol)
    Is the chrome app I've been using the issue? Do you know the reason I'd have that error message every time? Have I missed procedure needed for the errors not to occur? Thank you so much for taking the time to help me. I've spent the past 2 days and trying to figure this out.
    No problem and no need to apologize. This might be a long one, so it's my turn to apologize... What I would do is delete any of the apps in question from your device and then do the double volume button reset to help clear anything out. Then, open Snap and swipe down from the top to go to settings, and where it says "post install behavior" set it to move apk and tap on choose folder to pick where the apk's will save. I created a folder on my memory card called apk files for everything to keep it nice and easy. Then download and install from Snap the apps which will give you the apk files saved on your phone. Delete the actual apps again, then attach your device to your computer and open the windows patcher from this thread. When the computer recognized your device as attached and it shows up as an accessible drive, locate the apks you need to patch, and just drag and drop into the indicated field on the windows patcher. Make it easy on yourself and click on paths in the patcher and check on the option to automatically move the patched file back to your device (hit browse and find the same folder you are moving the apk from so the patched file goes back to the same place and you know where to find it). Then hit analyze and let the patcher do it's thing. Once it tells you what needs to be patched hit the button to proceed and when everything is done the patched file is back on your phone. Do this for each apk as you can only patch one at a time. Finally, disconnect the device and navigate to where the patched apks are located and tap the patched file name. The install screen will come up, tap install and before you know it a patched apk has been installed for you to enjoy. Once this is done, feel free to delete the unpatched apk file but I would recommend holding on to your patched file until after you can repeat this process with an updated version of the app just in case an update doesn't work so you at least have the last working patched version ready to go.
    MichaelBberry and motec bb like this.
    09-06-14 10:07 PM
  4. jzajac's Avatar
    For what it's worth, and I'm not saying it will be the case with these two apps you're asking about, but there will be times where patching the apk still will not get the app working on your device (see: Quiz Up). Despite your best efforts, every now and then things just won't work out. Sometimes these things happen. Good luck patching!
    09-06-14 10:16 PM
  5. MichaelBberry's Avatar
    Thank you so much for your help! It worked perfectly.
    09-07-14 12:14 AM
  6. jzajac's Avatar
    Thank you so much for your help! It worked perfectly.
    Happy to help, enjoy!

    Posted via CB10
    Cobalt232 likes this.
    09-07-14 01:06 AM
  7. svelt's Avatar
    Another case of "if it ain't broke, don't fix it". I had a patched version of Youtube installed (5738) which was working fine, but I decided to patch the latest version (59013) to see if that would work. Gave me the usual "needs google play services" message so I delete it and reinstall the patched 5738 version again, but lo and behold... it now also gives me the same message when it didn't before I tried the newer version!

    Did I break something by uninstalling the old working patched Youtube and installing a new patched Youtube? Does anyone know the steps I can take to revert this process?
    09-07-14 12:48 PM
  8. Cobalt232's Avatar
    As far as I can remember youtube always had to be patched. Are you sure that it worked without being patched?
    09-07-14 01:48 PM
  9. kye2000's Avatar
    As far as I can remember youtube always had to be patched. Are you sure that it worked without being patched?
    Does the latest Youtube work with a patch?

    Posted via my Z30 running 10.3.0.1xxx
    09-07-14 03:41 PM
  10. svelt's Avatar
    As far as I can remember youtube always had to be patched. Are you sure that it worked without being patched?
    sorry, what i meant to say was I had a patched .5738 version of Youtube working, which I removed and patched the latest version of youtube (59013) with. That didn't work, so I went back and reinstalled the .5738 patched version but that also suddenly stopped working... do I need to reinstall Google services to "reset" something to get it working again? Everything else that requires Google services patching (i.e. Groupon) still works on my phone however.
    BB4matt likes this.
    09-07-14 04:09 PM
  11. Cobalt232's Avatar
    sorry, what i meant to say was I had a patched .5738 version of Youtube working, which I removed and patched the latest version of youtube (59013) with. That didn't work, so I went back and reinstalled the .5738 patched version but that also suddenly stopped working... do I need to reinstall Google services to "reset" something to get it working again? Everything else that requires Google services patching (i.e. Groupon) still works on my phone however.
    No special actions required on Google Play services side. But I downloaded the latest version and will quickly look into it.
    09-07-14 05:00 PM
  12. Cobalt232's Avatar
    Just patched it with GMaps Patcher v1.0.1, option decompile without resources set. Nothing special, worked right away.

    Youtube 5.9.4.9-patched
    09-07-14 05:09 PM
  13. svelt's Avatar
    Worked perfectly, thanks! I just have made a mistake along the way.
    09-07-14 06:00 PM
  14. kye2000's Avatar
    Thanks cobalt

    Posted via my Z30 running 10.3.0.1xxx
    09-07-14 07:08 PM
  15. teostar's Avatar
    Just patched it with GMaps Patcher v1.0.1, option decompile without resources set. Nothing special, worked right away.

    Youtube 5.9.4.9-patched
    Installed this apk but it does not load or anything. Just the spinning cursor. Eventually a an error pops up. But nothing ever loads.
    See pix below...
    How to patch Android Apps depending on Google Maps and Google Play Services-img_20140907_200940.png

    How to patch Android Apps depending on Google Maps and Google Play Services-img_20140907_200958.png

    Posted via CB10
    09-07-14 08:11 PM
  16. teostar's Avatar
    Installed this apk but it does not load or anything. Just the spinning cursor. Eventually a an error pops up. But nothing ever loads.
    See pix below...
    Click image for larger version. 

Name:	IMG_20140907_200940.png 
Views:	2108 
Size:	17.6 KB 
ID:	296449

    Click image for larger version. 

Name:	IMG_20140907_200958.png 
Views:	2111 
Size:	15.8 KB 
ID:	296450

    Posted via CB10
    Scrap that. I only had the login apk installed, I installed the play services apk, now it loads. Just can't sign in to my account but this is fine.

    Posted via CB10
    09-07-14 08:24 PM
  17. sca5033's Avatar
    I recently was upgraded from a BBerry Bold to a Q10 for work. I'm an avid user of custom roms/apps/mods for Android. I am going to have fun learning the ropes here. Thank you to all those who have contributed before!

    Mine is a Verizon Q10 on 10.2.1.2976 (I understand other versions are probably on a newer build) if that matters.

    There are two apps I would particularly like to use, Google Play Music and Google Maps. As I have an Android, I tried extracting the Music, Maps, Play Store, and Play Services apks from my device, running them thru the patcher, and installing them on the Q10. I am unsure of what the Google Login Service apk as I've never encountered it before. I wanted to do it this way so I could have the newest versions of each app. This method didn't work. The Play Store apk failed to patch because Android(Something).XML wasn't present. The other's patched successfully. After installing the 3 patched apps and unpatched Play Store, Google Maps force closes upon opening, and Google Music is unable to be logged into.

    In the interest of just getting something working, I chose to download the Play Store, Login Service, and Music pre-patched apks found in this thread. This method got Music up and running. Maps can be downloaded and used with Snap, however it cannot be signed into.

    Any insight into my general way of looking at this hybrid ecosystem and it's limitations to guide me in getting the newest Maps and Music signed in and working would be much appreciated.

    Thanks!
    09-08-14 09:03 AM
  18. kye2000's Avatar
    I recently was upgraded from a BBerry Bold to a Q10 for work. I'm an avid user of custom roms/apps/mods for Android. I am going to have fun learning the ropes here. Thank you to all those who have contributed before!

    Mine is a Verizon Q10 on 10.2.1.2976 (I understand other versions are probably on a newer build) if that matters.

    There are two apps I would particularly like to use, Google Play Music and Google Maps. As I have an Android, I tried extracting the Music, Maps, Play Store, and Play Services apks from my device, running them thru the patcher, and installing them on the Q10. I am unsure of what the Google Login Service apk as I've never encountered it before. I wanted to do it this way so I could have the newest versions of each app. This method didn't work. The Play Store apk failed to patch because Android(Something).XML wasn't present. The other's patched successfully. After installing the 3 patched apps and unpatched Play Store, Google Maps force closes upon opening, and Google Music is unable to be logged into.

    In the interest of just getting something working, I chose to download the Play Store, Login Service, and Music pre-patched apks found in this thread. This method got Music up and running. Maps can be downloaded and used with Snap, however it cannot be signed into.

    Any insight into my general way of looking at this hybrid ecosystem and it's limitations to guide me in getting the newest Maps and Music signed in and working would be much appreciated.

    Thanks!
    Play Music is not needed to be patched. I don't know I about maps. I installed both the login and play services patched apks and have quite a few Google apps working

    Posted via my Z30 running 10.3.0.1xxx
    09-08-14 09:13 AM
  19. sca5033's Avatar
    When I tried installing a non patched music, clicking log in didn't register. I don't have play services currently installed.

    Sent from my SAMSUNG-SGH-I317 using Tapatalk
    09-08-14 11:58 AM
  20. Sally Mack's Avatar
    You should be able to get both music and maps installed without the need for play services. Login through Google maps, and play music should be logged in as well when you open it.
    09-08-14 12:05 PM
  21. sca5033's Avatar
    And the prerequisites are just a patched Play Store and Login Services? Should Maps and Music be patched as well? Any reason I shouldn't be able to use the newest versions of these extracted off my Android?

    Sent from my SAMSUNG-SGH-I317 using Tapatalk
    09-08-14 12:42 PM
  22. Sally Mack's Avatar
    And the prerequisites are just a patched Play Store and Login Services? Should Maps and Music be patched as well? Any reason I shouldn't be able to use the newest versions of these extracted off my Android?

    Sent from my SAMSUNG-SGH-I317 using Tapatalk
    Don't even think you need a patched play store. Versions from your Android should be fine.
    09-08-14 01:46 PM
  23. allwi's Avatar
    Hi there,

    I only lately found this tool and I'm highly impressed. Two apps I patched which rely on maps (TransitTimes+ and Weatherzone Free) work perfectly.
    Thanks very much!!

    However, I have a small aesthetic issue with 'Weatherzone Free'. The patched app lost its icon
    How to patch Android Apps depending on Google Maps and Google Play Services-wz.png
    Any thoughts why and what I can do to get the proper icon (which is shown when I install the unpatched app).

    Cheers
    09-08-14 07:37 PM
  24. Sally Mack's Avatar
    Restart your phone and the icon should appear.
    allwi likes this.
    09-08-14 08:16 PM
  25. popengchan's Avatar
    Install Google Play services and Google Login services first.

    Google Login services
    Google Play Services
    Sorry, just couldn't stay with the conversations as this thread is too popular.

    Are the above patched google stuff for 10.3 versions only? I have the official 10.2.1, will the above work for me?

    Posted via CB10
    09-08-14 09:55 PM
4,042 ... 4647484950 ...

Similar Threads

  1. how do you clean install a BB10 device using Link?
    By gameson in forum BlackBerry 10 OS
    Replies: 14
    Last Post: 04-01-15, 07:54 AM
  2. Android Apps no Longer Working? Candy Crush?
    By raxamillion in forum More for your BlackBerry 10 Phone!
    Replies: 41
    Last Post: 05-05-14, 04:04 AM
  3. Best Remote desktop App?
    By alejandrohn5 in forum BlackBerry Z10
    Replies: 7
    Last Post: 04-01-14, 11:16 PM
  4. Can DLNA Rendering be Enabled by an APP?
    By Cynycl in forum BlackBerry PlayBook
    Replies: 4
    Last Post: 03-15-14, 02:25 PM
  5. Question about 10.2 and sim.
    By Watcher777 in forum BlackBerry Z10
    Replies: 1
    Last Post: 03-14-14, 03:00 PM
LINK TO POST COPIED TO CLIPBOARD