03-24-19 02:56 AM
4,042 ... 3334353637 ...
tools
  1. popengchan's Avatar
    Did you remember to also install the patched google play services?
    Yes I did. Life 360 can now be opened without the error "this requires google...", but the maps does not appear, it's just blank

    Posted via CB10
    07-09-14 08:57 PM
  2. rajbir01's Avatar
    Great jobs guys. Thank you.

    Posted via CB10
    07-09-14 09:11 PM
  3. jzajac's Avatar
    Any luck for quizup yet??? The original app has been updated so any luck???

    Posted via CB10
    My friend, expect that this app will never work regardless of update. It won't ever work so don't ask for it anymore.

    Posted via CB10 on my Z10
    Sa Gar likes this.
    07-09-14 10:19 PM
  4. Cobalt232's Avatar
    Can anyone make life 360 work? I had it patched, installed and opened, but the maps does not show.

    Posted via CB10
    I looked at this app. As it does not recompile with resources, the Google Maps API v2 key is not injected into AndroidManifest and therefore you don't see any map.

    Solution:

    1. Patch life 360 with option decompile resources OFF
    2. Use Google Play Services 5.0.81 that support Google Maps API v2 direct key injection (Download here)
    popengchan likes this.
    07-10-14 03:32 AM
  5. mrjmc99's Avatar
    Cobalt,

    Can you check out the latest version of the My Disney Experience App?

    It was updated a few weeks ago, and is now using google play services, the good new for the app is its lightning fast now, the irony is the previous update when they were on the old fork of this app had finally fixed the location issues, now that is the only piece that doesnt work.

    when you click the map button on the unpatched version it asks to install play services, on a patched version it just crashes. ive tried pretty much every combination of patching, and i have the latest 5.0.81 services that you referred to in the post above. when you launch the app it will want to you login with an account, you dont have to, just click the attractions button at the top, then you will see a map icon at the bottom right.

    patched youtube, and greatclips are working fine on my phone.

    any help would be much appreciated
    https://play.google.com/store/apps/d...w.google&hl=en
    07-10-14 09:30 AM
  6. ralfyguy's Avatar
    Cobalt,

    Can you check out the latest version of the My Disney Experience App?

    It was updated a few weeks ago, and is now using google play services, the good new for the app is its lightning fast now, the irony is the previous update when they were on the old fork of this app had finally fixed the location issues, now that is the only piece that doesnt work.

    when you click the map button on the unpatched version it asks to install play services, on a patched version it just crashes. ive tried pretty much every combination of patching, and i have the latest 5.0.81 services that you referred to in the post above. when you launch the app it will want to you login with an account, you dont have to, just click the attractions button at the top, then you will see a map icon at the bottom right.

    patched youtube, and greatclips are working fine on my phone.

    any help would be much appreciated
    https://play.google.com/store/apps/d...w.google&hl=en
    Which version of YouTube did you use? The latest one does not work.

    Posted via CB10
    07-10-14 10:23 AM
  7. mrjmc99's Avatar
    I just patched 5741, I had to uninstall the older version I had been running first. I used the the default options.

    Z30STA100-3/10.2.1.3175
    07-10-14 10:42 AM
  8. ralfyguy's Avatar
    OK, I patched the YouTube app, but I get network error 401. Doesn't work.

    Posted via CB10
    07-10-14 12:29 PM
  9. popengchan's Avatar
    I looked at this app. As it does not recompile with resources, the Google Maps API v2 key is not injected into AndroidManifest and therefore you don't see any map.

    Solution:

    1. Patch life 360 with option decompile resources OFF
    2. Use Google Play Services 5.0.81 that support Google Maps API v2 direct key injection (Download here)
    Hi, first of al, thank you! Really, this is a much needed app for me.

    But the link you gave gives out an error 404 (page not found).

    Posted via CB10
    07-10-14 12:32 PM
  10. Sally Mack's Avatar
    Hi, first of al, thank you! Really, this is a much needed app for me.

    But the link you gave gives out an error 404 (page not found).

    Posted via CB10
    If opening from cb10 app, touch and hold, then select open in browser. Cb10 app struggles with url encoding apparently.
    popengchan likes this.
    07-10-14 12:47 PM
  11. rajbir01's Avatar
    If opening from cb10 app, touch and hold, then select open in browser. Cb10 app struggles with url encoding apparently.
    Any chance you or your team can patch the latest 5.0.84?

    Posted via CB10
    07-10-14 01:00 PM
  12. Cobalt232's Avatar
    Any chance you or your team can patch the latest 5.0.84?

    Posted via CB10
    Sure :-)
    07-10-14 01:06 PM
  13. popengchan's Avatar
    If opening from cb10 app, touch and hold, then select open in browser. Cb10 app struggles with url encoding apparently.
    Thank you thank you thank you!!!!

    Posted via CB10
    07-10-14 01:21 PM
  14. popengchan's Avatar
    I looked at this app. As it does not recompile with resources, the Google Maps API v2 key is not injected into AndroidManifest and therefore you don't see any map.

    Solution:

    1. Patch life 360 with option decompile resources OFF
    2. Use Google Play Services 5.0.81 that support Google Maps API v2 direct key injection (Download here)
    Good God it works! You are the salt of the earth! Thank you thank you thank you!!!

    Posted via CB10
    Sally Mack and Cobalt232 like this.
    07-10-14 01:21 PM
  15. rajbir01's Avatar
    Sure :-)
    You guys are awesome and nice people.

    Posted via CB10
    07-10-14 02:29 PM
  16. ralfyguy's Avatar
    I just patched 5741, I had to uninstall the older version I had been running first. I used the the default options.

    Z30STA100-3/10.2.1.3175
    How come mine shows that network error? I used the same settings?
    07-10-14 02:30 PM
  17. ralfyguy's Avatar
    OK, had to uninstall Play Services and then it worked. But then my other apps with maps wouldn't work. So i logged out of YouTube and reinstalled Play Services. YouTube works, but only without logging in.

    Posted via CB10
    07-10-14 03:03 PM
  18. Sally Mack's Avatar
    A quick question for cobalt... does the google play services patcher you released a little while back take into account the changes in newer versions of play services? I noticed you mentioned that the newer versions are getting more difficult to patch.

    Thanks,

    Sal
    07-10-14 03:04 PM
  19. Icarus3000's Avatar
    Has anyone been able to get "Heads Up" (charades type game promoted by Ellen Degeneres) to work? There is a knock-off native version available, but it's not as good as the android version.
    07-10-14 03:13 PM
  20. mrjmc99's Avatar
    How come mine shows that network error? I used the same settings?
    I had that happen on first launch, I was on bad Wifi, so I switched to mobile and relaunched and it worked, I tried a few videos

    Edit: sorry I should have mentioned that login doesn't work, I never got it to work.
    Z30STA100-3/10.2.1.3175
    Last edited by mrjmc99; 07-10-14 at 03:29 PM.
    07-10-14 03:15 PM
  21. Cobalt232's Avatar
    A quick question for cobalt... does the google play services patcher you released a little while back take into account the changes in newer versions of play services? I noticed you mentioned that the newer versions are getting more difficult to patch.

    Thanks,

    Sal
    Hi Sal

    Google Play services version 5.x are a real pain to patch. I have a dev version of my patcher that is able to do the patching, but it isn't ready for prime time yet. I had to postphone the xml capable version when 5.x poped up, as I first had to modify the patching engine to be able to decode both dex files, search and patch the files in all places, recompile everything and put the dex files back to the right place. I'll be on it this weekend and may then release a version combined with GMAPS Patcher 1.0.
    tryfe and Furell like this.
    07-10-14 03:28 PM
  22. Sally Mack's Avatar
    Sweet, thanks!
    07-10-14 07:09 PM
  23. ralfyguy's Avatar
    Two thumbs up!!!

    Posted via CB10
    07-10-14 08:13 PM
  24. stroberi's Avatar
    Google Play Service
    Package Name:
    com.google.android.gms
    File Size:16.4 MB
    QR Code:
    Version:5.0.84
    07-10-14 11:57 PM
  25. friso's Avatar
    Hi,

    First of all, I would like to thank you for all the work performed for the Maps patcher! I was able to successfully patch Endomondo and use it on my Z10 up to version 10.2.4.

    Endomondo released version 10.2.7 a while ago. I decided to give it a try and patched the apk using your tool. Unfortunately, version 10.2.7 requires a newer Play Services version (according to the res/values/integers.xml file version 4452000 is required).

    I updated the Play Services version to the latest version which can be found in this thread. I patched the Endomondo APK and tried to install it on my phone. As soon as the maps display is opened, Endomondo shows a message that Play Services cannot be found.

    How to patch Android Apps depending on Google Maps and Google Play Services-img_20140711_130253.png

    What else can I try? The link to my patched APK: https://www.dropbox.com/s/u8ianjzq7j....7-patched.apk

    Just a sidenote: Endomondo offers the Android version in the BlackBerry App World as well. However, they decided to strip all maps-related features. To do this, a check is built into version 10.2.7 which checks for the current os.name equals "qnx". I edited the "smali\com\endomondo\android\common\settings\Setti ngs.smali" file line 3605 and changed "qnx" to "_qnx" in order to bypass this BlackBerry check.
    07-11-14 06:24 AM
4,042 ... 3334353637 ...

Similar Threads

  1. how do you clean install a BB10 device using Link?
    By gameson in forum BlackBerry 10 OS
    Replies: 14
    Last Post: 04-01-15, 07:54 AM
  2. Android Apps no Longer Working? Candy Crush?
    By raxamillion in forum More for your BlackBerry 10 Phone!
    Replies: 41
    Last Post: 05-05-14, 04:04 AM
  3. Best Remote desktop App?
    By alejandrohn5 in forum BlackBerry Z10
    Replies: 7
    Last Post: 04-01-14, 11:16 PM
  4. Can DLNA Rendering be Enabled by an APP?
    By Cynycl in forum BlackBerry PlayBook
    Replies: 4
    Last Post: 03-15-14, 02:25 PM
  5. Question about 10.2 and sim.
    By Watcher777 in forum BlackBerry Z10
    Replies: 1
    Last Post: 03-14-14, 03:00 PM
LINK TO POST COPIED TO CLIPBOARD