03-24-19 02:56 AM
4,042 ... 2930313233 ...
tools
  1. Sally Mack's Avatar
    No, I don't think I did have play store installed.

    But aside from the Google Maps latest version issue, is there a reason to have or not to have play services installed for other apps?

    Posted via CB10
    If you use any apps that use "google play services" (such as apps that rely on location services or display maps within them... eg. Yelp, strava, uber, etc) , then you'll need to have Google play services installed and the apps patched in order for them to work properly.
    KenV54 likes this.
    06-27-14 06:58 PM
  2. KenV54's Avatar
    If you use any apps that use "google play services" (such as apps that rely on location services or display maps within them... eg. Yelp, strava, uber, etc) , then you'll need to have Google play services installed and the apps patched in order for them to work properly.
    Thanks, Sal.

    I just added the "new" Play Services in on top of the Play store and both the M-W dictionary and the older Maps are working fine. I think I'll stick with this configuration for a while.
    Sally Mack likes this.
    06-27-14 07:24 PM
  3. Sally Mack's Avatar
    Got another problem app: UPS mobile. I cannot get the map for locations to show. I had to set it to decompile without resources to even get it to rebuild, but still no dice.

    Posted via CB10
    I think the only way to get this to work is with a new patching method cobalt still hasn't released in his patcher yet. Effectively it does all the patching it normally does, without touching the android manifest file. The api key (which we would normally change in the android manifest file) gets injected through his newer patched google play services.
    06-27-14 07:32 PM
  4. ralfyguy's Avatar
    I think the only way to get this to work is with a new patching method cobalt still hasn't released in his patcher yet. Effectively it does all the patching it normally does, without touching the android manifest file. The api key (which we would normally change in the android manifest file) gets injected through his newer patched google play services.
    Sounds great, can't wait.

    Posted via CB10
    06-27-14 07:58 PM
  5. Sinserli's Avatar
    Hi there,

    First of all thanks to Cobalt232 and team for their great job!

    I just successfully patched the app "Todoist" and installed it on my Z30. The only "failure" is that the icon is missing. Is it normal or did I miss something?

    Thanks in advance for your replay!
    06-29-14 11:20 AM
  6. Sally Mack's Avatar
    Hi there,

    First of all thanks to Cobalt232 and team for their great job!

    I just successfully patched the app "Todoist" and installed it on my Z30. The only "failure" is that the icon is missing. Is it normal or did I miss something?

    Thanks in advance for your replay!
    Do you mean there's a spot for it on your icon tray and the icon is "blank", or can you not find the app at all?

    If it's the former, a restart should fix it. If it's the latter, it sounds like it didn't install fully.
    06-29-14 12:23 PM
  7. Sinserli's Avatar
    Thank you very much for your advice, a restart did it! Thanks a lot again.

    Posted via CB10
    06-29-14 01:42 PM
  8. ralfyguy's Avatar
    New Google Play Services out again...


    Posted via CB10
    06-30-14 02:05 PM
  9. ConorRobinson's Avatar
    It would be great if someone could make a native app so apks can be directly patched on the phone

    Posted via CB10
    07-01-14 09:08 AM
  10. Blackbox55's Avatar
    Hi,

    Trying to fix my Tesla app since it stopped working (the mapping service only) after 1Mobile asked me to update.

    Saw many posts on people having issues with the patching after using the patcher. I seem to be one of them. Here is the debug mode screen capture. Java seems to be 7.51

    How to patch Android Apps depending on Google Maps and Google Play Services-patcher.jpg
    07-01-14 12:19 PM
  11. mrjmc99's Avatar
    Hi,

    Trying to fix my Tesla app since it stopped working (the mapping service only) after 1Mobile asked me to update.

    Saw many posts on people having issues with the patching after using the patcher. I seem to be one of them. Here is the debug mode screen capture. Java seems to be 7.51

    Click image for larger version. 

Name:	patcher.jpg 
Views:	1633 
Size:	163.8 KB 
ID:	281822
    You probably need to remove all versions of the app from your phone and try a clean install.

    Also on a side note, since the tesla community is pretty small and I believe very customer oriented, have you asked them to port the app over or make a native one? I would be willing to guess that they might do it, especially if there are other bb10 tesla owners.

    Z30STA100-3/10.2.1.3247
    07-02-14 08:42 AM
  12. urShadow's Avatar
    Today I installed "Saga — Automatic Lifelogging", it was installed without an error but it asked for 'Google Play Services' thus I patched it using GMAPS Patcher v0.9, with and without 'Patch Additional Google Play Services' Option but in both cases when I tried to install it it gave an error "unable to install" although the icon was already created, tapping the icon just opened a blank screen for a second and then it closed. Anyone using "Saga — Automatic Lifelogging"?
    07-02-14 11:36 AM
  13. VictorRight's Avatar
    Just followed up with this approach (the extra patching method for apps like Strava). It made no difference on the apps that sometimes struggle to find location.
    I use Fitness Tracker (BlackBerry native app) that uploads your gpx file automatically to Strava and it works nicely; however, there is nor hrm yet.


    Posted via CB10
    07-02-14 11:49 AM
  14. Sally Mack's Avatar
    Today I installed "Saga Automatic Lifelogging", it was installed without an error but it asked for 'Google Play Services' thus I patched it using GMAPS Patcher v0.9, with and without 'Patch Additional Google Play Services' Option but in both cases when I tried to install it it gave an error "unable to install" although the icon was already created, tapping the icon just opened a blank screen for a second and then it closed. Anyone using "Saga Automatic Lifelogging"?
    Uninstall the app from your phone, double volume button restart, then reinstall.

    The reason why it didn't install correctly was because you either didn't uninstall the first version you installed, or it didn't uninstall correctly. The patched version has a different signature, so it won't overwrite the non patched version correctly. I hope that made sense.
    07-02-14 12:12 PM
  15. urShadow's Avatar
    Uninstall the app from your phone, double volume button restart, then reinstall.

    The reason why it didn't install correctly was because you either didn't uninstall the first version you installed, or it didn't uninstall correctly. The patched version has a different signature, so it won't overwrite the non patched version correctly. I hope that made sense.
    Hi Sally: I had uninstalled the original app. Now I performed the hard reset and installed the patched app but the result is exactly the same. Any suggestions?
    07-02-14 12:24 PM
  16. Sally Mack's Avatar
    Double check that all traces of the app are gone using ghost commander as well?
    07-02-14 12:44 PM
  17. urShadow's Avatar
    Double check that all traces of the app are gone using ghost commander as well?
    I have installed Ghost Commander and tried to search for traces of Saga, there are so many directories, is there any particular path which I should check or is there any guide available on deleting all traces of an app using ghost commander? it would be really helpful.
    07-02-14 02:03 PM
  18. NewFordOrder's Avatar
    On some apps, such as Tumblr, it says they do not require patching, but when I run them, I get the warning that Google Services has stopped over and over.
    07-02-14 03:53 PM
  19. Sally Mack's Avatar
    I have installed Ghost Commander and tried to search for traces of Saga, there are so many directories, is there any particular path which I should check or is there any guide available on deleting all traces of an app using ghost commander? it would be really helpful.
    When you open ghost commander, just go to applications. Then it'll bring you to a list of all the android applications on your device in alphabetical order.
    07-02-14 04:31 PM
  20. ralfyguy's Avatar
    On some apps, such as Tumblr, it says they do not require patching, but when I run them, I get the warning that Google Services has stopped over and over.
    Yeah, just like the Skype version I got from BlackBerry World.

    Posted via CB10
    07-02-14 04:37 PM
  21. Sally Mack's Avatar
    On some apps, such as Tumblr, it says they do not require patching, but when I run them, I get the warning that Google Services has stopped over and over.
    The play services crashes may be (most likely are) independent of the app you're using.

    For example, ever since installing the new theScore app, I've been getting errors about it crashing in any android app I'm in.
    NewFordOrder likes this.
    07-02-14 04:50 PM
  22. Cobalt232's Avatar
    Can you guys give this version a try:

    Google Play services 5.0.81
    07-02-14 05:10 PM
  23. tryfe's Avatar
    Can you guys give this version a try:

    Google Play services 5.0.81
    Error (404)

    Posted via CB10
    ralfyguy likes this.
    07-02-14 05:51 PM
  24. ralfyguy's Avatar
    Can you guys give this version a try:

    Google Play services 5.0.81
    Tried to download but page shows an error.

    Posted via CB10
    07-02-14 07:57 PM
  25. ralfyguy's Avatar
    OK it worked now.

    Posted via CB10
    07-02-14 07:59 PM
4,042 ... 2930313233 ...

Similar Threads

  1. how do you clean install a BB10 device using Link?
    By gameson in forum BlackBerry 10 OS
    Replies: 14
    Last Post: 04-01-15, 07:54 AM
  2. Android Apps no Longer Working? Candy Crush?
    By raxamillion in forum More for your BlackBerry 10 Phone!
    Replies: 41
    Last Post: 05-05-14, 04:04 AM
  3. Best Remote desktop App?
    By alejandrohn5 in forum BlackBerry Z10
    Replies: 7
    Last Post: 04-01-14, 11:16 PM
  4. Can DLNA Rendering be Enabled by an APP?
    By Cynycl in forum BlackBerry PlayBook
    Replies: 4
    Last Post: 03-15-14, 02:25 PM
  5. Question about 10.2 and sim.
    By Watcher777 in forum BlackBerry Z10
    Replies: 1
    Last Post: 03-14-14, 03:00 PM
LINK TO POST COPIED TO CLIPBOARD