03-24-19 02:56 AM
4,042 ... 2122232425 ...
tools
  1. Sally Mack's Avatar
    I have the login service and Google play services installed and have been logged into maps since v7. I think the trick is to install the login service first then play services last

    Z30STA100-3/10.2.1.3175
    Which version of Google play services? I've tried every combination including the one you mentioned with no such luck.
    05-30-14 10:36 PM
  2. mrjmc99's Avatar
    The latest patched that cobalt released, not the latest available in snap. I found that It will throw an error "could not install this app" but it's actually installed from what I can tell, I have the latest YouTube patched and it runs fine, I also use Google voice and am logged into it. So I have maps and voice using the login service and YouTube using play services, I had the patched play store at one point to verify a license for an app, but it was easier to use a hacked older version of the app than to deal with the license check at each launch, it was slow and annoying. Maybe some other apps that use other portions of play services won't work, I can test one if you want. I don't play games on my phone so most apps I use don't need to be patched

    Z30STA100-3/10.2.1.3175
    05-30-14 11:40 PM
  3. Sally Mack's Avatar
    Don't think YouTube requires play services, and by the sounds of it, you don't have cobalt's play services fully installed (hence why maps is logging in for you).

    I should mention that the error you're seeing is usually when you try to upgrade an existing installed app, and signatures don't match. Are you sure you don't have a previous, unpatched version of Google play services installed?
    05-31-14 12:06 AM
  4. mrjmc99's Avatar
    The newest version of YouTube requires play services. Had to patch it for it to run. I'll take some screen shots later
    Edit : here are my screen shots, somehow they disappeared the first time I posted.

    Me signed into maps
    Attachment 275108
    Play services installed
    Attachment 275109
    Patched Youtube installed
    Attachment 275110
    Version of maps and voice installed, as well as the account manager.
    Attachment 275111
    Last edited by mrjmc99; 05-31-14 at 09:12 PM.
    05-31-14 08:48 AM
  5. svelt's Avatar
    Wasn't aware Youtube works. Can you sign in now?

    Sent from my Z30 using Tapatalk
    05-31-14 12:04 PM
  6. mrjmc99's Avatar
    Wasn't aware Youtube works. Can you sign in now?

    Sent from my Z30 using Tapatalk
    It works fine, runs pretty smooth actually , but can't sign in, I only have it because I can use it to share to my xbmc through the yatse remote.

    Z30STA100-3/10.2.1.3175
    05-31-14 01:34 PM
  7. Sa Gar's Avatar
    Patched apk for quiz up plzzzzzzz

    Posted via CB10
    05-31-14 09:01 PM
  8. tryfe's Avatar
    The latest patched that cobalt released, not the latest available in snap. I found that It will throw an error "could not install this app" but it's actually installed from what I can tell, I have the latest YouTube patched and it runs fine, I also use Google voice and am logged into it. So I have maps and voice using the login service and YouTube using play services, I had the patched play store at one point to verify a license for an app, but it was easier to use a hacked older version of the app than to deal with the license check at each launch, it was slow and annoying. Maybe some other apps that use other portions of play services won't work, I can test one if you want. I don't play games on my phone so most apps I use don't need to be patched

    Z30STA100-3/10.2.1.3175
    I got the same thing but after a security wipe/reload of 10.2.1.3175, it installed fine along with the patched play store apk. Perhaps our systems got somewhat corrupted? All I know is that I got it working perfect now.
    05-31-14 10:21 PM
  9. Sally Mack's Avatar
    Patched apk for quiz up plzzzzzzz

    Posted via CB10
    Doesn't exist.
    05-31-14 10:31 PM
  10. jzajac's Avatar
    Patched apk for quiz up plzzzzzzz

    Posted via CB10
    You can patch that one all you want,but the app won't let you log in. So I guess technically it does run on BB10 but you can't actually play it. There is absolutely nothing we can do about that. Sorry. Try giving this forum a search next time though, that's been posted plenty of times in here.

    Posted via CB10 on my Z10
    06-01-14 07:30 AM
  11. Nigelbrown's Avatar
    All I really want is Youtube and Plex to use Chromecast, which is now bundled into G Services. Can this be patched?
    06-01-14 11:27 PM
  12. FlagshipFighter's Avatar
    Didn't know about this!

    Hmmmm, I wonder if Zombies, Run or Zombies 5k now works...

    Posted via CB10
    06-02-14 06:00 AM
  13. Sally Mack's Avatar
    All I really want is Youtube and Plex to use Chromecast, which is now bundled into G Services. Can this be patched?
    Some users have reported chromecast working on a previous version of YouTube. Give it a search through the forums to see how users got it to work (not sure if patching makes a difference in that respect).
    06-02-14 08:20 AM
  14. Nigelbrown's Avatar
    Yeah the older Youtube version now doesn't work with layer builds but netflix does flawlessly at least.

    I'm on 10.3 so I assume we might get better success in coming builds.

    Posted via CB10
    06-02-14 10:15 AM
  15. Johan Aelbrecht's Avatar
    Hi everyone.
    I'm trying this method with some games (royal revolt 2 and dungeon keeper). the .apk files got patched using the tool.
    But when i run them those games can't seem to connect. (i get connection time out errors).

    I saw the message: Google Play Services has stopped. when i run those games the 1st time. I use the google account manager, play store and play services that i found in this topic. OS 10.2.1.2941 Any tips?
    06-03-14 05:04 AM
  16. svelt's Avatar
    It works fine, runs pretty smooth actually , but can't sign in, I only have it because I can use it to share to my xbmc through the yatse remote.

    Z30STA100-3/10.2.1.3175
    Weird I run the same OS as you on the same phone, and patched it with the 0.9 Patcher, but it just crashes on launch (Unfortunately the app has stopped type of error). If you still have the patched apk and if it's convenient to do so can you upload it?
    06-03-14 02:55 PM
  17. Sally Mack's Avatar
    Hi everyone.
    I'm trying this method with some games (royal revolt 2 and dungeon keeper). the .apk files got patched using the tool.
    But when i run them those games can't seem to connect. (i get connection time out errors).

    I saw the message: Google Play Services has stopped. when i run those games the 1st time. I use the google account manager, play store and play services that i found in this topic. OS 10.2.1.2941 Any tips?
    Do you have the *patched* google play services installed?
    06-03-14 03:05 PM
  18. mrjmc99's Avatar
    Weird I run the same OS as you on the same phone, and patched it with the 0.9 Patcher, but it just crashes on launch (Unfortunately the app has stopped type of error). If you still have the patched apk and if it's convenient to do so can you upload it?
    Here is Youtube 5636
    https://app.box.com/s/9ojzz5g4kkalsrjxgw9d

    Here is cobalt's play services 4.4.48
    https://app.box.com/s/wzaokahbfmodb41i3l3f

    You need both and don't try to login, it will break the app.if you have either app loaded now remove them first.

    Good luck

    Z30STA100-3/10.2.1.3175
    svelt likes this.
    06-03-14 04:22 PM
  19. edwineel's Avatar
    Hi all, any luck with Google Hangouts?
    06-04-14 12:12 AM
  20. Johan Aelbrecht's Avatar
    Do you have the *patched* google play services installed?
    Yes, i use the version of cobalt found on this forum (+ google vendor + google login services)
    06-04-14 01:10 AM
  21. mrjmc99's Avatar
    Hi all, any luck with Google Hangouts?
    Hangouts requires Google software framework, which can't be installed on the blackberry runtime at this time.

    Z30STA100-3/10.2.1.3175
    edwineel likes this.
    06-04-14 07:30 AM
  22. edwineel's Avatar
    Hangouts requires Google software framework, which can't be installed on the blackberry runtime at this time.

    Z30STA100-3/10.2.1.3175
    thanks for the reply!!!


    Sent from my iPad using Tapatalk
    06-04-14 09:03 AM
  23. tryfe's Avatar
    Can Google Play Store v4.8.20 be patched and Google Play services 4.4.52?
    06-04-14 06:32 PM
  24. Cobalt232's Avatar
    Some of you may have noticed, that GMAPS Patcher is not able to patch Google Play Services (com.google.android.gms.apk). This is because this apk uses double DEX files that contain the Java classes and APKTool can not handle such files.

    As a solution, I wrote a new, specific patcher for Google Play Services. It is able to extract the correct dex file, decompile and patch it and put it back into the original package. So if you guys want to patch the latest Google Play Services, you may want to grab this new tool.

    Don't forget to read the readme inlcuded in the archive.

    Download Google Play Services Mini Patcher
    tryfe, kolok, dustmalik and 7 others like this.
    06-05-14 06:17 AM
  25. eywong's Avatar
    I wrote a new, specific patcher for Google Play Services.
    Download Google Play Services Mini Patcher
    Your Google Play Services Mini Patcher works on my WinXP. Using it, I patched Google Play services version 4.4.52 and then I installed the patched .apk on my Z10. No problems, so far. Thanks for the nice tool. (For reference, I attached the patcher's session dialog, below.)
    Z10STL100-3/10.2.1.3175

    Session dialog:
    Working on C:\GMaps_Patcher_Win_v0.9\tmp\com.google.android.g ms-4452036.apk
    [Extracting dex file from apk package]
    Done.
    [Checking enforceCallingOrSelfPermission]
    Found C:\GMaps_Patcher_Win_v0.9\tmp\com.google.android.g ms-4452036\imq.smali
    .method private static c()V in imq.smali detected
    [Patching Permissions Verification]
    Done.
    [Checking Signature Verification]
    Found C:\GMaps_Patcher_Win_v0.9\tmp\com.google.android.g ms-4452036\bhd.smali
    .method public static a(Landroid/content/ContextI in bhd.smali detected
    [Patching Signature Verification]
    Done.
    [Rebuilding]
    Done.
    [Signing and Zipaligning]
    Done.
    The package com.google.android.gms-4452036.apk has been successfully patched. Check \output folder for patched file.
    [Cleaning up]
    Done.
    tryfe and Cobalt232 like this.
    06-05-14 12:03 PM
4,042 ... 2122232425 ...

Similar Threads

  1. how do you clean install a BB10 device using Link?
    By gameson in forum BlackBerry 10 OS
    Replies: 14
    Last Post: 04-01-15, 07:54 AM
  2. Android Apps no Longer Working? Candy Crush?
    By raxamillion in forum More for your BlackBerry 10 Phone!
    Replies: 41
    Last Post: 05-05-14, 04:04 AM
  3. Best Remote desktop App?
    By alejandrohn5 in forum BlackBerry Z10
    Replies: 7
    Last Post: 04-01-14, 11:16 PM
  4. Can DLNA Rendering be Enabled by an APP?
    By Cynycl in forum BlackBerry PlayBook
    Replies: 4
    Last Post: 03-15-14, 02:25 PM
  5. Question about 10.2 and sim.
    By Watcher777 in forum BlackBerry Z10
    Replies: 1
    Last Post: 03-14-14, 03:00 PM
LINK TO POST COPIED TO CLIPBOARD