1. conite's Avatar
    That hasn't happened to me. I would delete everything and re do the process. Make sure you're following step by step.
    Thank you so much for replying...what I meant was that...when I'm usin the playstore and I click on an app to download...the play store itself immediately closes and says 'unfortunately google play store has stopped' and so I am unable to download any apps from the appstore
    Apply Cobalt's fix from yesterday. A new Play Store build that addresses the problem.
    Emeral likes this.
    08-30-17 07:27 PM
  2. JPD404's Avatar
    Apply Cobalt's fix from yesterday. A new Play Store build that addresses the problem.
    Thank you. I wasn't aware of that.
    08-30-17 07:28 PM
  3. Emeral's Avatar
    Apply Cobalt's fix from yesterday. A new Play Store build that addresses the problem.
    Thank you so much...really grateful...hoping it works...bt where can I find the fix?
    08-30-17 08:17 PM
  4. conite's Avatar
    Thank you so much...really grateful...hoping it works...bt where can I find the fix?
    Cobalt's normal Mega link.
    08-30-17 08:22 PM
  5. Govind Sirvi's Avatar
    Maybe start over.

    Cobalt's file share:

    https://mega.nz/#F!lIUWjSSQ!yoLoiNX3PNG3Sef1Fa_fMA

    Install and login with 4.3.3.
    Install and register with 2.8.
    Install Play Services v10.
    Update 4.4.4 over 4.3.3 (but don't open).
    Install Play Store v6.
    Install whitelist 1.0.0.6.

    If an app requires Google Play Services:
    Download app with Cobalt's Play Store (but don't install).
    Whitelist unpatched app.
    Patch app on PC with Play Services Patcher 1.6 using defaults settings.

    Install patched app.


    If after all that, your app still won't work, then it's simply not compatible with BB10.
    Where is whitelist option

    Posted via CB10
    09-03-17 11:08 PM
  6. conite's Avatar
    Where is whitelist option

    Posted via CB10
    I don't understand the question.
    09-03-17 11:14 PM
  7. Govind Sirvi's Avatar
    How to whitelist an app

    Posted via CB10
    09-03-17 11:15 PM
  8. JPD404's Avatar
    Open the Whitelisting app and add package.
    09-03-17 11:59 PM
  9. TheCharlestonCount's Avatar
    Hello friends. I have been trying relentlessly to patch a new version of Lyft to get it to work on my Blackberry Classic. I have followed the instructions as per Cobalt and downloaded the Play Services Patcher on my PC and uploaded the new version of the Lyft APK. It will not work! It keeps telling me "Package cannot be recomplied."

    Please help me.
    09-12-17 04:50 PM
  10. TheCharlestonCount's Avatar
    Processing C:\Users\TLO\Favorites\Downloads\me.lyft.android-4.47.3.1504123929@APK4Fun.com.apk
    The package contains 3 classes.dex files
    [Decompiling classes]
    Decompiled 24.55 MB in 449.88 seconds
    Done.
    [Analyzing Package]
    Google Play services dependencies detected
    Found: C:\Users\TLO\Favorites\Downloads\PS_Patcher-1.6\PS_Patcher-1.6\tmp\me.lyft.android-4.47.3.1504123929@APK4Fun.com\smali\com\google\and roid\gms\common\zzg.smali
    Found: C:\Users\TLO\Favorites\Downloads\PS_Patcher-1.6\PS_Patcher-1.6\tmp\me.lyft.android-4.47.3.1504123929@APK4Fun.com\smali\com\google\and roid\gms\common\zzh.smali
    [Analysis completed]

    Press CONTINUE to proceed or CANCEL to abort.

    [Patching isGooglePlayServicesAvailable]
    .method public static d(Landroid/content/ContextI
    in file C:\Users\TLO\Favorites\Downloads\PS_Patcher-1.6\PS_Patcher-1.6\tmp\me.lyft.android-4.47.3.1504123929@APK4Fun.com\smali\com\google\and roid\gms\common\zzg.smali
    Done.
    [Patching isSignatureValid]
    .method varargs a(Landroid/content/pm/PackageInfo;[Lcom/google/android/gms/common/zzf$zzaLcom/google/android/gms/common/zzf$zza;
    in file C:\Users\TLO\Favorites\Downloads\PS_Patcher-1.6\PS_Patcher-1.6\tmp\me.lyft.android-4.47.3.1504123929@APK4Fun.com\smali\com\google\and roid\gms\common\zzh.smali
    Done.
    [Patching isGoogleSigned]
    .method public a(Landroid/content/pm/PackageInfo;Z)Z
    in file C:\Users\TLO\Favorites\Downloads\PS_Patcher-1.6\PS_Patcher-1.6\tmp\me.lyft.android-4.47.3.1504123929@APK4Fun.com\smali\com\google\and roid\gms\common\zzh.smali
    Done.
    [Rebuilding]
    Error: Package cannot be recompiled.
    [Cleaning up]
    Done.
    09-12-17 04:51 PM
  11. conite's Avatar
    Hello friends. I have been trying relentlessly to patch a new version of Lyft to get it to work on my Blackberry Classic. I have followed the instructions as per Cobalt and downloaded the Play Services Patcher on my PC and uploaded the new version of the Lyft APK. It will not work! It keeps telling me "Package cannot be recomplied."

    Please help me.
    Works fine. Just make sure your Patcher folder is just off your root drive. If the nesting gets too deep, it has trouble.

    Also, go back slightly to version 4.41.3 to eliminate log in problems.

    Don't forget to patch with default settings, and be using whitelist 1.0.0.6 and Play Services v10.
    09-12-17 05:10 PM
  12. TheCharlestonCount's Avatar
    Contie,

    Thank you: can you please explain a little further what you mean. I have all of the necessary components from the COBALT drive on my phone, but I don't know how to download the 4.41.3 version of Lyft (IE: i dont know where to find it). I also dont know how to just download (and not install) using the Google Play App Store.

    I have whitelist 1.0.0.6 on my Classic, but are you saying that I would whitelist the raw app using my phone first, then send the file to my computer to patch it, and then back to the phone to install it?

    I am sorry if I sound like an *****: I promise, I want to understand.

    Thank you!

    TLO
    09-13-17 10:13 AM
  13. conite's Avatar
    Contie,

    Thank you: can you please explain a little further what you mean. I have all of the necessary components from the COBALT drive on my phone, but I don't know how to download the 4.41.3 version of Lyft (IE: i dont know where to find it). I also dont know how to just download (and not install) using the Google Play App Store.

    I have whitelist 1.0.0.6 on my Classic, but are you saying that I would whitelist the raw app using my phone first, then send the file to my computer to patch it, and then back to the phone to install it?

    I am sorry if I sound like an *****: I promise, I want to understand.

    Thank you!

    TLO
    Yes, you want to whitelist the unpatched app first. Then patch. Then install patched app.

    Normally you would begin to install an app off the Play Store, but then quit when the Blackberry installer comes up, and find the APK in your download folder.

    But in this case, since you are looking for an older version, you will need to go to apkmirror.com.
    09-13-17 11:03 AM
  14. TheCharlestonCount's Avatar
    Holy goodness,

    I figured it out! Right when I saw your reply, I got it to work on my phone! Moving the Patcher file folder to my desktop did the trick to get the file to patch!

    Contie, you are a genius and a miracle worker!

    Thank you, thank you, thank you!
    09-13-17 11:07 AM
  15. JPD404's Avatar
    Conite was too fast. There's also apkpure.com. I believe those are the two more reliable apk sources.
    09-13-17 11:26 AM
  16. crowning73's Avatar
    Anyone can confirm that this app is not patchable and also that MAPS.ME doesn't work anymore?

    it.mediaset.premiumplay

    Since it's too big (25MB) to upload here I will share it publicly on mediafire if that's not a problem.
    09-13-17 03:33 PM
  17. mah62ina's Avatar
    Yes, you want to whitelist the unpatched app first. Then patch. Then install patched app.

    Normally you would begin to install an app off the Play Store, but then quit when the Blackberry installer comes up, and find the APK in your download folder.

    But in this case, since you are looking for an older version, you will need to go to apkmirror.com.
    Please help. I am really confuse with about the prerequisite to run android play service dependent-apps in blackberry 10.

    to run android play service dependent apps, blackberry 10 device need to have these components:

    1. c-1. com.google.android.gms -> google play service
    2. c-2. com.google.android.gsf.login-4.3.3 -> google account manager

      if want to user patched Google Play service then install

      c-2.1. com.google.android.gsf.login-4.4.4
    3. c-3. cobalt.blackberry.googleID -> blackberry google ID (=my understanding is so the device recognized as "android device)
    4. c-4. com.android.vending -> google play store (=to download and buy android apps)

    --------------------------
    additional components are:
    • ac-1. Google+ Whitelist
    • ac-2. Windows PC tools to patch google play service in an app

    --------------------------

    my questions:
    1. q-1. if we already install Google Play Service like referred as "c-1", what does it mean with "c-2.1"?
    2. q-2. if we already have Google Play Service, why we need Google+ Whitelist?
    3. q-3. if we have Google+ Whitelist and Google Play Service, why we need to patch the app?


    I know in general we don't need to patch the android app if it not popping "This app requires Google Play Services...". I need to understand what am i doing. Thank you very much for your help.
    09-18-17 07:13 AM
  18. conite's Avatar
    Please help. I am really confuse with about the prerequisite to run android play service dependent-apps in blackberry 10.

    to run android play service dependent apps, blackberry 10 device need to have these components:

    1. c-1. com.google.android.gms -> google play service
    2. c-2. com.google.android.gsf.login-4.3.3 -> google account manager

      if want to user patched Google Play service then install

      c-2.1. com.google.android.gsf.login-4.4.4
    3. c-3. cobalt.blackberry.googleID -> blackberry google ID (=my understanding is so the device recognized as "android device)
    4. c-4. com.android.vending -> google play store (=to download and buy android apps)

    --------------------------
    additional components are:
    • ac-1. Google+ Whitelist
    • ac-2. Windows PC tools to patch google play service in an app

    --------------------------

    my questions:
    1. q-1. if we already install Google Play Service like referred as "c-1", what does it mean with "c-2.1"?
    2. q-2. if we already have Google Play Service, why we need Google+ Whitelist?
    3. q-3. if we have Google+ Whitelist and Google Play Service, why we need to patch the app?


    I know in general we don't need to patch the android app if it not popping "This app requires Google Play Services...". I need to understand what am i doing. Thank you very much for your help.
    Just follow these instructions exactly:

    /more-your-blackberry-10-phone-f306/how-patch-android-apps-depending-google-maps-google-play-services-914930-post12953060/
    09-18-17 08:49 AM
  19. mah62ina's Avatar
    Just follow these instructions exactly:

    https://forums.crackberry.com/showthread.php?p=12953060
    Thank you very much, i didn't expect get this fast response.

    I have follow the instructions and successfully run android apps that require google play service in my friend's Q10. Cobalt is genius and nice.

    the apps are: Keep, Grab, and Ho-Jak. Go-Jek is the exception. I know, just ignore the error, it will run just fine.

    My understanding for this requirements is Blackberry 10 need two side of patch, on the operating system to have the runtime and on the app it self.

    Thanks
    09-18-17 10:09 AM
  20. Govind Sirvi's Avatar
    Yes, you want to whitelist the unpatched app first. Then patch. Then install patched app.

    Normally you would begin to install an app off the Play Store, but then quit when the Blackberry installer comes up, and find the APK in your download folder.

    But in this case, since you are looking for an older version, you will need to go to apkmirror.com.
    What ia that default settings.

    Posted via CB10
    09-21-17 11:42 PM
  21. bergmannap's Avatar
    Why not use the native, Built-For-Blackberry version? It would also let developers know we want and use native apps.

    Q10SQN100-1/10.2.1.2947
    09-29-17 03:46 PM
  22. bergmannap's Avatar
    Please keep in mind that GasBuddy no longer supports the native app. This is per Patrick DeHaan (@GasBuddyGuy). So we need to create a Twitter storm so they start Support again.
    09-29-17 03:49 PM
  23. Thayna de Paula's Avatar
    I did every step to patch the latest version of Uber (including all the API thing, Whitelist et cetera) and I was able to install it, it opens up but it doesn't work properly because it says I need Google Services and it's not compatible with the device I'm using... but I have downloaded all the Google-related apps in Cobalt's list... What am I possibly doing wrong? I recently traded an Android for a BlackBerry but I didn't really know it wasn't compatible with Uber... I really need it cause I use it to go to work so I'd appreciate some help.
    10-01-17 12:02 PM
  24. JPD404's Avatar
    I did every step to patch the latest version of Uber (including all the API thing, Whitelist et cetera) and I was able to install it, it opens up but it doesn't work properly because it says I need Google Services and it's not compatible with the device I'm using... but I have downloaded all the Google-related apps in Cobalt's list... What am I possibly doing wrong? I recently traded an Android for a BlackBerry but I didn't really know it wasn't compatible with Uber... I really need it cause I use it to go to work so I'd appreciate some help.
    Latest Uber doesn't work on BB10. You can go back in versions to the latest one that works or use m.uber.com from browser. Or if you're in America you can use Lyft as well.
    10-01-17 12:13 PM
  25. conite's Avatar
    Latest Uber doesn't work on BB10. You can go back in versions to the latest one that works or use m.uber.com from browser. Or if you're in America you can use Lyft as well.
    The last several versions work again, no problem.
    10-01-17 12:24 PM
4,042 ... 150151152153154 ...

Similar Threads

  1. how do you clean install a BB10 device using Link?
    By gameson in forum BlackBerry 10 OS
    Replies: 14
    Last Post: 04-01-15, 07:54 AM
  2. Android Apps no Longer Working? Candy Crush?
    By raxamillion in forum More for your BlackBerry 10 Phone!
    Replies: 41
    Last Post: 05-05-14, 04:04 AM
  3. Best Remote desktop App?
    By alejandrohn5 in forum BlackBerry Z10
    Replies: 7
    Last Post: 04-01-14, 11:16 PM
  4. Can DLNA Rendering be Enabled by an APP?
    By Cynycl in forum BlackBerry PlayBook
    Replies: 4
    Last Post: 03-15-14, 02:25 PM
  5. Question about 10.2 and sim.
    By Watcher777 in forum BlackBerry Z10
    Replies: 1
    Last Post: 03-14-14, 03:00 PM
LINK TO POST COPIED TO CLIPBOARD