1. conite's Avatar
    And is there any other way how to connect Android Wear stuff to BB ?
    Nope. Unless you buy a Priv or DTEK50.
    08-03-16 12:03 PM
  2. Stanley008's Avatar
    I saw some stuff working with BB... I am not saying all of it. Maybe It's just hit and try... nothing else. Could You please patch It? So I could atleast give It a shot Thank You.
    08-03-16 12:04 PM
  3. RoseBud68's Avatar
    I saw some stuff working with BB... I am not saying all of it. Maybe It's just hit and try... nothing else. Could You please patch It? So I could atleast give It a shot Thank You.
    Or you can learn how to do it yourself instead.


    Posted via CB10
    08-03-16 12:33 PM
  4. Stanley008's Avatar
    Or you can learn how to do it yourself instead.


    Posted via CB10
    If You would read previous posts You would know that I have a MAC so there is no possibility to do It by myself.
    08-03-16 12:44 PM
  5. conite's Avatar
    I saw some stuff working with BB... I am not saying all of it. Maybe It's just hit and try... nothing else. Could You please patch It? So I could atleast give It a shot Thank You.
    Check your PM.
    BigBadWulf and TGIS like this.
    08-03-16 01:25 PM
  6. dede koswara's Avatar
    How to install play store on BlackBerry Z10? Thank....

    Posted via CB10
    TGIS likes this.
    08-03-16 03:47 PM
  7. conite's Avatar
    How to install play store on BlackBerry Z10? Thank....

    Posted via CB10
    /more-your-blackberry-10-phone-f306/google-play-store-blackberry-10-outdated-985344/
    08-03-16 03:48 PM
  8. TGIS's Avatar
    How to install play store on BlackBerry Z10? Thank....

    Posted via CB10
    Read the first post on this thread:
    /blackberry-10-os-f269/cobalts-official-google-apps-landing-page-965257/
    Last edited by TGIS; 08-03-16 at 03:50 PM. Reason: You beat me to it, conite!
    08-03-16 03:49 PM
  9. egglys's Avatar
    Hallo, I am running into a similar Problem with trying to patch the current Google Maps App. It used to work fine with all former versions. Now I am getting the message "The package could not be rebuild". I followed all the necessary steps i.e. Map API, Geolocation API and checked "decompile...." Anybody running into the same Problem and might know what is the Problem and to fix it? Thank you!
    08-04-16 02:46 AM
  10. Smokeaire's Avatar
    Hallo, I am running into a similar Problem with trying to patch the current Google Maps App. It used to work fine with all former versions. Now I am getting the message "The package could not be rebuild". I followed all the necessary steps i.e. Map API, Geolocation API and checked "decompile...." Anybody running into the same Problem and might know what is the Problem and to fix it? Thank you!
    Do not check decompile.
    08-04-16 03:10 AM
  11. 1978dll's Avatar
    I'm trying to patch the latest version of Fitbit but got this error
    How to patch Android Apps depending on Google Maps and Google Play Services-fitbit.jpg
    08-04-16 12:30 PM
  12. KNReddy's Avatar
    I have followed all the steps and patched app ola cabs , but it is not showing maps.
    uber.apk works without patching as it takes to m.uber.com but if patched , maps integration breaks (blank map).

    For getting api keys, I have installed java sdk and android studio on PC, then I got Sha-1 signature from PC.

    I have given package name as com.ubercab, .....and above sha-1
    To get google maps api, similarly geolocation key for Uber.apk. Both with space without space I have tried.

    Is there any errors in the above process of getting keys , you may please explain step by step for getting api keys incl any tips and tricks.
    08-05-16 09:11 PM
  13. nikhildhoot's Avatar
    Hey guys...First of all let me thank Cobalt, Nahadoth and all the other guys for their efforts in patching apps and helping others do the same. I am trying to patch the latest release of Pokmon Go downloaded from APK Mirror but I do need some help. Can anyone help me with instructions on generating the Android keys required for this. More specifically I need help with getting the SHA1 signature for the APK file. I have read Nahadoth's instructions and am probably either missing something or probably just don't know enough. Any help would be greatly appreciated.
    Thanks
    08-07-16 01:55 PM
  14. rbtg's Avatar
    i thought I've read that you can't play it on bb10 because of the ART 4.3
    08-07-16 02:05 PM
  15. rbtg's Avatar
    I have followed all the steps and patched app ola cabs , but it is not showing maps.
    uber.apk works without patching as it takes to m.uber.com but if patched , maps integration breaks (blank map).

    For getting api keys, I have installed java sdk and android studio on PC, then I got Sha-1 signature from PC.

    I have given package name as com.ubercab, .....and above sha-1
    To get google maps api, similarly geolocation key for Uber.apk. Both with space without space I have tried.

    Is there any errors in the above process of getting keys , you may please explain step by step for getting api keys incl any tips and tricks.

    it didn't work for me either ,followed step by step then i messed with api keys
    you got to go to manager after you generate the keys then click on google maps api and click on enable ,then copy and paste the keys
    do the same thing for both keys
    good luck
    08-07-16 02:16 PM
  16. C_McD's Avatar
    Cobalt, Nahadoth did a nice summary post #3082, but it'd be nice to have a slightly more detailed "Manual" since it'd be helpful to those of us that aren't Android current/savvy.

    Just a thought.

    Thanks for all your hard work.

     Z30 10.3.2.858 USA
    08-07-16 03:30 PM
  17. 1978dll's Avatar
    This continues to fail using the latest fitbit app.
    08-09-16 10:07 AM
  18. 1978dll's Avatar
    However it does seem to work successfully on the NFL Mobile app
    08-09-16 10:10 AM
  19. TSY-CB's Avatar
    Hi Cobalt, Conite,

    Wondering if you could help - there's a new taxi app, CURB, that I've been trying unsuccessfully to patch & install. I used both GMaps patcher win v4.1-final.exe and PS_Patcher-1.5-beta2.exe. The apktool.jar does not show a version number in it's properties, but it's dated 10/13/2015.

    On both patches, the apk installs, and runs fine until I try and log in, whereupon I get a "Curb requires one or more Google Play Services that are not currently available. Please contact the developer for assistance." A screenshot is attached.

    As a side note, this is from the same developer as Way2Ride, another taxi app that runs fine since I patched it back in June 2016.

    Is there a later version of apktool.jar or indeed the patcher app?

    Thanks in advance,

    TSHow to patch Android Apps depending on Google Maps and Google Play Services-img_20160812_123906.png
    08-12-16 11:58 AM
  20. conite's Avatar
    Hi Cobalt, Conite,

    Wondering if you could help - there's a new taxi app, CURB, that I've been trying unsuccessfully to patch & install. I used both GMaps patcher win v4.1-final.exe and PS_Patcher-1.5-beta2.exe. The apktool.jar does not show a version number in it's properties, but it's dated 10/13/2015.

    On both patches, the apk installs, and runs fine until I try and log in, whereupon I get a "Curb requires one or more Google Play Services that are not currently available. Please contact the developer for assistance." A screenshot is attached.

    As a side note, this is from the same developer as Way2Ride, another taxi app that runs fine since I patched it back in June 2016.

    Is there a later version of apktool.jar or indeed the patcher app?

    Thanks in advance,
    Seems to work for me. Did you populate the maps api keys?

    Also, you can try updating to the newest apktool (2.2.0) if you like. https://ibotpeaches.github.io/Apktool/
    How to patch Android Apps depending on Google Maps and Google Play Services-img_20160812_131834_edit.png

    Priv STV100-1/AAF960 Z30STA100-5/10.3.3.746
    08-12-16 12:22 PM
  21. TSY-CB's Avatar
    Seems to work for me. Did you populate the maps api keys?

    Also, you can try updating to the newest apktool (2.2.0) if you like. https://ibotpeaches.github.io/Apktool/
    Click image for larger version. 

Name:	IMG_20160812_131834_edit.png 
Views:	645 
Size:	58.1 KB 
ID:	406256

    Priv STV100-1/AAF960 Z30STA100-5/10.3.3.746
    Sorry, not familiar w maps api keys....are they files in the "lib" folder?

    SQC100-3 | 10.3.2.858
    08-12-16 02:40 PM
  22. conite's Avatar
    Sorry, not familiar w maps api keys....are they files in the "lib" folder?

    SQC100-3 | 10.3.2.858
    You have to get your own Android developer maps API keys and input them into the Patcher app. This allows mapping to work within an app.
    08-12-16 03:24 PM
  23. TSY-CB's Avatar
    You have to get your own Android developer maps API keys and input them into the Patcher app. This allows mapping to work within an app.
    Thx 4 responding Conite.

    Ah, and that would be the hard part, I'm assuming. Any tips? Sorry for the ignorance, haven't been on the forums or really dug into this yet. Any help would be most appreciated.

    On another note, if Cobalt is reading this, I have to say that your efforts are amazing, made a donation first time it worked, in June. You deserve to be compensated for the shear number of people you've helped.

    SQC100-3 | 10.3.2.858
    08-12-16 03:37 PM
  24. conite's Avatar
    Thx 4 responding Conite.

    Ah, and that would be the hard part, I'm assuming. Any tips? Sorry for the ignorance, haven't been on the forums or really dug into this yet. Any help would be most appreciated.

    On another note, if Cobalt is reading this, I have to say that your efforts are amazing, made a donation first time it worked, in June. You deserve to be compensated for the shear number of people you've helped.

    SQC100-3 | 10.3.2.858
    Start here:

    https://developers.google.com/maps/android/
    08-12-16 04:06 PM
  25. Jay Kim_BB's Avatar
    Hi, nice to meet you. also really thank you for your help
    Basically, I have a Black berry classic & OS version is 10.3.2.2836 (I updated 11.08.2016 yesterday)

    simply, successfully I installed 3 APK files (login, ID, play service)
    after that, I installed couples of google's apps

    Then, when I run Google maps app. screen is only black. <- first problem
    also when I run google keep app.<- second problem
    I can see next message
    "Keep relies on Google play services, which is not supported by your device. Contact the manufacturer for assistance."

    so, I can search GMS pacther, this pacther also successfully done.
    but now I have a stuck .how can I uninstall previous google map app & android.gms APK files?

    Google play store said google map apps is already installed.
    some one tell to me please, how can I uninstall?
    08-12-16 10:52 PM
4,042 ... 124125126127128 ...

Similar Threads

  1. how do you clean install a BB10 device using Link?
    By gameson in forum BlackBerry 10 OS
    Replies: 14
    Last Post: 04-01-15, 07:54 AM
  2. Android Apps no Longer Working? Candy Crush?
    By raxamillion in forum More for your BlackBerry 10 Phone!
    Replies: 41
    Last Post: 05-05-14, 04:04 AM
  3. Best Remote desktop App?
    By alejandrohn5 in forum BlackBerry Z10
    Replies: 7
    Last Post: 04-01-14, 11:16 PM
  4. Can DLNA Rendering be Enabled by an APP?
    By Cynycl in forum BlackBerry PlayBook
    Replies: 4
    Last Post: 03-15-14, 02:25 PM
  5. Question about 10.2 and sim.
    By Watcher777 in forum BlackBerry Z10
    Replies: 1
    Last Post: 03-14-14, 03:00 PM
LINK TO POST COPIED TO CLIPBOARD