1. BigBadWulf's Avatar
    Yes but I do have some apps on my phone that have maps and I patched them and they only work with his patched Google Servers . So I don't really want two Google Servers installed. Anyway is there a way to patch Google Servers to a more updated on or is a updated one out?
    Google servers?
    07-27-16 07:19 PM
  2. conite's Avatar
    Yes but I do have some apps on my phone that have maps and I patched them and they only work with his patched Google Servers . So I don't really want two Google Servers installed. Anyway is there a way to patch Google Servers to a more updated on or is a updated one out?
    Google Play SERVICES.

    You can only install one. Cobalt's landing page currently hosts build5, which you need when patching apps that use mapping functions. You also have to use your own Android developer maps API key.

    Use Play Services Patcher 1.5beta with the newest apktool (2.1.1).
    Last edited by conite; 07-28-16 at 07:18 AM.
    07-27-16 07:24 PM
  3. Shyam Prasad Reddy Mora's Avatar
    You are missing Cobalt's modified Google Play Services.
    Oh. Ok. I patched with with Cobalt's apps. The post says "Google Play Services -> Removed with no replacement". Is there any way I can get Google Play Services ?
    07-28-16 01:39 AM
  4. conite's Avatar
    Oh. Ok. I patched with with Cobalt's apps. The post says "Google Play Services -> Removed with no replacement". Is there any way I can get Google Play Services ?
    What did you patch? I hope you're not talking about Cobalt's modified Google Play Services - he already worked his magic on all of his files.

    By the way, you will be able to sign into GMaps, but will not be able to save maps. This is a current limitation on BB10.
    07-28-16 07:21 AM
  5. pomidor's Avatar
    I was this close to throwing in the towel and buying a Priv, but I finally today got the 2 apps I wanted to work (Google Maps and Uber) on my passport. Fingers-crossed they keep working until the next update when I will have to patch again.

    First I want to give a lot of thanks to Cobalt for the programs and the other posters who are still posting to help people!

    However, for some of us who are less experienced / tech-savvy - this whole process can be very confusing. Especially now that this thread is over 100 pages and some of the things on Cobalt's first page are outdated.

    This thing really needs a step-by-step guide with like screenshots, or like a FAQ - because I kept seeing some of the same questions that I was having trouble with but maybe I would find the answer on page 118 or like page 74 or something.

    Anyway for those who are having trouble, I thought I would outline my steps for patching Google Maps and Uber (this all assumes you got Google Play Store already working) in the hopes that this would help some new people coming to this thread (like me) who are not so tech-savvy and honestly don't have time to read 50+ pages:

    1. If my app was asking for Google Play Services -> I just patched like regular (see steps below but ignore API and Decompile steps)

    2. If my app was showing blank maps -> it seems this is because it is using a Google Map API and you need to add your own API keys into the patched app (i.e. Uber)

    3. Some apps cannot work even after patching -> i.e. Snapchat

    Set up Patcher on my PC:
    - On your PC, go to Cobalt's file storage site and download i) the Patcher 1.4 and extract - it will create a PS_Patcher-1.4 folder with some files in it including the Gmaps 1.4 program, then ii) download the Patcher 1.5 beta exe and also copy this exe file into the extracted Patcher 1.4 folder
    - You may need to install Java on your PC, and then start the Patcher program and go to the "Paths" tab on the Patcher and make sure Java is showing linked correctly on the "Java.exe" box
    - For some of the Android apps that use Google Maps (like Uber) you will now need to add your own Google Map API keys when you are doing the rebuilding patch - this is done with the Patcher 1.5 beta.
    - First get your own API keys by going here - I got "Android API" and "Geolocation API" keys:
    Android API
    Geolocation API
    - Copy each of these API strings (my strings each had a space at the end so I copied that as well, not sure if it made a difference but the first set of APIs I copied without the ending spaces didn't make the patch work in my Blackberry) into the Patcher 1.5 application: start the Patcher 1.5, go to the "Google Maps" tab, paste in the Android API key and then the Geolocation API key into those boxes

    - You will also need to replace the "apktool" file for the Patcher with the latest version
    - Download the latest apktool file from here: [URL]https://ibotpeaches.github.io/Apktool/[URL]. Latest I had was v2.1.1.
    - Go to the Patcher folder on your PC -> then "lib" folder.
    - After downloading this apktool v2.1.1, I renamed it to "apktool", and then just copied to replace the existing "apktool" file already in the "lib" folder

    - Then I started up the Patcher 1.5 beta again, went to the "Options" tab, checked the "Decompile resources" box (so that it would use my own API keys for recompiling the uber app) and then clicked "Update Framework" button on the right - to use the new programs

    Then I got my apps on my Blackberry and transferred them to my PC:
    - Uninstalled any existing version of Uber on my Blackberry by going to the Google Play Store -> My Apps and uninstalling
    - Also checked with the "GhostCommander" app on my phone that the Uber app was properly removed from my phone
    - Go to the Play Store app on your Blackberry and download the Uber app. Do not install it, it will download to the "Downloads" folder
    - Go to "File Manager" on the Blackberry and then "Downloads" - you will see something like ubercab.apk
    - I moved the ubercab.apk file onto a micro-SD card on my Blackberry, then plugged the SD-card into my tablet and copied the ubercab.apk file into a separate folder on my PC

    Patching on PC:
    - Started Patcher 1.5 beta
    - Made sure my Google API keys were loaded on the "Google Maps" tab, and that "Decompile resources" was checked on the "Options" tab
    - The clicked "Browse" and linked to the ubercab.apk that I had just copied to my PC
    - Clicked "Analyze APK", it will decompile. Once Analysis is complete there should be option to "Continue"
    - Once it is all done there will be an ubercab-patched.apk file in an "output" folder in the Patcher folder
    - Copied this to my SD card

    Installing on Blackberry:
    - Move the patched uber apk file from my SD card to my Downloads folder on my Blackberry
    - Then tapped this uber apk file and it will boot up and install and was running correctly with full map showing

    For the Google Maps app itself
    - You do not need the API keys for this or to Decompile
    - I used the 1.4 Patcher for this using the same process as above and then put it on my Blackberry
    - Even after this it was STILL showing blank maps, but when I restarted my Blackberry and went back in to the Google Maps app it was working!
    Dude, you friggen rock!

    I followed your steps and finally got Uber to work again. I though I was already doing what you listed when I tried patching many times before, but I must have been missing something. I just tried again while carefully following your instructions and it worked.

    Unfortunately, your instructions will get lost in the haystack as this thread keeps growing.

    Btw, I patched one app with the space at the end of the API key and one other app without the space. Both apps patched and the map is showing in each app.
    07-28-16 07:24 AM
  6. phil59000's Avatar
    Sorry for my english but i would take 5 minutes to congatulate Nahadoth for his work to synthesize the operations of patching applications with google map.

    I spent a lot of time to read the different posts and i was disapointed to make working my 2 application of city bike reservation.

    Firstly i encounter the problem of the bug to undelete properly the applications, i follow one thread to make some parameters and after i read that a fix exist on blackberryworld for the android runtime to solve this problem.

    Finally i success to patch the apk and to install them in ma bb classic but no map on the screen only the google logo.

    I finally read the Nahadoth post and i follow it with attention (in particular api key and apktool) and my 2 applications are now working so nice.

    Thank you very much and thanks at the crackberry team for their work too.

    Only one problem persist that would avoid me to take with me my android tablet on my back when i make sport is to be able to connect my smart blutooth hearth rate sensor to my blackberry but i think it's impossible. I think it's an hardware problem because the sensor work only on android or ios while it's bluetooth. No solution.
    07-28-16 09:06 AM
  7. BigBadWulf's Avatar
    Unfortunately, your instructions will get lost in the haystack as this thread keeps growing.
    Nope! Just took me a couple days to find time, and edit the OP.
    07-28-16 08:21 PM
  8. pomidor's Avatar
    Nope! Just took me a couple days to find time, and edit the OP.
    When I click the link you added at the bottom of the first post, it takes me to the top of this page instead of Nahadoth's post on the previous page. Can you check the link and adjust it, or what this intentional?
    07-29-16 08:03 AM
  9. C_McD's Avatar
    Nahadoth,

    Ah, maybe that's my issue on two apps I need. Google Maps work but apps calling it do not.

    Will give it a try - much appreciated!
    07-29-16 12:48 PM
  10. BigBadWulf's Avatar
    When I click the link you added at the bottom of the first post, it takes me to the top of this page instead of Nahadoth's post on the previous page. Can you check the link and adjust it, or what this intentional?
    What browser are you using? It's definitely a direct link.
    07-29-16 01:25 PM
  11. C_McD's Avatar
    Nahadoth,

    Ah, maybe that's my issue on two apps I need. Google Maps work but apps calling it do not.

    Will give it a try - much appreciated!
    Sigh, no luck - one app decompiled et al, but Maps still don't work after rebooting and the other app would not recompile.
    07-29-16 02:26 PM
  12. pomidor's Avatar
    What browser are you using? It's definitely a direct link.
    Chrome, Firefox, IE. Win 7, XP. Just tried in z30 Browser. Same result. I end up at the top of this page.

    This is the link I get from your post:
    ....how-patch-android-apps-depending-google-maps-google-play-services-914930/index155.html#post12515811

    This is the link I get from thread # 3082

    ..../how-patch-android-apps-depending-google-maps-google-play-services-914930/index124.html#post12515811

    Index is different

    Strange that it works for you but not me
    BigBadWulf likes this.
    07-30-16 02:48 AM
  13. BigBadWulf's Avatar
    Chrome, Firefox, IE. Win 7, XP. Just tried in z30 Browser. Same result. I end up at the top of this page.

    This is the link I get from your post:
    ....how-patch-android-apps-depending-google-maps-google-play-services-914930/index155.html#post12515811

    This is the link I get from thread # 3082

    ..../how-patch-android-apps-depending-google-maps-google-play-services-914930/index124.html#post12515811

    Index is different

    Strange that it works for you but not me
    Even stranger, testing both across a variety of browsers yielded varying results for me, so instead I set this as the direct link. Never had an issue before, using my original method.
    07-30-16 05:52 AM
  14. Saurabh Patel5's Avatar
    How to download java


    Posted via CB10
    07-30-16 06:46 AM
  15. Saurabh Patel5's Avatar
    Please help me


    Posted via CB10
    07-30-16 06:53 AM
  16. conite's Avatar
    How to download java


    Posted via CB10
    www.java.com
    gfondeur likes this.
    07-30-16 07:13 AM
  17. asari's Avatar
    How to patch Android Apps depending on Google Maps and Google Play Services-capture.png

    pls anyone help me in this case : I follow all the steps but the error keep appear : "the package can not be signed "
    I really want patch "chromecast" file but it keep fail
    Lucky Ladyy likes this.
    07-30-16 09:59 AM
  18. BigBadWulf's Avatar
    Click image for larger version. 

Name:	Capture.PNG 
Views:	250 
Size:	256.1 KB 
ID:	405156

    pls anyone help me in this case : I follow all the steps but the error keep appear : "the package can not be signed "
    I really want patch "chromecast" file but it keep fail
    Bud, enough with the duplicate posts. Someone familiar with the app will answer eventually. I'm not, but would assume it can't be patched.

    Edit - Did you try patcher version 1.3 as previously suggested to you?
    Smokeaire likes this.
    07-30-16 03:34 PM
  19. khalloudy's Avatar
    Hello everyone!

    First, thank you Cobalt for all the hard work and support you have given to the community; sad to see BB not providing the support we need!

    I have been trying to test WhatsApp but neither pure download and install from the Google Store works, nor the version after patching using the Patch 1.4 application. The unpatched version comes up with the error message saying that Google Services is required. When trying to install the patched version I get past the SMS versification send only to get a message after that there is something wrong with the application and I should install the latest from WhatsApp.

    Any help would be appreciated!
    07-31-16 05:56 PM
  20. KNReddy's Avatar
    If the above problem of Whatsapp is solved , whats app can be used after the deadline of ending of native support after December, 2016.
    08-03-16 10:31 AM
  21. Stanley008's Avatar
    Hi,
    is there still an apk Lucky Patcher to patch android services? Or any other way how to patch Android APK(Google services) on MAC? I don't have windows any more. Or could any good angel patch latest Android Wear apk? Thank You.
    08-03-16 11:49 AM
  22. conite's Avatar
    Hi,
    is there still an apk Lucky Patcher to patch android services? Or any other way how to patch Android APK(Google services) on MAC? I don't have windows any more. Or could any good angel patch latest Android Wear apk? Thank You.
    Android Wear doesn't work anyway.

    An no, there is no other way to patch but on a PC.
    08-03-16 11:51 AM
  23. Stanley008's Avatar
    It should atleast halfway work or not? I can't get pass the message that I don't have google services installed.

    Conite Could You patch the apk ?
    08-03-16 11:53 AM
  24. conite's Avatar
    It should atleast halfway work or not? I can't get pass the message that I don't have google services installed.

    Conite Could You patch the apk ?
    It can be patched, but it still won't be able to connect to the wear device. It's a limitation of the BlackBerry Android Runtime.
    08-03-16 11:58 AM
  25. Stanley008's Avatar
    And is there any other way how to connect Android Wear stuff to BB ?
    08-03-16 12:00 PM
4,042 ... 123124125126127 ...

Similar Threads

  1. how do you clean install a BB10 device using Link?
    By gameson in forum BlackBerry 10 OS
    Replies: 14
    Last Post: 04-01-15, 07:54 AM
  2. Android Apps no Longer Working? Candy Crush?
    By raxamillion in forum More for your BlackBerry 10 Phone!
    Replies: 41
    Last Post: 05-05-14, 04:04 AM
  3. Best Remote desktop App?
    By alejandrohn5 in forum BlackBerry Z10
    Replies: 7
    Last Post: 04-01-14, 11:16 PM
  4. Can DLNA Rendering be Enabled by an APP?
    By Cynycl in forum BlackBerry PlayBook
    Replies: 4
    Last Post: 03-15-14, 02:25 PM
  5. Question about 10.2 and sim.
    By Watcher777 in forum BlackBerry Z10
    Replies: 1
    Last Post: 03-14-14, 03:00 PM
LINK TO POST COPIED TO CLIPBOARD