10-13-16 12:08 PM
733 ... 7891011 ...
tools
  1. kfroese's Avatar
    This looks very cool! I'll admit I skipped to Post #36 and didn't bother reading the whole thread until I got stuck. I'm trying to modify/convert miCoach to use on my Q10 (running 10.2.1.1055) but I'm having an error with OpenSSL. Can anyone comment? I had an initoal error with it not finding a configuration file but modified my system environment variables to fix that one. This current input/output error has me stumped. TIA.
    How to fix any Android app dependent on Google Maps API and make maps working-openssl-error.png

    EDIT: Figured it out. My path to the config file was incomplete. Used this:
    Code:
    C:\> set OPENSSL_CONF=C:\OpenSSL-Win32\bin\openssl.cfg
    Last edited by kfroese; 11-19-13 at 04:34 PM. Reason: found own answer
    11-19-13 03:28 PM
  2. kfroese's Avatar
    This is amazing! Moneytoo is my hero! miCoach is on my phone and working! I haven't tried it running yet but looks awful promising!
    How to fix any Android app dependent on Google Maps API and make maps working-img_00000416.png

    Q10SQN100-1/10.2.1.1055
    11-19-13 04:41 PM
  3. Lendo's Avatar
    Ya, I've pretty much given up. My brain doesn't want to work this week LOL
    11-20-13 10:07 AM
  4. acschnitzersport's Avatar
    Could someone help with this process for BMW Remote? APK is saved here: https://share.n-sant.com:7001/fbsharing/XCjgqzTV

    I appreciate your help!
    11-20-13 10:17 AM
  5. dustmalik's Avatar
    I believe this process can be automated. I'm hoping someone with the required knowledge look into it and see what they can come up with. TBH, the process of modifying one app takes a lot of time.

    As I understand it, those who are on OS 10.2.1.1055 don't have to worry about modifying apps with Maps api v1 because it's already been implemented in the OS. Only apps with Maps api v2 still needs modification, right? Could someone clarify this for me?

    Posted via CB10 using my Gorgeous Z10
    11-20-13 11:01 AM
  6. Lendo's Avatar
    I believe this process can be automated. I'm hoping someone with the required knowledge look into it and see what they can come up with. TBH, the process of modifying one app takes a lot of time.

    As I understand it, those who are on OS 10.2.1.1055 don't have to worry about modifying apps with Maps api v1 because it's already been implemented in the OS. Only apps with Maps api v2 still needs modification, right? Could someone clarify this for me?

    Posted via CB10 using my Gorgeous Z10
    I don't think so. I tried using Quebec511 and it doesn't work and I'm pretty sure it uses v1.
    11-20-13 11:28 AM
  7. kfroese's Avatar
    Could someone help with this process for BMW Remote? APK is saved here: https://share.n-sant.com:7001/fbsharing/XCjgqzTV

    I appreciate your help!
    No promises that this will work since I didn't try it myself but let me know!

    https://www.dropbox.com/s/os6xif8jru...ote-signed.apk
    11-21-13 04:18 PM
  8. Icarus3000's Avatar
    Will this allow me to log in to youtube from the android app?

    Posted via CB10
    11-21-13 08:26 PM
  9. platyias's Avatar
    This is fantastic, thanks so much!! I could get the v1 method to work on 10.2.1.1055, the tiles were not showing previously.
    Last edited by platyias; 11-21-13 at 09:03 PM.
    11-21-13 08:34 PM
  10. acschnitzersport's Avatar
    No promises that this will work since I didn't try it myself but let me know!

    https://www.dropbox.com/s/os6xif8jru...ote-signed.apk
    I appreciate your help! I am getting a "No Internet Connection Available" Error. Got this on my attempt too. I've tried wifi and WAN, rebooting between the 2, closing the app between the 2. Pretty annoying.

    Again, Thank you for your help and time.

    Posted via CB10
    11-22-13 02:42 PM
  11. kfroese's Avatar
    I appreciate your help! I am getting a "No Internet Connection Available" Error. Got this on my attempt too. I've tried wifi and WAN, rebooting between the 2, closing the app between the 2. Pretty annoying.

    Again, Thank you for your help and time.

    Posted via CB10
    Ok, I got curious and tried it for myself. Screenshot shows how far I got. Is thiss were you got to? I don't haave a username/password so couldn't take it further.
    How to fix any Android app dependent on Google Maps API and make maps working-img_00000422.png

    Q10SQN100-1/10.2.1.1055
    11-22-13 03:59 PM
  12. wcowings's Avatar
    Starbucks works on my Z10
    11-23-13 02:44 PM
  13. wcowings's Avatar
    Starbucks works on my Z10
    Starbucks all, please!

    Posted via CB10
    11-23-13 02:45 PM
  14. Sally Mack's Avatar
    Starbucks works on my Z10
    Care to share? Lots of people looking for this app.
    11-23-13 06:00 PM
  15. dustmalik's Avatar
    The latest Starbucks works without any modification to the app or installing of Google login service or Google Play services on OS 10.2.1.1055.

    Posted via CB10 using my Gorgeous Z10
    wcowings likes this.
    11-24-13 05:20 AM
  16. Sally Mack's Avatar
    For those who have been having problems getting uber to work, I re-built it from scratch and tested again. Tiles working fine for me, so give this a shot https://mega.co.nz/#!uFd3wLab!Caf1lk...fNMACTpg2ISw0I
    11-24-13 01:10 PM
  17. Sally Mack's Avatar
    I'm trying to convert hailo using the api v2 method, however the only reference to "isgoogleplayservicesavailable" is in LauncherActivity.smali as part of ".method public onResume()V", and all it shows re google play services is ""isGooglePlayServicesAvailable() = ".

    I tried the v1 method and I get a google play services nag screen. I tried replacing ""isGooglePlayServicesAvailable() = " with
    Code:
    "isGooglePlayServicesAvailable(Landroid/content/Context;)I
        .locals 1
        .parameter "context"
    
        .prologue
        const/4 v0, 0x0
    	
        return v0"
    to no avail (apktool spits out an error about the launcheractivity.smali file). Any help on how I could tackle this?
    11-24-13 01:58 PM
  18. Jsolts's Avatar
    Could someone convert this pioneer radio app

    This is the link to the apk in my drop box.
    https://db.tt/ERC042AE

    Thanks

    Posted on a Post-It!
    11-24-13 10:32 PM
  19. acschnitzersport's Avatar
    Yes, I got to that area, the issue is I get a "no connection" error when I try to log in. Try using any email, pw combo and see if it says either username password incorrect, or no connection. If you get the former, it may be my device.

    Posted via CB10
    11-25-13 12:54 PM
  20. Pluto is a planet's Avatar
    For those who have been having problems getting uber to work, I re-built it from scratch and tested again. Tiles working fine for me, so give this a shot https://mega.co.nz/#!uFd3wLab!Caf1lk...fNMACTpg2ISw0I
    Still doesn't work for me I'm on 1055. Once I login it crashes.

    Posted via CB10
    11-25-13 04:06 PM
  21. Sally Mack's Avatar
    Not sure if it makes any difference but I'm on official 10.2.0.1802. Maybe something in 1055 doesn't like something in this app.

    Do you have Google play services installed? I just realized this may be playing a part as well.
    11-25-13 08:39 PM
  22. Jsolts's Avatar
    Could someone convert this pioneer radio app

    This is the link to the apk in my drop box.
    https://db.tt/ERC042AE

    Thanks

    Posted on a Post-It!
    Not trying to be a pain but could someone fix this apk for me.

    Really burning to see if this will fix my issues, but I think attempting this myself is a bit over my head.


    Thanks in advance

    Posted on a Post-It!
    11-26-13 12:00 PM
  23. Jsolts's Avatar
    i attempted this fix myself tonight but keep getting stuck at recompiling......

    i keep getting this error.....

    How to fix any Android app dependent on Google Maps API and make maps working-error.jpg


    Any suggestions?

    I followed all the steps in post #38 and cannot get past this point...
    11-26-13 10:37 PM
  24. Pluto is a planet's Avatar
    Not sure if it makes any difference but I'm on official 10.2.0.1802. Maybe something in 1055 doesn't like something in this app.

    Do you have Google play services installed? I just realized this may be playing a part as well.

    Nooope I don't. How would I go about installing play services? I was under the impression everything google was still blacklisted.
    11-26-13 10:39 PM
  25. Sally Mack's Avatar
    Nooope I don't. How would I go about installing play services? I was under the impression everything google was still blacklisted.
    Almost everything... sorta kinda. check out this thread which has some apks you can install + directions.
    http://forums.crackberry.com/showthread.php?t=866259
    11-27-13 08:03 AM
733 ... 7891011 ...

Similar Threads

  1. Best Leak to Run on T-Mobile Network?
    By AfroZepher in forum BlackBerry 10 OS
    Replies: 16
    Last Post: 01-21-15, 07:29 AM
  2. Manually program BB10 device to set MDN and MSID?
    By onlinespending in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 10-20-13, 12:26 PM
  3. My Z10 updated now I can't hook up to wifi
    By Tony Stashuk in forum BlackBerry Z10
    Replies: 5
    Last Post: 10-19-13, 11:44 PM
  4. Used sachesi and SR version still says 4181??
    By sinnar in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 10-19-13, 08:18 PM
LINK TO POST COPIED TO CLIPBOARD