10-13-16 12:08 PM
733 ... 1920212223 ...
tools
  1. carbon98accord's Avatar
    I am trying to get Uber and Yelp to work on my Z10 10.2.1.1925...I have installed patched-GoogleLoginService-573038.apk and patched-GooglePlayService-4034536.apk and Google Maps 6.14.4. Google Maps appears to be working, but Uber does not get past the login screen. Any help/guidance would be extremely appreciated
    02-12-14 12:10 PM
  2. dustmalik's Avatar
    Uber still needs to be patched. Use Cobalt's script to patch it.

    Posted via CB10 using my Gorgeous Z10
    carbon98accord likes this.
    02-12-14 12:51 PM
  3. carbon98accord's Avatar
    Uber still needs to be patched. Use Cobalt's script to patch it.

    Posted via CB10 using my Gorgeous Z10
    It worked! Woot!
    02-12-14 01:39 PM
  4. Sally Mack's Avatar
    Same with yelp. Patch using cobalt's tool and you'll be good to go.
    02-12-14 03:11 PM
  5. 3Athlete's Avatar
    Hey guys,

    I'm trying to get the Rossignol Ski Pursuit app to work right now.

    So far:

    1. I've downloaded the 2.5.1 gmaps apk patcher.
    2. Placed the rossignol apk in the main directory.
    3. Run the patcher and selected the apk.
    4. Chose "g" when given the option to.

    Following this the cmd prompt closes and there is no file to be found in the output folder. I put the apk in the main directory back onto by phone but it still returns the google services dependency.

    Any idea what may be happening?

    EDIT**

    I've also tried the autopatch option and the window closes without any file in the output folder.
    02-12-14 03:40 PM
  6. mitfry's Avatar
    Hey guys,

    I'm trying to get the Rossignol Ski Pursuit app to work right now.

    So far:

    1. I've downloaded the 2.5.1 gmaps apk patcher.
    2. Placed the rossignol apk in the main directory.
    3. Run the patcher and selected the apk.
    4. Chose "g" when given the option to.

    Following this the cmd prompt closes and there is no file to be found in the output folder. I put the apk in the main directory back onto by phone but it still returns the google services dependency.

    Any idea what may be happening?

    EDIT**

    I've also tried the autopatch option and the window closes without any file in the output folder.
    Remove all spaces and other special characters from the APK's file name and try again

    Example:
    "com supercell clashofclans.apk" -> "com_supercell_clashofclans.apk"

    In this case, I replaced all spaces " " with underscores "_"
    02-12-14 04:20 PM
  7. Cobalt232's Avatar
    You should try to open a CMD Shell and then run the script from there instead of running it directly from file explorer.

    You will then see the error that causes the script to exit. Most likely you have a problem with Java path.

    Posted via CB10
    02-12-14 04:24 PM
  8. mitfry's Avatar
    Cobalt, I would like to ask you a couple of questions regarding the steps and processes of your APK-Patcher. I would like to understand the changes better and try to manually edit the code. Can I contact you though BBM or skype chat?
    02-12-14 04:46 PM
  9. eywong's Avatar
    Hey Cobalt could you possibly be up to patching google play services 4.2.34 anytime soon?
    Google released version 4.2.42, today.

    Edit 02-15: Is there an automated patcher for Google Play services apk?
    Last edited by eywong; 02-17-14 at 01:42 PM.
    02-12-14 07:35 PM
  10. eywong's Avatar
    Here is the link to the correctly patched Google Login Services
    I got message, "Unable to install this app" and the Google Account Manager icon was added to the Home screen. It crashed/closed when I tried to run it. (To install, I clicked on the .apk in the native File Manager.)
    Z10STL100-3/10.2.1.1925
    02-13-14 11:32 AM
  11. Cobalt232's Avatar
    Make sure that you remove all previous versions (check with Ghost Commander). Then reboot device and reinstall.

    The error occures if you have mixed signatures in Google login Services and Google Play Services.



    Posted via CB10
    02-13-14 11:59 AM
  12. eywong's Avatar
    The error occurs if you have mixed signatures in Google login Services and Google Play Services.
    Hmm. I thought both apps came from your collection. I will check my downloads.

    cobalt-com.google.android.gsf.login-573038.apk (ref. post #478)

    Google Play services 4.1.32 (978161-36) patched.apk (ref. post #1)
    Last edited by eywong; 02-17-14 at 01:43 PM.
    02-13-14 01:13 PM
  13. kfroese's Avatar
    Can one of you that has this script working try stripping the Google Play Services dependency from Dash? Link: https://db.tt/4Ju2RGfn. And don't worry, the app is free.

    Thanks in advance!

    Q10SQN100-1/10.2.1.1925
    02-14-14 12:02 AM
  14. mitfry's Avatar
    Can one of you that has this script working try stripping the Google Play Services dependency from Dash? Link: https://db.tt/4Ju2RGfn. And don't worry, the app is free.

    Thanks in advance!

    Q10SQN100-1/10.2.1.1925
    Done. Patched using version 2.6 of cobalts APK Patcher. You will also need to install the patched version of Google Play Services.

    I have created a zip of the files. Remember, both files inside the ZIP file need to be installed.
    Enjoy.

    https://dl.dropboxusercontent.com/u/...android.40.zip
    kfroese and eywong like this.
    02-14-14 06:17 AM
  15. kfroese's Avatar
    Thanks - it works great now! Doesn?t fix the screen size issues on my Q (I can't see the bottom of some menus) but that isn't your fault.

    Cobalt - you, sir, are a genuis! I'm inspired now to see if I can get the script to run.

    Q10SQN100-1/10.2.1.1925
    02-14-14 09:16 AM
  16. millwright40's Avatar
    Hi,

    I have been trying to patch this apk https://play.google.com/store/apps/d...raffic.android with GMS APK patcher V2.6, I have this app Beat_the_Traffic.apk in the same directory as the patch & i drag it over the patch.bat and the patch opens and then closes. If I open the patch.bat and hit the F key it says their is no apk. I have Java 7.51 64 bit running, Windows 7, acquired the app from the Google store using real apk leecher V 1.3.6 . I am not sure what I am doing wrong and I have read the thread from page 1 to 21 trying to see if I have missed a step, I am just not seeing it.

    Could I ask for someones help?

    Kind Regards
    Vernon
    Last edited by millwright40; 02-14-14 at 08:42 PM. Reason: added detail
    02-14-14 06:50 PM
  17. Cobalt232's Avatar
    What is your installationpath?

    Posted via CB10
    02-15-14 01:00 AM
  18. millwright40's Avatar
    What is your installationpath?

    Posted via CB10
    Hi Cobalt232,

    I took A break from the process to re think what I had read & you put your finger on exactly what I found on page 20 when you helped ewong with the same problem. The path was incorrect & I used the example you gave to ewong & the apk was recognized. The patch wanted to decompile the apk and halted part way through the prosess with an error, I was working on this during break at work when this happened and as luck would have it I was called to a break down so I had to close the process & so I did not have time to record the error code or the reason for the stop.

    I won't have a chance to continue with patching the apk until Sunday, then I can take A look to see what else I may have goten wrong!

    I would like to take this opportunity to Thank You for your quick response to my question and your overall participation on this thread. I realize that this knowledge base came about as A result of all the participants, but you have been one of the driving forces behind this thread.

    Kind Regards
    Vernon
    Last edited by millwright40; 02-15-14 at 10:37 AM.
    02-15-14 02:01 AM
  19. eywong's Avatar
    Hi millwright40. I am not clear what issues you are having, but I would like to summarize for you what works for me.

    1. Unzip gmaps-apk-patcher-v2.6.zip to path C:\
    2. Copy/move the .apk file to be patched to folder C:\gmaps-apk-patcher-v2.6
    3. Open a Command Prompt window
    4. In the Command Prompt window, enter "cd C:\gmaps-apk-patcher-v2.6"<return> (note: don't enter quotes; <return> is the "return" key)
    5. In the Command Prompt window, enter "patch"<return>
    6. In the Command Prompt window, respond to the prompts
    7. At the prompt "Press any key", I press Ctrl-C to abort the script. Otherwise, it will patch the .apk again. (Cobalt232 says he doesn't see my issue.)
    millwright40 likes this.
    02-15-14 02:40 PM
  20. BAV0's Avatar
    can someone help me and patch "Munzee" http://bav0.com/random_shizzle/com.m...client-289.zip
    I have no idea what i'm doing wrong...
    02-16-14 04:49 AM
  21. mitfry's Avatar
    can someone help me and patch "Munzee" http://bav0.com/random_shizzle/com.m...client-289.zip
    I have no idea what i'm doing wrong...
    Done! Patched using Cobalt's APK patcher v2.6. I have not tested it but the patch was succesful without any errors. I have created a ZIP file, you need to install BOTH files inside the ZIP to get the app to work. Good luck!

    Download link:
    https://dl.dropboxusercontent.com/u/...client-289.zip

    For everyone:
    I don't mind patching APK's for fellow CrackBerry members but please remember this thread is not intented to ask others to patch your APK's. Cobalt has written an easy to use patcher which he shared with us and all you need to do is simply follow the instructions. Just read through them and I'm sure everyone can patch APK's theirselves, just spend a little time on it . Ofcourse you can always post other related questions here!
    millwright40 likes this.
    02-16-14 06:53 AM
  22. Sally Mack's Avatar
    For everyone:
    I don't mind patching APK's for fellow CrackBerry members but please remember this thread is not intented to ask others to patch your APK's. Cobalt has written an easy to use patcher which he shared with us and all you need to do is simply follow the instructions. Just read through them and I'm sure everyone can patch APK's theirselves, just spend a little time on it . Ofcourse you can always post other related questions here!
    Well said. I'd rather spend an hour of my time going back and forth troubleshooting why someone can't get the patcher, or a specific apk to work then spend the 10 seconds it takes to convert it myself.

    So basically: don't ask us to patch your apk's until after you've tried it yourself.
    02-16-14 10:57 AM
  23. BAV0's Avatar
    Done! Patched using Cobalt's APK patcher v2.6. I have not tested it but the patch was succesful without any errors. I have created a ZIP file, you need to install BOTH files inside the ZIP to get the app to work. Good luck!

    Download link:
    https://dl.dropboxusercontent.com/u/...client-289.zip

    For everyone:
    I don't mind patching APK's for fellow CrackBerry members but please remember this thread is not intented to ask others to patch your APK's. Cobalt has written an easy to use patcher which he shared with us and all you need to do is simply follow the instructions. Just read through them and I'm sure everyone can patch APK's theirselves, just spend a little time on it . Ofcourse you can always post other related questions here!
    Thanks a lot! I did try the patcher, but I couldn't get it to work :/ That's why I asked your help.
    The app works, it doesn't complain about the Google play services anymore and it doesn't crash, but the map tiles don't load, all maps are blank. Any suggestions?
    Last edited by BAV0; 02-16-14 at 04:32 PM.
    02-16-14 12:10 PM
  24. carbon98accord's Avatar
    I have a Korean game that I've tried to patch on both 2.5.1 and 2.6 without any luck...both say that there's nothing to patch...It looks like it has a Google Play dependency (when you first load the program, it tries to open Google Play on my BlackBerry)...im not sure if maybe some of the Korean characters may be the cause of it not working? Any help would be greatly appreciated! Thanks in advance!

    https://dl.dropboxusercontent.com/u/...service-16.apk
    02-17-14 06:24 PM
  25. 2Big2Strong2Fast's Avatar
    Hey guys,

    Tried following the instructions to patch the latest Uber apk, and Cobalt's patch script is unable to rebuild the Uber apk after completing about 2-3 minutes of other successful steps. Anyone have any luck?
    02-17-14 08:17 PM
733 ... 1920212223 ...

Similar Threads

  1. Best Leak to Run on T-Mobile Network?
    By AfroZepher in forum BlackBerry 10 OS
    Replies: 16
    Last Post: 01-21-15, 07:29 AM
  2. Manually program BB10 device to set MDN and MSID?
    By onlinespending in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 10-20-13, 12:26 PM
  3. My Z10 updated now I can't hook up to wifi
    By Tony Stashuk in forum BlackBerry Z10
    Replies: 5
    Last Post: 10-19-13, 11:44 PM
  4. Used sachesi and SR version still says 4181??
    By sinnar in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 10-19-13, 08:18 PM
LINK TO POST COPIED TO CLIPBOARD