10-13-16 12:08 PM
733 ... 1819202122 ...
tools
  1. Cobalt232's Avatar
    The error when I tried to patch:
    Error: Unable to rebuild "com.groupon-3166".apk.
    I: Try option [r] to decompile without resources
    I: This will not work with API v1 or API v2

    No errors when I patched it using v2.5.1. However, when I ran the patched version, it terminated with "Unfortunately, Groupon has stopped running." (Not sure if I should install the com.google.android.gms.apk from the output folder or if I should continue using the gms 1.0.326.6136 that is already installed on my Z10. Please advise.)
    I just patched Groupon with 2.6 and in run through without any errors. Can you be more specific about the error you get? Did you use automode or did you force patching API v1/v2?
    02-07-14 02:10 PM
  2. Cobalt232's Avatar
    The issue persists in v2.6. The attached screen shot of the second iteration may provide clarification of my description.
    Maybe additional logic is needed here in patch.bat:
    CALL :ECHOB "[FINISHED]"
    ECHO.
    PAUSE
    GOTO MENU
    Just a question to clarify the situation: If you run patcher.bat, without any arguments, do you see the menu?
    02-07-14 02:13 PM
  3. Cobalt232's Avatar
    Dear @Cobalt232 !
    I've already used GMAPS Patcher v2.5.1 to patch a game Clash of Clans but nothing is patched.



    Pls guide me (and more other members, I think so ) to patch this game to sign in G+ using Google Play Service.

    Thank you for any help you can provide in this situation
    There is no patching needed for Clash of Clans. The patcher doesn't find any dependencies. You can try to login to Google+ with GoogleLoginServices, but I don't think it will work: Download

    Make sure you are using the latest OS 10.2.1.1925 (SW 537)
    BluE iS likes this.
    02-07-14 02:19 PM
  4. eywong's Avatar
    Just a question to clarify the situation: If you run patcher.bat, without any arguments, do you see the menu?
    I see the menu when I run patch.bat without any arguments. See attached screen shot. (I double-clicked on the patch.bat icon in the gmaps-apk-patcher-v2.6 folder and I then entered "1" in the CMD window.)
    How to fix any Android app dependent on Google Maps API and make maps working-2014-02-07_14-41-22.jpg
    02-07-14 04:53 PM
  5. eywong's Avatar
    I just patched Groupon with 2.6 and in run through without any errors. Can you be more specific about the error you get? Did you use automode or did you force patching API v1/v2?
    I just tried patching again. Same error result. (I neglected to provide exception info in my prior posting. Sorry.)

    ---------------------------------------------------------
    [REBUILDING APK]
    I: Using Apktool 2.0.0-Beta9 on com.groupon-3166
    I: Checking whether sources has changed...
    I: Smaling...
    I: Checking whether resources has changed...
    I: Building resources...
    I: Building apk file...
    I: Copying unknown files/dir...
    Exception in thread "main" java.nio.file.FileSystemNotFoundException: <deleted>\gmaps-apk-patcher-v2.6\com.groupon-3166-notsigned.apk
    at com.sun.nio.zipfs.ZipFileSystem.<init>(ZipFileSyst em.java:120)
    at com.sun.nio.zipfs.ZipFileSystemProvider.newFileSys tem(ZipFileSystemProvider.java:117)
    at java.nio.file.FileSystems.newFileSystem(Unknown Source)
    at java.nio.file.FileSystems.newFileSystem(Unknown Source)
    at brut.androlib.Androlib.insertFolder(Androlib.java: 599)
    at brut.androlib.Androlib.buildUnknownFiles(Androlib. java:566)
    at brut.androlib.Androlib.build(Androlib.java:294)
    at brut.androlib.Androlib.build(Androlib.java:258)
    at brut.apktool.Main.cmdBuild(Main.java:236)
    at brut.apktool.Main.main(Main.java:88)

    Error: Unable to rebuild "com.groupon-3166".apk.
    I: Try option [r] to decompile without resources
    I: This will not work with API v1 or API v2

    [CLEANING UP]
    ---------------------------------------------------------

    I see file com.groupon-3166-notsigned.apk in the gmaps-apk-patcher-v2.6 folder.
    I ran in a CMD window. I CD'ed to the gmaps-apk-patcher-v2.6 folder and then I launched patch.bat from the command line.
    02-07-14 05:24 PM
  6. Cobalt232's Avatar
    You have a weird path in the error message:

    <deleted>\gmaps-apk-patcher-v2.6\com.groupon-3166-notsigned.apk

    What exactly is your full installation path?
    02-07-14 05:49 PM
  7. eywong's Avatar
    You have a weird path in the error message:

    <deleted>\gmaps-apk-patcher-v2.6\com.groupon-3166-notsigned.apk

    What exactly is your full installation path?
    C:\Documents and Settings\me\My Documents\Misc Desktop\Android apps\gmaps-apk-patcher-v2.6

    I was trying to be efficient. Sorry.
    02-07-14 06:01 PM
  8. Cobalt232's Avatar
    Ok, can you please copy the gmaps folder to c:\gmaps-apk-patcher-v2.6 and try again?

    Make sure that there are no blanks in the name.
    02-07-14 06:16 PM
  9. eywong's Avatar
    Ok, can you please copy the gmaps folder to c:\gmaps-apk-patcher-v2.6 and try again?
    I moved the patcher folder to path C:\gmaps-apk-patcher-v2.6. I patched the Groupon app again; it now works on my Z10. Thanks for resolving this issue.
    Last edited by eywong; 02-08-14 at 12:51 AM.
    02-08-14 12:36 AM
  10. BluE iS's Avatar
    There is no patching needed for Clash of Clans. The patcher doesn't find any dependencies. You can try to login to Google+ with GoogleLoginServices, but I don't think it will work: Download

    Make sure you are using the latest OS 10.2.1.1925 (SW 537)
    Yeap, I've already used OS 10.2.1.1925 (Software Release 10.2.1.537) and installed your GG Service Login but it's still the same.
    May be I need wait for Clash of Clans's dev team :

    Thanks for your help !
    02-08-14 02:54 AM
  11. mitfry's Avatar
    Yeap, I've already used OS 10.2.1.1925 (Software Release 10.2.1.537) and installed your GG Service Login but it's still the same.
    May be I need wait for Clash of Clans's dev team :

    Thanks for your help !
    I feel confident that we can get Google+ sync in Clash of Clans to work with the help of Moneytoo and Cobalt232. We could create a thread like the ones that explain how to fix Google account dependent apps and Google Maps dependent apps but instead it will be focused on Google+ and Google+ dependent apps like Clash of Clans.

    I have currently got the following Google apps installed:
    - Google Play Service (Patched)
    - Google Login Service (Patched)
    - Google Maps (latest)
    - Google+ (patched with gmaps patcher 2.6 from cobalt232)

    All apps are starting up without any error messages. The only problem is with Google+. After starting it up and selecting an account to log in with, it tries for some seconds and gives the error message: "Cannot connect to server". Then it shows the screen to select or add an account again without crashing but it will keep looping if I keep selecting my account.

    I think that if we can get Google+ to work it would possibly also fix the Clash of Clans Google+ login issue many of us are having. Two thing I worry about though is that:

    1. With all these patched apps and google services installed, upon trying to log into Google+ with Clash of Clans it still gives the error message: "Google Play Service required not supported by your device".

    2. When I install unpatched versions of Google Play and Google Play Services Clash of Clans won't give any message at all upon trying to log in with Google+. But it will start giving "Google Play stopped working" error messages.

    Looking forward to your replies.


    Mitchell
    BluE iS likes this.
    02-09-14 06:02 AM
  12. mitfry's Avatar
    There is no patching needed for Clash of Clans. The patcher doesn't find any dependencies. You can try to login to Google+ with GoogleLoginServices, but I don't think it will work: Download

    Make sure you are using the latest OS 10.2.1.1925 (SW 537)
    Cobalt, thank you for all the time you spent into this so far.

    Could you explain the following please:

    1. With patched versions of google apps and google services installed, upon trying to log into Google+ with Clash of Clans it still gives the error message: "Google Play Service required not supported by your device".

    2. When I install unpatched versions of Google Play and Google Play Services Clash of Clans won't give any message at all upon trying to log in with Google+. But it will start giving "Google Play stopped working" error messages.

    What are our options to get Google+ to work and hopefully get Clash of Clans to be able to sign in with Google+?
    BluE iS likes this.
    02-10-14 04:30 AM
  13. Cobalt232's Avatar
    Hi guys. I'll look into it when I'm back from my skiing holidays. Right now I'm in the Austrian mountains enjoying the ride!



    Posted via CB10
    BluE iS likes this.
    02-10-14 04:52 AM
  14. mitfry's Avatar
    Hi guys. I'll look into it when I'm back from my skiing holidays. Right now I'm in the Austrian mountains enjoying the ride!

    Posted via CB10
    Woah! That's great, enjoy your holidays Cobalt!

    We'll be waiting for you right here on CrackBerry hehe
    BluE iS likes this.
    02-10-14 05:54 AM
  15. BluE iS's Avatar
    I have currently got the following Google apps installed:
    - Google Play Service (Patched)
    - Google Login Service (Patched)
    - Google Maps (latest)
    - Google+ (patched with gmaps patcher 2.6 from cobalt232)
    Dear @mitfry !
    I've already installed all above apps. Gmap is working smoothly now so I'm agree with you may be it's because of Google+.
    Hope Cobalt can help us to fix this error after his holidays
    02-11-14 03:05 AM
  16. Cobalt232's Avatar
    How to fix any Android app dependent on Google Maps API and make maps working-topofischgl.jpg

    Posted via CB10
    BluE iS likes this.
    02-11-14 08:54 AM
  17. dustmalik's Avatar
    Lol now you are teasing. Enjoy

    Posted via CB10 using my Gorgeous Z10
    02-11-14 08:56 AM
  18. Cobalt232's Avatar


    Posted via CB10
    02-11-14 11:39 AM
  19. rollshifter's Avatar
    Hey Cobalt could you possibly be up to patching google play services 4.2.34 anytime soon? I'm trying to get Allcast working. Thanks.

    Posted via CB10
    02-11-14 06:35 PM
  20. spiller's Avatar
    Dear @mitfry !
    I've already installed all above apps. Gmap is working smoothly now so I'm agree with you may be it's because of Google+.
    Hope Cobalt can help us to fix this error after his holidays
    Does it allow voice input to set destination / get directions?
    02-11-14 08:15 PM
  21. BluE iS's Avatar
    Does it allow voice input to set destination / get directions?
    I don't see Voice Input function in Gmap Android version. May be this function is a part of Android OS.
    After you use it to input command, it will calls Gmap with parameters to show a map
    02-12-14 02:17 AM
  22. eywong's Avatar
    Request a new option to patch.bat: add "patched" to the output file's name. For example, the patched xyz.apk file would be named "xyz patched.apk"
    Rationale: I rename the output file and I retain both files for quality control purpose. Automated renaming would be a useful feature for me. Thank you.
    02-12-14 09:05 AM
  23. Cobalt232's Avatar
    Good idea. Will implement after my Holydays.

    Posted via CB10
    02-12-14 09:15 AM
  24. andrewwdai's Avatar
    You need to install TTS "Text to Speech" app to make that work. Google has a default one, but I am not sure it is working. There are tons of third party apps for GPS navigation purpose.

    I don't see Voice Input function in Gmap Android version. May be this function is a part of Android OS.
    After you use it to input command, it will calls Gmap with parameters to show a map
    02-12-14 09:58 AM
  25. eywong's Avatar
    patch.bat provides a useful execution trace, but it can be misleading to newbies (like me). I think the "Install ..." comment should be displayed just before "[FINISHED]". Reference the original snippet, below. (Being a rather impatient sort, I now grab the patched .apk right after it appears in the output folder. That saves me a few seconds!)

    The patched Foursquare does not work on my phone. I can login Foursquare, but it later encounters some problem with your patched Google Play services.
    Attachment 247173
    app: com.joelapenna.foursquared-2014013000.apk
    patcher: gmaps-apk-patcher-v2.6
    Z10STL100-3/10.2.1.1925

    ----------------
    [COPYING GOOGLE PLAY TO OUTPUT FOLDER]
    (Done)
    Install com.joelapenna.foursquared-2014013000.apk and com.google.android.gms.apk.The files are in the \output folder.
    [REBUILDING APK]
    I: Using Apktool 2.0.0-Beta9 on com.joelapenna.foursquared-2014013000
    I: Checking whether sources has changed...
    I: Smaling...
    I: Checking whether resources has changed...
    I: Building resources...
    I: Building apk file...
    (Done)
    [SIGNING APK]
    (Done)
    [FINISHED]
    02-12-14 10:59 AM
733 ... 1819202122 ...

Similar Threads

  1. Best Leak to Run on T-Mobile Network?
    By AfroZepher in forum BlackBerry 10 OS
    Replies: 16
    Last Post: 01-21-15, 07:29 AM
  2. Manually program BB10 device to set MDN and MSID?
    By onlinespending in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 10-20-13, 12:26 PM
  3. My Z10 updated now I can't hook up to wifi
    By Tony Stashuk in forum BlackBerry Z10
    Replies: 5
    Last Post: 10-19-13, 11:44 PM
  4. Used sachesi and SR version still says 4181??
    By sinnar in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 10-19-13, 08:18 PM
LINK TO POST COPIED TO CLIPBOARD