10-13-16 12:08 PM
733 ... 1718192021 ...
tools
  1. keysoflife's Avatar
    Hmm weird. I just patched Sobeys and it worked just fine. Did you use the latest version 2.5.1?

    Download patched Sobeys

    You can try the following:

    Open a DOS window, navigate to the folder of the patcher and then run the script by entering patch.bat. Then select the desired file and press P for Automode patching. If the script crashes, you will see a error message. Can you post it?
    Thanks for that. I see what I did wrong and everything works great. To my understanding Google+ isn't working yet? I have the Blackberry version but it hasn't been updated in quite awhile.
    02-03-14 01:30 PM
  2. nightfly2000's Avatar
    Hi, can you try to patch Runtastic ? I get an re compile error. If I don't patch the app, then I can't see the map in this app! I have tried the latest version from snap! This app is also in the official bb store, but this app is old and doesn't work good!

    Greets from Austria! ;-)

    Posted via CB10
    02-03-14 03:17 PM
  3. oldschool75's Avatar
    So I went through all 19 pages of this thread, although I must admit, things got a little blurry at times..

    I'm trying to figure out if one of these methods can be used to get Google Maps 7.x working on BB 10.2.1.x running the native apk.

    Can patch Youtube, but you will get "Network error" when running it. We can't fix Google Apps. Sorry for that!
    Hi Cobalt232,

    Seems like you are the man to consult for Maps issues. I've followed your instruction and solved my map problems. I have a suspicion that I'm still missing something.

    I can run Google Maps now and it logs in and I can see my Starred places after removing Google Play Services. However, everytime I use Google Maps it regularly polls Play Service and a new entry is found in my Hub which says "Maps... An application requires installation of Google Play Services."

    Is there something I haven't done? Thanks mate.
    If its only a notification and it still works then download an app called Ghost commander from BlackBerry app world and disable notification of the maps so u wont get those pesky notification

    Posted via CB10
    That's the way I did it.

    Posted via CB10
    Does the 2.5.1 script work automatically with Google Maps 7.x (1.7.500.1713) to allow my starred maps?
    I tried running the script, and when I hit 'p', it just auto-closes...

    Moneytoo posted an older version here...
    If anyone's interested, here's bundle of latest Google maps with Google account login enabled. It's highly probable that it's not 100% working but sign in works and I'm able to see my synced starred places etc. Use included Google Play services as it contains additional patch. At your own risk!
    gmaps.zip
    Doesn't seem to work 100%.. It let me log in, but not use my own starred map (that I can see from Google Maps on my desktop).
    I'd like to update it to the latest and get it working with starred maps..

    Any help would be appreciated! (like, providing a working gmaps with starred maps )

    Thanks!
    02-04-14 01:47 AM
  4. Cobalt232's Avatar
    Doesn't seem to work 100%.. It let me log in, but not use my own starred map (that I can see from Google Maps on my desktop).
    I'd like to update it to the latest and get it working with starred maps..

    Any help would be appreciated! (like, providing a working gmaps with starred maps )

    Thanks!
    Nice summary. Some information is outdated though.

    Here is the ultimate procedure to get Google Maps running on OS 10.2.1.537 (1925)
    1. Use OS 10.2.1.537 (1925)
    2. Download Google Maps 7.5 (no patching required)
    3. Install Google Login Services (do not install Google Play Services)
    4. Go to Google Maps settings and login from there, do not login directly in Google Account app
    5. Install Ghost Commander, go to Apps, find Google Maps, press and hold until you see Manage, unselect notifications
    6. Go to www.google.com/history and activate webprotocol
    7. Run Google Maps (Press and hold on any spot to save a location)

    If any error message appears in Google Maps about Google Play Services missing, choose ignore. The message will not show up anymore.

    Here is the link to the correctly patched Google Login Services
    Last edited by Cobalt232; 02-04-14 at 12:24 PM.
    kfroese, oldschool75 and 1delmar like this.
    02-04-14 02:56 AM
  5. Sally Mack's Avatar
    Alternatively, if you're like me and want your cake and eat it too (i.e. You want to be able to use Google maps AND Google play services such as maps in certain apps like Hailo and uber), you can install Google maps 6.14.4 and it'll login and let you see your starred places even with Google play services installed.
    oldschool75 likes this.
    02-04-14 12:52 PM
  6. andrewwdai's Avatar
    Thank Sally, I want the cake and eating too.

    Posted via CB10
    02-04-14 04:14 PM
  7. kpoulos's Avatar
    Thanks guys! But where can I find 6.14? I'll be very happy to have a working google maps app but really I need hailo.. I'm on 10.2 and I have snap sideloaded but as you've all said, hailo's looking for google play services.

    Posted via CB10
    02-05-14 05:09 PM
  8. Sally Mack's Avatar
    Thanks guys! But where can I find 6.14? I'll be very happy to have a working google maps app but really I need hailo.. I'm on 10.2 and I have snap sideloaded but as you've all said, hailo's looking for google play services.

    Posted via CB10
    https://app.box.com/s/9ry3446utgjejlj485v4

    IMO 6.14.4 is still much better than 7.x anyways.
    kpoulos and oldschool75 like this.
    02-05-14 06:29 PM
  9. oldschool75's Avatar
    Nice summary. Some information is outdated though.

    Here is the ultimate procedure to get Google Maps running on OS 10.2.1.537 (1925)
    1. Use OS 10.2.1.537 (1925)
    2. Download Google Maps 7.5 (no patching required)
    3. Install Google Login Services (do not install Google Play Services)
    4. Go to Google Maps settings and login from there, do not login directly in Google Account app
    5. Install Ghost Commander, go to Apps, find Google Maps, press and hold until you see Manage, unselect notifications
    6. Go to www.google.com/history and activate webprotocol
    7. Run Google Maps (Press and hold on any spot to save a location)

    If any error message appears in Google Maps about Google Play Services missing, choose ignore. The message will not show up anymore.

    Here is the link to the correctly patched Google Login Services
    Many thanks!

    I got as far as the last step...

    > Go to www.google.com/history and activate webprotocol

    I do not see an 'Active webprotocol', only 'Turn on Web History', is that what I want..?
    I turned that on, since it said it would share web search data (like maps?) with my mobile.

    Went back in to Google Maps (7.5) was logged in.. still no stars..
    Went into Settings -> Maps History, and it says "No network connection" (?!)

    Any ideas?
    02-06-14 01:17 AM
  10. Cobalt232's Avatar
    Do you have uninstalled Google Play services?
    02-06-14 04:14 AM
  11. Macko McLiver's Avatar
    Hi. Thanks for this great script.

    I have followed the instructions in the readme file to the letter, however when I try to patch my apk, i get the following message:

    \Java\jre7"" was unexpected at this time.

    I checked the java directory and it's correct as in the bat files.

    Update: I found the issue. I downloaded the 64 bit java, so the x64 in the bat was pointing to the program files x86 folder which is wrong. it's working now.
    Last edited by Macko McLiver; 02-06-14 at 05:00 AM.
    02-06-14 04:36 AM
  12. kpoulos's Avatar
    Thanks again! 6.14.4 appears to be crashing once I hit settings, so i'll have to play with it a bit more..

    Posted via CB10
    02-06-14 10:21 AM
  13. eywong's Avatar
    Blogger requires no patching. Make sure that you have installed Google Login Services
    Sobeys is API v2, the patcher will detect it correctly and patch it. Make sure you have Google Play services installed.

    You can get Google Login Services and Google Play Services here
    I patched my .apk using GMAPS Patcher v2.5.1. I installed the patched app on my Z10. The app runs ok with the Google Play services that is already on my phone. Kudos and thanks to you, Sally Mack and other contributors to this effort.

    Should I update my phone to the latest official Google Play services (4.1.32 / 978161-36), install the com.google.android.gms.apk from the patcher's output folder, install the patched -GooglePlayService-4034536.apk, or just continue to use whatever Google Play services that is installed on my phone?

    I'm not sure I need them right now, but should I install com.android.vending-4.5.10.apk and patched-GoogleLoginService-573038.apk?

    Please advise. Thanks.
    Last edited by eywong; 02-07-14 at 12:22 AM.
    02-06-14 12:33 PM
  14. eywong's Avatar
    Alternatively, if you're like me and want your cake and eat it too (i.e. You want to be able to use Google maps AND Google play services such as maps in certain apps like Hailo and uber), you can install Google maps 6.14.4 and it'll login and let you see your starred places even with Google play services installed.
    I installed the stock Google Maps 7.6.0 on my Z10. After I patched and installed Uber 2.7.13, it seems to run ok and have no problems with Google Maps. (Keeping my fingers crossed!)
    02-06-14 12:46 PM
  15. Cobalt232's Avatar
    I patched my .apk using GMAIL Patcher v2.5.1. I installed the patched app on my Z10. The app runs ok with the Google Play services that is already on my phone. Kudos and thanks to you, Sally Mack and other contributors to this effort.

    Should I update my phone to the latest official Google Play services (4.1.32 / 978161-36), install the com.google.android.gms.apk from the patcher's output folder, install the patched -GooglePlayService-4034536.apk, or just continue to use whatever Google Play services that is installed on my phone?

    I'm not sure I need them right now, but should I install com.android.vending-4.5.10.apk and patched-GoogleLoginService-573038.apk?

    Please advise. Thanks.
    It depends on what apps you want to use. GoogleLoginServices are only needed if you want to login to Google i.e. to have starred places in Maps or to play Ingress. Com.android.vending is the Google Play Store. It doesn't work and is for testing purpose only. GooglePlayServices are needed, if your app uses Google Maps API V2.

    The new Google Play Services with version 4.1.32 do not work correctly (at least on my device) and should not be installed.
    eywong likes this.
    02-06-14 01:00 PM
  16. jimmyt1's Avatar
    Count me as another with much better performance from 6.14.4 maps. My saved layers are available and navigation seems to work. I wasn't having such fortune with 7.5 version. But now it appears 7.6 is available...

    Posted via CB10
    02-06-14 04:18 PM
  17. eywong's Avatar
    After the one .apk that I specified had been patched, I got the "hit any key" prompt. I pressed the space bar. The batch file did not exit; it then restarted the patch process on the same .apk file. I hit ctrl-C to abort.

    It occurred with each file that I patched. A logic bug? I'm running WinXP/SP3 on my PC.
    02-06-14 05:25 PM
  18. Cobalt232's Avatar
    After the one .apk that I specified had been patched, I got the "hit any key" prompt. I pressed the space bar. The batch file did not exit; it then restarted the patch process on the same .apk file. I hit ctrl-C to abort.

    It occurred with each file that I patched. A logic bug? I'm running WinXP/SP3 on my PC.
    Should not be. Never seen this behavior before. I run Win7 32. You can test 2.6 in a few hours. Some things reworked there. Maybe it helps.
    02-06-14 06:33 PM
  19. oldschool75's Avatar
    Many thanks!

    I got as far as the last step...

    > Go to www.google.com/history and activate webprotocol

    I do not see an 'Active webprotocol', only 'Turn on Web History', is that what I want..?
    I turned that on, since it said it would share web search data (like maps?) with my mobile.

    Went back in to Google Maps (7.5) was logged in.. still no stars..
    Went into Settings -> Maps History, and it says "No network connection" (?!)

    Any ideas?
    Do you have uninstalled Google Play services?
    Yes, I removed all three (Google Play Services, Google Login, and GMaps), and went through all the steps (did not re-install Google Play service).

    I might note that I'm on a different 10.2.1.x build. I tried 6.14 with your steps and it worked perfectly (starred map, saved maps, latitude, etc). I'm hearing 7.5 wasn't allowing for other saved layers and stuff (is latitude removed as well?), so I might actually stick to 6.14 for now until I read that it's working for 7.6.

    Thanks for your help!
    02-06-14 06:46 PM
  20. bhrgvr's Avatar
    Nice summary. Some information is outdated though.

    Here is the ultimate procedure to get Google Maps running on OS 10.2.1.537 (1925)
    1. Use OS 10.2.1.537 (1925)
    2. Download Google Maps 7.5 (no patching required)
    3. Install Google Login Services (do not install Google Play Services)
    4. Go to Google Maps settings and login from there, do not login directly in Google Account app
    5. Install Ghost Commander, go to Apps, find Google Maps, press and hold until you see Manage, unselect notifications
    6. Go to www.google.com/history and activate webprotocol
    7. Run Google Maps (Press and hold on any spot to save a location)

    If any error message appears in Google Maps about Google Play Services missing, choose ignore. The message will not show up anymore.

    Here is the link to the correctly patched Google Login Services
    Install Google login services... I lost you there. searched snap but could not find anything remotely close to it. Please explain... )

    Posted via CB10
    02-06-14 08:24 PM
  21. BluE iS's Avatar
    Dear @Cobalt232 !
    I've already used GMAPS Patcher v2.5.1 to patch a game Clash of Clans but nothing is patched.

    PROCESSING FILE: clashofclans.apk
    PROCESSING MODE: GOOGLE PLAY SERVICES
    DECOMPILE RESOURCES: [YES]
    TRY TO REMOVE ADS: [NO]
    DEBUG MODE: [NO]

    [DECOMPILING APK]
    I: Baksmaling...
    I: Loading resource table...
    I: Loaded.
    I: Decoding AndroidManifest.xml with resources...
    I: Loading resource table from file: C:\Users\BluEiS\apktool\framework\1.apk
    I: Loaded.
    I: Regular manifest package...
    I: Decoding file-resources...
    I: Decoding values */* XMLs...
    I: Done.
    I: Copying assets and libs...
    (Done)

    [CHECKING FOR ADS]
    Feature not activated, select option [a] in menu.

    [CHECKING GOOGLE PLAY SERVICES]
    Warning: clashofclans.apk might be obfuscated
    Trying to guess the correct file...

    Warning: Nothing to patch.

    [CLEANING UP]
    (Done)

    [FINISHED]

    Press any key to continue . . .


    Pls guide me (and more other members, I think so ) to patch this game to sign in G+ using Google Play Service.

    Thank you for any help you can provide in this situation
    02-07-14 02:23 AM
  22. Cobalt232's Avatar
    For the brave testers we have a new version 2.6

    Changelog:
    • New: uses APKTool 2.0.0 Beta 9 (this may fix some problems with recompiling resources)
    • New: uses pre-detection before patching, so no more error messages about obfuscated files
    • Fix: reworked Autodetect patching mode (infamous a.smali bug)


    The Bug is Dead, Long Live the Bugs!
    02-07-14 10:32 AM
  23. Sally Mack's Avatar
    For the brave testers we have a new version 2.6

    Changelog:
    • New: uses APKTool 2.0.0 Beta 9 (this may fix some problems with recompiling resources)
    • New: uses pre-detection before patching, so no more error messages about obfuscated files
    • Fix: reworked Autodetect patching mode (infamous a.smali bug)


    The Bug is Dead, Long Live the Bugs!
    Good stuff. Will run this through the usual gambit of apps.
    02-07-14 10:52 AM
  24. eywong's Avatar
    For the brave testers we have a new version 2.6
    The error when I tried to patch:
    Error: Unable to rebuild "com.groupon-3166".apk.
    I: Try option [r] to decompile without resources
    I: This will not work with API v1 or API v2

    No errors when I patched it using v2.5.1. However, when I ran the patched version, it terminated with "Unfortunately, Groupon has stopped running." (Not sure if I should install the com.google.android.gms.apk from the output folder or if I should continue using the gms 1.0.326.6136 that is already installed on my Z10. Please advise.)
    02-07-14 01:53 PM
  25. eywong's Avatar
    Should not be. Never seen this behavior before. I run Win7 32. You can test 2.6 in a few hours. Some things reworked there. Maybe it helps.
    The issue persists in v2.6. The attached screen shot of the second iteration may provide clarification of my description.
    Maybe additional logic is needed here in patch.bat:
    CALL :ECHOB "[FINISHED]"
    ECHO.
    PAUSE
    GOTO MENU

    How to fix any Android app dependent on Google Maps API and make maps working-2014-02-07_8-43-09.jpg
    02-07-14 02:05 PM
733 ... 1718192021 ...

Similar Threads

  1. Best Leak to Run on T-Mobile Network?
    By AfroZepher in forum BlackBerry 10 OS
    Replies: 16
    Last Post: 01-21-15, 07:29 AM
  2. Manually program BB10 device to set MDN and MSID?
    By onlinespending in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 10-20-13, 12:26 PM
  3. My Z10 updated now I can't hook up to wifi
    By Tony Stashuk in forum BlackBerry Z10
    Replies: 5
    Last Post: 10-19-13, 11:44 PM
  4. Used sachesi and SR version still says 4181??
    By sinnar in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 10-19-13, 08:18 PM
LINK TO POST COPIED TO CLIPBOARD