10-13-16 12:08 PM
733 ... 1617181920 ...
tools
  1. Cobalt232's Avatar
    This is how it works:

    Apps that use Maps / Google Play Services
    • must be patched and need com.google.android.gms.apk
    • com.google.gsf.login can be installed, it will not cause problems


    Apps that use Google Login features
    • need com.google.gsf.login
    • com.google.android.gms can not be installed, or you get Network error message
    01-31-14 12:01 AM
  2. Phr51's Avatar
    Hello
    (Sorry for my english)
    I have a problem with this file:
    https://www.dropbox.com/s/jwnwtz0818...ream.beamy.apk
    "Error : Unable to guess the obfuscated file. Nothing to patch"
    I do not know where is the problem
    thank you for your help
    02-01-14 10:04 AM
  3. Cobalt232's Avatar
    Hi

    Thanks for this information. There is a small bug in the processing logic. Will fix. Meanwhile patch you app with option 1 (API v1)
    02-01-14 10:35 AM
  4. Phr51's Avatar
    It's ok !!!
    Think you very much
    02-01-14 10:58 AM
  5. Cobalt232's Avatar
    Fixed Version. Original post has been updated.

    GMAPS Patcher v2.5.1

    Changelog:
    • Fixed a bug where API v1 would not be patched correctly if no Google Play dependencies are found
    02-01-14 11:01 AM
  6. Sally Mack's Avatar
    Fixed Version. Original post has been updated.

    GMAPS Patcher v2.5.1

    Changelog:
    • Fixed a bug where API v1 would not be patched correctly if no Google Play dependencies are found
    Thanks... this one has been around for awhile I think! And it was strangely intermittent! I.e. I'd run the batch file one time and it would do nothing. Put the same apk through it again right after, and it would patch!
    02-01-14 11:03 AM
  7. Cobalt232's Avatar
    Thanks... this one has been around for awhile I think! And it was strangely intermittent! I.e. I'd run the batch file one time and it would do nothing. Put the same apk through it again right after, and it would patch!
    I know a strange bug I've not been able to isolate. It mostly appeared to me when patching Google Play dependencies. For some unknown reason, the script sometimes finds a.smali but it should be f.smali. If you run the script a second time, it finds f.smali and patches correctly. Weird.

    The fix I provided with 1.5.1 just was a problem in the processing logic, as Automode now is much more sophisticated in finding the right stuff to patch. Still, the a.smali bug may appear again. In that case just run the script again.
    02-01-14 11:18 AM
  8. Phr51's Avatar
    I have another problem with this file:
    https://www.dropbox.com/s/twm56yulsf...e.ELeclerc.apk
    "Unable to rebuild"
    02-01-14 11:33 AM
  9. Cobalt232's Avatar
    Sorry, can't fix that. The app has API v1 and we must decompile resources to patch androidmanifest. As it doesn't recompile, there's nothing we can do.
    02-01-14 12:08 PM
  10. Phr51's Avatar
    don't worry
    think you
    02-01-14 12:29 PM
  11. Phr51's Avatar
    Here's latest Google Play services 4.1.32 (978161-36) patched.apk with two verifications checks removed fixing some FC's (at least in apps I'm using).
    This crashes immediately after installation on my Q10 with 10.2.1.1925 (SW 537). Any ideas?
    Yes, this crashes on my Q5 with 10.2.1
    02-01-14 12:52 PM
  12. keysoflife's Avatar
    Thanks to those involved in finding this workaround! Any chance i get get these converted so I can get around the Google Play services? Many thanks!

    https://play.google.com/store/apps/d....blogger&hl=en
    https://play.google.com/store/apps/d...m.sobeys&hl=en
    02-01-14 10:46 PM
  13. Sally Mack's Avatar
    Thanks to those involved in finding this workaround! Any chance i get get these converted so I can get around the Google Play services? Many thanks!

    https://play.google.com/store/apps/d....blogger&hl=en
    https://play.google.com/store/apps/d...m.sobeys&hl=en
    No problem.

    Step 1: download the package cobalt made.
    https://www.dropbox.com/s/5pb0n29zfp...her-v2.5.1.zip

    Step 2: drag the apk's onto patch.bat

    Step 3: go into the output folder, and copy/paste the apk's in there onto your device.

    Step 4: install the apk's on your device.

    02-01-14 11:33 PM
  14. keysoflife's Avatar
    Thank you!

    Tried the software, but I can't get any of them to work? Program crashes?
    Last edited by keysoflife; 02-02-14 at 02:01 AM.
    02-01-14 11:47 PM
  15. Cobalt232's Avatar
    Thank you!

    Tried the software, but I can't get any of them to work? Program crashes?
    Blogger requires no patching. Make sure that you have installed Google Login Services
    Sobeys is API v2, the patcher will detect it correctly and patch it. Make sure you have Google Play services installed.

    You can get Google Login Services and Google Play Services here
    02-02-14 05:35 AM
  16. CyberMan2013's Avatar
    Perhaps you can collaborate with BlackBerry and have them improve general Android Runtime compatibility with this? To me this is big! Great work! Needs more recognition and maybe a simplified explanation for the masses. Is this a universal fix for ALL the apps that require Google Play Services? This should be a part of the OS. Have you contacted and shared this with BlackBerry or even Kevin Michaluk?

    Posted via CB10
    02-02-14 06:35 AM
  17. Cobalt232's Avatar
    Perhaps you can collaborate with BlackBerry and have them improve general Android Runtime compatibility with this? To me this is big! Great work! Needs more recognition and maybe a simplified explanation for the masses. Is this a universal fix for ALL the apps that require Google Play Services? This should be a part of the OS. Have you contacted and shared this with BlackBerry or even Kevin Michaluk?

    Posted via CB10
    The patcher works quite universal, there are only a few apps it can't patch. Mostly these apps are google native apps such as google+. There has been a lot of talk about integrating google play features into the Blackberry Android Runtime and it seems to be clear that it's more a legal issue than a technical one.

    As this thread has 48'000+ views I believe that everyone at CB and maybe even at BB has recognized what we are doing here.

    But thanks anyway for the feedback and keep reporting back if you find any issues with the patcher.

    02-02-14 07:41 AM
  18. TryOut's Avatar
    First of all I'd like to thank you Cobalt for doing all that great work and helping all those people getting their apps to work!

    I tried to use your latest script GMAPS Patcher v2.5.1 (Post #430) to get the Polar Beat app to work on my Q10. First, I installed all four apk files from your .zip file mentioned here: Than I copied the apk of the Polar Beat app into the gmaps-apk-patcher-v2.5.1 folder and clicked on the patch.bat (after giving the correct folder structure for java and winrar into the .bat). Got two apks in the output folder and tried to install them. Google Play Services went fine, but the created Polar Beat apk can't be installed it says. Gmaps apk patcher gives a yellow warning when it comes to: [Checking Google Play Services] Warning: fi.polar.beat_1.0.apk might be obfuscated

    I would be so glad, if you could tell me, what I did wrong. Or if you could help me out a bit with the patching of the apk file if your time allows it? I hope, I uploaded it correctly with dropbox. Anyway, thank you once again for the great tool, cause maybe it'll work for me with some other app :-)
    02-02-14 09:31 AM
  19. Cobalt232's Avatar
    I patched the file and it runs thru with API v1 and v2 but when installing I also get the message that the app can not be installed. I did some research and found out, that Android minsdk version of this app is 18, where Blackberry Android runtime only supports minsdk 17. So the app call methods that are not supported in the runtime. For this app, we are out of luck.

    BTW: It looks like the missing api calls are bluetooth related. you can look for yourself by installing my Blackberry Android Runtime logger and then look at the realtime system messages. Link is in my signature.
    TryOut likes this.
    02-02-14 10:35 AM
  20. dustmalik's Avatar
    I just checked Play stores for Polar beat app and found out it only supports Android 4.3 and later. Hence why it can't work on BlackBerry 10 Android runtime. BB10 runtime is still at Android 4.2.2.

    Posted via CB10 using my Gorgeous Z10
    TryOut likes this.
    02-02-14 11:04 AM
  21. TryOut's Avatar
    Big thanks to both of you, Cobalt and dustmalik! As I'm new to all this Android Apps on BB stuff, I highly appreciate that there are people like you, spending their time helping noobs like me out. Thanks a lot!
    02-02-14 11:20 AM
  22. Sally Mack's Avatar
    I'm having difficulties patching without decompiling resources...

    I tried using "patch.bat file.apk r", "patch.bat file.apk g" (thinking by default g doesn't decompile resources), and i also tried editing patch.bat to "SET DECOMPRES=[NO]" with no such luck. What am I missing here?

    Also having issues with "FIND is not recognized as an internal or external command", but think it has to do with my PATH settings. Not as easy to correct as my xcopy issue awhile back.

    EDIT: fixed my path settings, and what do you know... this whole time I've been using this script without the first selection screen ever working. It would default to autodetect right off the bat and just run. If i wanted to pick certain options, I'd have to do it as a command. Used option r, then option g, and it worked!

    But that said... wouldn't it make more sense if it were to determine what needs patching first, then decide whether or not to decompile resources (though this may mean apktool running twice)... or a routine where if it ONLY patches google play services, and rebuilding fails, it automatically tries the g, r method as a fallback.
    Last edited by Sally Mack; 02-02-14 at 11:54 PM.
    02-02-14 11:29 PM
  23. Cobalt232's Avatar
    Hey good to hear that it works now and you get to the startup-screen ;-)

    Detecting what to patch requires decompilation of resources, as we need to to look into manifest.xml to find Maps dependencies. There is no way to circumvent this for Maps V1/V2 Api.

    If you want to patch Google Play only, you can use the Resources=NO Feature in the menu.


    The steps to patch a file with gplay that fails recompiling would be the following:

    1. Run automode and look, what patching it would suggest (ie gplay). Let it complete, even if it fails
    2. Set decompile resources = NO
    3. In Advanced, Select patch Google Play

    Hope, this helps.


    Btw: the find command is used to determine, if we have obfuscated methods in an unobfuscated filename.



    Posted via CB10
    02-03-14 12:59 AM
  24. keysoflife's Avatar
    Thanks Cobalt!

    Blogger works great now. As for Sobeys, I opened the software and when I go to patch it (APIv2) the software crashes. Nothing goes to the output folder. I don't see an error - the whole program just shuts down no matter what option I select after selecting which APK I wish to load. Anything I am doing wrong? Thanks!
    02-03-14 12:33 PM
  25. Cobalt232's Avatar
    Thanks Cobalt!

    Blogger works great now. As for Sobeys, I opened the software and when I go to patch it (APIv2) the software crashes. Nothing goes to the output folder. I don't see an error - the whole program just shuts down no matter what option I select after selecting which APK I wish to load. Anything I am doing wrong? Thanks!
    Hmm weird. I just patched Sobeys and it worked just fine. Did you use the latest version 2.5.1?

    Download patched Sobeys

    You can try the following:

    Open a DOS window, navigate to the folder of the patcher and then run the script by entering patch.bat. Then select the desired file and press P for Automode patching. If the script crashes, you will see a error message. Can you post it?
    02-03-14 01:12 PM
733 ... 1617181920 ...

Similar Threads

  1. Best Leak to Run on T-Mobile Network?
    By AfroZepher in forum BlackBerry 10 OS
    Replies: 16
    Last Post: 01-21-15, 07:29 AM
  2. Manually program BB10 device to set MDN and MSID?
    By onlinespending in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 10-20-13, 12:26 PM
  3. My Z10 updated now I can't hook up to wifi
    By Tony Stashuk in forum BlackBerry Z10
    Replies: 5
    Last Post: 10-19-13, 11:44 PM
  4. Used sachesi and SR version still says 4181??
    By sinnar in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 10-19-13, 08:18 PM
LINK TO POST COPIED TO CLIPBOARD