10-13-16 12:08 PM
733 ... 1516171819 ...
tools
  1. dustmalik's Avatar
    Great work Cobalt. Well done. BTW, v2.4 successfully patches Lyft. Thanks.

    Posted via CB10 using my Gorgeous Z10
    01-29-14 11:23 AM
  2. Sally Mack's Avatar
    New Version 2.4A which should fix some problems.

    Glymps
    Sucessfully patched with Autodetect

    TransitApp
    Sucessfully patched with Autodetect

    Hailo
    Sucessfully patched with Autodetect

    Toronto
    Sucessfully patched with Autodetect

    Football Italia
    Successfully patched with Autodetect (Decompile Resources = NO)

    Home Depot Canada
    Can't be patched because API V2 key can't be writen in AndroidManifest (recompile error)

    Tripadvisor
    Needs further investigation
    Sweet! Can't wait to try this out!
    01-29-14 11:23 AM
  3. AshDeezy's Avatar
    Great work Cobalt. Well done. BTW, v2.4 successfully patches Lyft. Thanks.

    Posted via CB10 using my Gorgeous Z10
    Could you post a link to your patched Lyft APK?

    Posted via CB10
    01-29-14 08:38 PM
  4. scooterman's Avatar
    The app Strava won't work w/o Google play store installed on my phone then it still gives and error that Google play services are not supported on my phone. But your patch does make it work.

    Anyway to remove the Google play services not supported error?

    Also the need to have Google play store installed

    If Google play store is not installed it says Google play services are not installed. Even though they are and the app is patched with v2.4 of the script

    Posted via CB10
    01-29-14 09:21 PM
  5. xtremez's Avatar
    Ok, here is a small How-To of the way I did id.


    First: you need a bunch of tools:

    • apkTool Link (I used the windows version)
    • gapps Link (I used Android 4.2.2. Version)
    • openSSL Link
    • SignAPK Link (Password: SanketN8 ) -> Credits go to YouTube User Sanket Naik


    Second:
    • unpack apktool
    • move the app you want to convert in the apkTool folder (let's call "app.apk")
    • open cmd in apkTool folder (shift + rightclick)
    • enter
      Code:
      apktool d app.apk app
    • a new folder is created with the name of your app
    • ​go into this folder and open "AndroidManifest.xml" with editor
    • delete line
      Code:
      <uses-libraryandroid:name=“com.google.android.maps”/>
    • save & exit


    Third:

    • unpack com.google.android.maps.jar from gapps-jb-20130812-signed.zip /system/framework
    • move it in your apkTool folder
    • open cmd in apkTool folder
    • enter
      Code:
      apktool d com.google.android.maps.jar
    • a new com.google.android.maps -folder is created
    • copy and paste the "smali" folder from com.google.android.maps into your app folder


    Fourth:

    • install openssl
    • open app.apk with 7zip or winrar, go to folder META-INF and extract "Cert.RSA" into your openssl bin folder (C:\OpenSSL-Win32\bin)
    • open cmd in c:\OpenSSL-Win32\bin folder
    • enter
      Code:
      openssl.exe pkcs7 -inform DER -in *.RSA -print_certs -out cert
    • enter
      Code:
      openssl.exe x509 -noout -in cert -fingerprint -md5
    • copy the MD5 fingerprint
    • go to you apkTool\app\smali\android_maps_conflict_avoidance\ com\google\googlenav\datarequest folder, open DataRequestDispatcher.smali with editor
    • find the method setAndroidSignature()
    • Code:
       .method public setAndroidSignature(Ljava/lang/String;)V
    • modify as followed:

    Code:
        .locals 3
        .parameter "signature"
    
        .prologue
        .line 1332
        iget-object v0, p0, Landroid_maps_conflict_avoidance/com/google/googlenav/datarequest/DataRequestDispatcher;->properties:Landroid_maps_conflict_avoidance/com/google/common/io/protocol/ProtoBuf;
    
        const/16 v1, 0x12
    
        const-string v2, "2878691fb70c1076bf76b803e15d904a"       <-- this is were you place your MD5 Hash without colons, lower case!
        
        invoke-virtual {v0, v1, v2}, Landroid_maps_conflict_avoidance/com/google/common/io/protocol/ProtoBuf;->setString(ILjava/lang/String;)V
    
        .line 1334
        return-void 
    .end method
    • save and exit
    • go back to your main apkTool folder, open CMD and enter:
      Code:
      apktool b App App2.apk


    • App2.apk is created


    sixth:

    • unzip signAPK files into new folder
    • move App2.apk into the same folder
    • add a batch file, SignAPK.bat with the following code:
      Code:
      java -jar signapk.jar certificate.pem key.pk8  %1 %~n1-signed.apk
    • place app2.apk on SignApp.bat and app2_signed.apk is created.
    • You can now convert app2_signed.apk to a bar file and install it on your device
    Cobalt, currently this is where i'm stuck. I've moved past the previous error, which was unable to create the folder. That was caused by me leaving out the .JAR file, so after added it in. It worked.

    Now I can't seem to find that line to delete.
    Goniff likes this.
    01-29-14 09:48 PM
  6. dustmalik's Avatar
    Could you post a link to your patched Lyft APK?

    Posted via CB10
    I currently don't have access to mine where i am now. But you can use the patched Lyft by Cobalt. Here is the link Patched Lyft

    Posted via CB10 using my Gorgeous Z10
    01-30-14 12:38 AM
  7. Cobalt232's Avatar
    Cobalt, currently this is where i'm stuck. I've moved past the previous error, which was unable to create the folder. That was caused by me leaving out the .JAR file, so after added it in. It worked.

    Now I can't seem to find that line to delete.
    You cant't find this line because it must be inserted.

    Search for:
    .method public setAndroidSignature(Ljava/lang/StringV

    Then raplace everything below that line with:
    .locals 3
    .parameter "signature"

    .prologue
    .line 1332
    iget-object v0, p0, Landroid_maps_conflict_avoidance/com/google/googlenav/datarequest/DataRequestDispatcher;->properties:Landroid_maps_conflict_avoidance/com/google/common/io/protocol/ProtoBuf;

    const/16 v1, 0x12

    const-string v2, "2878691fb70c1076bf76b803e15d904a" <-- this is were you place your MD5 Hash without colons, lower case!

    invoke-virtual {v0, v1, v2}, Landroid_maps_conflict_avoidance/com/google/common/io/protocol/ProtoBuf;->setString(ILjava/lang/StringV

    .line 1334
    return-void
    .end method

    But anyway, just use the patcher, it will do all modifications without any hassle.
    01-30-14 02:03 AM
  8. Cobalt232's Avatar
    The app Strava won't work w/o Google play store installed on my phone then it still gives and error that Google play services are not supported on my phone. But your patch does make it work.

    Anyway to remove the Google play services not supported error?

    Also the need to have Google play store installed

    If Google play store is not installed it says Google play services are not installed. Even though they are and the app is patched with v2.4 of the script

    Posted via CB10
    Did you try with script 2.4A?
    01-30-14 02:06 AM
  9. xtremez's Avatar
    Okay will try the patcher instead. Thanks Cobalt, so it will allow Google Services?
    01-30-14 02:30 AM
  10. Cobalt232's Avatar
    Okay will try the patcher instead. Thanks Cobalt, so it will allow Google Services?
    Please define Google Services. If you're talking about apps like google drive etc they may work with limitations. All other apps should work
    01-30-14 02:44 AM
  11. xtremez's Avatar
    I was thinking like some apps i.e jobstreet (it's like a job search app) that needed play store service to run or runkeeper. I know there might be limitations with Gmail, Google+ and Google Drive
    01-30-14 02:52 AM
  12. Azrae49's Avatar
    I was thinking like some apps i.e jobstreet (it's like a job search app) that needed play store service to run or runkeeper. I know there might be limitations with Gmail, Google+ and Google Drive
    Gmail has been working for a long time now? On a side note I've had success getting quite a few of the final fantasy games that I have on android to run by patching them with lucky patcher on a rooted android device and then installing the patched apk on my BlackBerry, they did a check to see if the play store was available and if it was bought when the app started and if it didn't detect the play store it crashed. After patching, the check seems to be gone and the apps load up fine. Lucky patcher can unfortunately be used for.. other, less noble purposes too.

    Posted via CB10
    01-30-14 02:57 AM
  13. Cobalt232's Avatar
    I was thinking like some apps i.e jobstreet (it's like a job search app) that needed play store service to run or runkeeper.
    They all are successfully patched with the patcher using Option "Auto". For your convenience, you can download the prepatched files here
    01-30-14 03:36 AM
  14. xtremez's Avatar
    After using the patch is it a side effect to keep getting software updates? I keep getting a 328kb update that doesn't want to go away. Cobalt any idea?

    Posted via CB10
    01-30-14 07:00 AM
  15. Cobalt232's Avatar
    No, there should be no side effects. I'm sure this is not a result of the patching.

    Which App is asking for updates?

    Posted via CB10
    01-30-14 07:23 AM
  16. scooterman's Avatar
    same results from 2.4a
    01-30-14 08:04 AM
  17. xtremez's Avatar
    Not whatsapp it's the main BB10 software update in settings. After updating, restart it prompts again

    Posted via CB10
    01-30-14 08:21 AM
  18. Cobalt232's Avatar
    @Scooterman. 2.4 b is on it's way.

    Posted via CB10
    01-30-14 08:25 AM
  19. xtremez's Avatar
    Well it's not affecting phone performance I will wait for your 2.4B, thanks for the effort Cobalt. But I think this is slightly beyond my amatur knowledge

    Posted via CB10
    01-30-14 08:42 AM
  20. Cobalt232's Avatar
    Strava is really a stubborn app and requires special treatment. Not sure if I can implement this fix into the patcher.

    Anyway, I patched it manually. Here is the patched file
    01-30-14 10:19 AM
  21. scooterman's Avatar
    can you do strava ride ?
    01-30-14 10:23 AM
  22. Cobalt232's Avatar
    can you do strava ride ?
    Here you go: Strada ride
    01-30-14 11:02 AM
  23. Cobalt232's Avatar
    So here we have a new release v2.5

    I did a lot of fixing, read the readme in the package. Feedback is welcome!

    Download GMAPS APK PATCHER v2.5
    dustmalik and Sally Mack like this.
    01-30-14 11:05 AM
  24. AshDeezy's Avatar
    So here we have a new release v2.5

    I did a lot of fixing, read the readme in the package. Feedback is welcome!

    Download GMAPS APK PATCHER v2.5
    Does this support any app using gmaps inside? Can you clarify if we need to remove GSF from our device using app manager for this to work right?

    Posted via CB10
    01-30-14 04:21 PM
  25. Cobalt232's Avatar
    This is how it works:

    Apps that use Maps / Google Play Services
    • must be patched and need com.google.android.gms.apk
    • com.google.gsf.login can be installed, it will not cause problems


    Apps that use Google Login features
    • need com.google.gsf.login
    • com.google.android.gms can not be installed, or you get Network error message
    kfroese likes this.
    01-31-14 12:00 AM
733 ... 1516171819 ...

Similar Threads

  1. Best Leak to Run on T-Mobile Network?
    By AfroZepher in forum BlackBerry 10 OS
    Replies: 16
    Last Post: 01-21-15, 07:29 AM
  2. Manually program BB10 device to set MDN and MSID?
    By onlinespending in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 10-20-13, 12:26 PM
  3. My Z10 updated now I can't hook up to wifi
    By Tony Stashuk in forum BlackBerry Z10
    Replies: 5
    Last Post: 10-19-13, 11:44 PM
  4. Used sachesi and SR version still says 4181??
    By sinnar in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 10-19-13, 08:18 PM
LINK TO POST COPIED TO CLIPBOARD