09-03-17 11:41 PM
726 ... 1617181920 ...
tools
  1. importjanrens's Avatar
    Hmm that toggle off onn works on the passport yes.

    I think hé will just send a new request to the server. And you will bypass the security..

    Thats Strange. Very very strange.

    But thats a huge development.
    Thanks for staring guys..

    Now i could try to add some lines into the codes that hé will toggle off on itself auto after a few minutes...

    Then it should be solved...

    But Then i wonder.. why its not working on the 3th version...

    As we are getting updates in a few weeks to trade and battle with eachother.

    It should be Nice to get those versions working as well

    Posted via the CrackBerry App for Android
    michal zavodsky likes this.
    07-26-16 12:14 AM
  2. Lisen's Avatar
    This works for my Classic ( besides the terrible graphic glitches ). But I can see the small blue dots on the screen now after I switch of and on the internet and GPS. I´m running the 0.29.2 version
    07-26-16 01:51 AM
  3. estekwellek's Avatar
    Can we get a link for the patched 0.29.2 version please?

    Posted via CB10
    07-26-16 02:34 AM
  4. Kanashimi's Avatar
    So I tried this method on my Z30 and I have to include mobile and location.

    I turn off location first, then mobile network. I count to five and turn on mobile network. I then count to ten before I turn on location. This seems to even make Pokemon appear.

    However, instead of the Pokemon appearing for five to ten minutes they only seem to spawn for 30 seconds to a minute (if that). Sometimes the Pokemon around me spawn for a bit, but then when I click on them it tells me I'm too far away despite being right on top of them. So it's a constant struggle at that point. Unless I'm missing something.

    Edit: I tried this method because a Vulpix was on my house and it had four minutes and just nothing. She spawned for literally four seconds, but then all Pokemon disappeared. Nothing I did besides restarting the phone brought them back and by then it was too late.
    Last edited by Kanashimi; 07-26-16 at 04:01 AM.
    07-26-16 02:54 AM
  5. Lisen's Avatar
    You can find it on page 5 in this thread
    07-26-16 03:57 AM
  6. michal zavodsky's Avatar
    Confirmed this works, amazing. I'll explain:
    1. Go to the settings of your BlackBerry 10 device and choose "quick settings". (The settings where you can edit the buttons of the menu that you can pull down at the home screen, or in any app with two fingers at once).
    2. Enable at least the options "Location Services" and "GSM Network", if you haven't already.
    3. Make you have installed patched Pokemon Go version 29.2. I tried with 29.0 but it didn'tt work and 29.3 doesn't work at all.
    4. After you've installed patched PoGo 29.2, open it up and wait for it to load until you're in-game.
    5. If you do not see any nearby Pokemon or PokeStops, here's the trick to make it work again without a restart:
    5.1 Use TWO FINGERS and pull down the quick settings menu from the TOP of your screen.
    5.2 Disable both Location and GSM and wait a couple of seconds.
    5.3 Now First enable GSM for internet connectivity, give it a moment, and enable GPS as well for location.
    6. Enjoy!

    Let me know if this helped you out guys
    Thank you! Worked for me on BeBe Passport.
    07-26-16 06:20 AM
  7. JCMM's Avatar
    Can you show me a screnshot that shows how it looks like? On my Classic the game is just unplayable
    This works for my Classic ( besides the terrible graphic glitches ). But I can see the small blue dots on the screen now after I switch of and on the internet and GPS. I´m running the 0.29.2 version
    07-26-16 07:12 AM
  8. nixysug's Avatar
    Hi, I installed the latest 29.2 apk on my Z30, but still nothing, when I click on logging in with my google account, I just see the pokeball rolling over and over, it never connects... my Google ID is configured, I can't find why it doesn't work with me ...any clue ?
    I tried as first app after a reboot , still nothing.

    I'm on 10.3.2.2876 and installed cobalt's 4.4.4 gsf-login ...

    thx !
    07-26-16 08:00 AM
  9. importjanrens's Avatar
    Hi, I installed the latest 29.2 apk on my Z30, but still nothing, when I click on logging in with my google account, I just see the pokeball rolling over and over, it never connects... my Google ID is configured, I can't find why it doesn't work with me ...any clue ?
    I tried as first app after a reboot , still nothing.

    I'm on 10.3.2.2876 and installed cobalt's 4.4.4 gsf-login ...

    thx !
    is the app showed in the whitelist?
    07-26-16 08:08 AM
  10. nixysug's Avatar
    Mmmm OK I just saw in another post something related to this whitelist thing... I haven't installed it, actually, I guess that's my main concern right now, isn't it ?

    EDIT : OK so now I can launch the game ! But I have the problem with nothing on the maps, if i stay too long...
    It is barely unplayable , or is there a way to make this work permanently ?
    Last edited by nixysug; 07-26-16 at 08:31 AM.
    07-26-16 08:09 AM
  11. Pallam93's Avatar
    Thank you! Worked for me on BeBe Passport.
    But i am right, that pokestopps und gyms not working then. You can only catch pokemon.

    So yes, this on off thing doesnt work. Pokestops will shown as well as Gyms, but they´re not working then.
    Have the latest version from importjanrens.

    It would be really usefull if you can say which versions you have.
    Maybe i have some troubles (and the other versions as well) cause of the launchmode setting.

    Did anyone decompiles the other versions as well? I thing they use differens launchmodes. That could explain why this workaround doesn´t work on 0.29.3. and 0.29.2.

    I will check all versions that importjanrens sets if they are changes between this launchmodes.
    Last edited by Pallam93; 07-26-16 at 09:30 AM.
    07-26-16 09:20 AM
  12. Lisen's Avatar
    This is what I see, I cant play it on my Classic but after switching off and on the internet and GPS i could see the pokestops, sort of
    How do I get Pokemon Go to work on BlackBerry 10?-img_20160726_082141.png

    Posted via CB10
    07-26-16 09:41 AM
  13. importjanrens's Avatar
    Mmmm OK I just saw in another post something related to this whitelist thing... I haven't installed it, actually, I guess that's my main concern right now, isn't it ?

    EDIT : OK so now I can launch the game ! But I have the problem with nothing on the maps, if i stay too long...
    It is barely unplayable , or is there a way to make this work permanently ?
    you'll need the whitelist
    07-26-16 09:55 AM
  14. nixysug's Avatar
    you'll need the whitelist
    Yup installed it and I got it to work, but now as I was saying, I get the same problems as everyone else : no pokemons showing up, and troubles with GPS sometimes.
    07-26-16 10:04 AM
  15. Pallam93's Avatar
    This is what I see, I cant play it on my Classic but after switching off and on the internet and GPS i could see the pokestops, sort of
    Click image for larger version. 

Name:	IMG_20160726_082141.png 
Views:	387 
Size:	323.3 KB 
ID:	404847

    Posted via CB10
    Wait, is that the rainbow-track of mario kart? Did you find a easter egg then?


    Btt.: singletask doesnt work. (on off thing) Maybe it´s about the permissions that importjanrens changed?
    07-26-16 10:24 AM
  16. lucassorel's Avatar
    Thank you! Worked for me on BeBe Passport.
    Thanks for your work man. Its makes appears pokestop and gym again yes but I cant go to them like i do when I restart my device (BlackBerry Passport). So... its work 50% for me. Any solution??? So boring to restart every 10-15 mins...
    07-26-16 11:05 AM
  17. michal zavodsky's Avatar
    But i am right, that pokestopps und gyms not working then. You can only catch pokemon.

    So yes, this on off thing doesnt work. Pokestops will shown as well as Gyms, but they´re not working then.
    Have the latest version from importjanrens.

    It would be really usefull if you can say which versions you have.
    Maybe i have some troubles (and the other versions as well) cause of the launchmode setting.

    Did anyone decompiles the other versions as well? I thing they use differens launchmodes. That could explain why this workaround doesn´t work on 0.29.3. and 0.29.2.

    I will check all versions that importjanrens sets if they are changes between this launchmodes.
    I have 29.2. version. But I have found issue with this little trick. After toggling on/off GPS and radio it only loads certain area around you. I have tried this in bus today and after turning gsp and radio on again it loaded area around me an after while as I moved further away from my original location there were no pokestops etc loaded, even map wasn't loaded.

    Posted via my amazing Passport running 10.3.2.something
    07-26-16 11:10 AM
  18. Lisen's Avatar
    Wait, is that the rainbow-track of mario kart? Did you find a easter egg then?


    Btt.: singletask doesnt work. (on off thing) Maybe it´s about the permissions that importjanrens changed?
    Im afraid not..

    But i find it a bit hopeful that i could not see the pokestops before i toggled of and on. It locked better before i rotated the screen and it all became a mess. I wish i know how this stuff work but Im in dark with this tech-stuff

    Posted via CB10
    07-26-16 11:32 AM
  19. importjanrens's Avatar
    Wait, is that the rainbow-track of mario kart? Did you find a easter egg then?


    Btt.: singletask doesnt work. (on off thing) Maybe it´s about the permissions that importjanrens changed?
    I'm running on the same.. toggle on or off works here..

    But its still the request you get back from the google servers.
    It just a bypass to refresh the data..
    But you have still no permission to turn the pokestops or to battle..

    Pokemons i could not catch on the BlackBerry passport with this toggle on off.

    I see the pokestops spawning but Then it just tells me that the pokemons are to far away..

    So its really the permission or some kind we need to spoof

    Posted via the CrackBerry App for Android
    07-26-16 12:03 PM
  20. CisnB_05's Avatar
    Attachment 404576

    Well the app work in my BlackBerry Classic but i got this bug with my screen. I dont think it's a problem of performance of my phone. Maybe a problem with the default maps GPS ?

    Posted via CB10
    A lot being done to make Pokestops etc appear...what about the problem illustrated above? What is causing this screen malfunction and is there a solution?

    Posted via CB10
    07-26-16 12:55 PM
  21. programagor's Avatar
    As many people already experienced, after 10 or so minutes of gameplay, the stops, gyms, and nearby pokemon stopped showing. I just thought of posting my negative result here, so that no one else wastes their time trying this. (but feel free to replicate, just in case I messed up)
    I went to Google Blackberry ID > Menu > Android settings > Apps;
    and "Forced Stop" everything related to Google, Cobalt, and the game, starting from Pokemon GO, ending with Google Play services and Settings. To top it off, I went to Blackberry Device monitor, CPU, and closed Google Blackberry ID.
    I then started the game, and nothing happened.
    I'm using importjanrens' version "Pokémon.GO.v.0.29.2.b.2016071201.develop",
    Cobalt's Google Account Manager 4.3.3, and
    Android Runtime 10.3.2.231 (downgraded from the current one so that I can fully uninstall Android apps without the store crashing).

    One possible thing I didn't try was updating to the current runtime, performing the steps above, and dummy-uninstalling any app from the Play store to trigger restart of the runtime. (nothing actually gets uninstalled because of a bug in the runtime)
    Before I downgraded, I tried to just dummy-uninstall some app to trigger restart, without performing the steps above, and that didn't help either.

    I hope this helps narrow down the search for some solution.
    07-26-16 02:06 PM
  22. Line69's Avatar
    There is the way to crash runtime completely, it forces BlackBerry to launch it again, but it's still not enough for pokestops to appear and work as intended. I've tried everything on soft-execution side, unfortunately, no luck. Waste of time

    Posted via CB10
    07-26-16 02:33 PM
  23. programagor's Avatar
    I went to Google Blackberry ID > Menu > Android settings > Apps;
    and "Forced Stop" everything related to Google, Cobalt, and the game, starting from Pokemon GO, ending with Google Play services and Settings. To top it off, I went to Blackberry Device monitor, CPU, and closed Google Blackberry ID.
    I then started the game, and nothing happened.
    So I updated my Android runtime to the current version and tried following the Force Stops with restart of the runtime, but to no avail. Next time I might try removing my Google account, and adding a new one through the Google Account Manager.
    07-26-16 02:41 PM
  24. importjanrens's Avatar
    As many people already experienced, after 10 or so minutes of gameplay, the stops, gyms, and nearby pokemon stopped showing. I just thought of posting my negative result here, so that no one else wastes their time trying this. (but feel free to replicate, just in case I messed up)
    I went to Google Blackberry ID > Menu > Android settings > Apps;
    and "Forced Stop" everything related to Google, Cobalt, and the game, starting from Pokemon GO, ending with Google Play services and Settings. To top it off, I went to Blackberry Device monitor, CPU, and closed Google Blackberry ID.
    I then started the game, and nothing happened.
    I'm using importjanrens' version "Pokémon.GO.v.0.29.2.b.2016071201.develop",
    Cobalt's Google Account Manager 4.3.3, and
    Android Runtime 10.3.2.231 (downgraded from the current one so that I can fully uninstall Android apps without the store crashing).

    One possible thing I didn't try was updating to the current runtime, performing the steps above, and dummy-uninstalling any app from the Play store to trigger restart of the runtime. (nothing actually gets uninstalled because of a bug in the runtime)
    Before I downgraded, I tried to just dummy-uninstall some app to trigger restart, without performing the steps above, and that didn't help either.

    I hope this helps narrow down the search for some solution.
    I explained it all why this is all happening.. is no one reading my posts.??

    Ist the server of google who is kicking you out.
    I have the whole game decompile here.. and looked step by stephen what hé is doing.

    The problem lays at the com.android.gms.location and com.android.gms.location.gps on the manifest..

    There is a sender and receiver on the manifest.
    Thats also logical.

    They all both awaiting green Light from the server with the permission to turn pokestops.
    Spawn pokemons etc etc...

    The maps that you are seeing is sort of integrated and works as a standard.

    Al extra.. the levelled stuff is updated from the servers..
    Thee pokestops.
    Pokemons that are spawning for just 5 minutes somewhere..

    You need constant update..

    The gps is not a problem! The request from the server is..

    Toggle on or off your WiFi or 4g. Then hé is again sending a request.. but on your token that you send to that server you already tried

    So hé is not given you permission to spin the wheel..

    In a Strange way hé is obtaining the gyms and the stops..

    That is what I'm figure out.. Maybe we could bypass the whole..

    So we can get an permission..


    The next updates of this app will be trading abilitys with bluetooth..
    And heard storys about battling against eachother..

    The new manifest of the 3th version gives the right impression..

    But it never going to be for our blackberry users if we find a good solution and patch for this whole server issue

    Or make a token toggler.. but that doesnt help the smooth play of the game

    Posted via the CrackBerry App for Android
    Dominique Derrier likes this.
    07-26-16 03:20 PM
  25. programagor's Avatar
    I did read that, I just thought that by restarting one of these services I might reinitialise connection to the server, effectively simulating full reboot of my phone. I don't know the inner dependencies, so I just tried.
    07-26-16 03:31 PM
726 ... 1617181920 ...

Similar Threads

  1. Switching from OS7 to OS10: email organization, any help?
    By CrackBerry Question in forum BlackBerry 10 OS
    Replies: 22
    Last Post: 09-03-16, 12:09 AM
  2. BES 12 on Android - phone not receiving messages after lock screen
    By Roveer in forum BlackBerry Secure UEM & Productivity Suites
    Replies: 9
    Last Post: 07-17-16, 09:48 PM
  3. BlackBerry won't rule out another BlackBerry 10 phone
    By Erik_1991 in forum BlackBerry 10 OS
    Replies: 7
    Last Post: 07-11-16, 07:38 PM
  4. Pokemon Go?
    By MrMooshroom in forum More for your BlackBerry 10 Phone!
    Replies: 3
    Last Post: 07-11-16, 05:50 PM
  5. Bloomberg: BlackBerry Won’t Rule Out New Phone Running on its BB10 System
    By Sairos in forum General BlackBerry News, Discussion & Rumors
    Replies: 1
    Last Post: 07-11-16, 04:41 PM
LINK TO POST COPIED TO CLIPBOARD