1. BD_BB_8520's Avatar
    Update: Success!

    I deleted everything and started from scratch. It worked, I now have Google Play Store!

    I have been using my z 10 for about 1 year without using Google Play Store...just never had the need, and was too scared to try Cobalts method. But man its really EASY and BIG THANKS TO COBALT for making this. I wish I could contribute some $$ my friend but unfortunately I cannot, but lots of positive energy directed your way.

    Now I basically put in the runtime so that I can use WhatsApp , which I use extensively for my work purposes. But I am unable to use it, it says (please see attached pic)

    I m reading up on the forum, is it because I used 4.3? do I need to upgrade to 4.4? I will read up more on forum to see if I can solve the problem.

    So, so far, very happy that I have play store on my z 10, but unable to use the 2 apps I have downloaded ; WhatsApp & Prisma.

    Thanks again to Cobalt, I'm in awe of my z10, hoping I can get this to work Google Play Store for BlackBerry 10 [OUTDATED]-img_20160730_175503.png

    Update : put in 4.4, installed. WhatsApp, Prisma still not working...any advice..?
    Last edited by BD_BB_8520; 07-30-16 at 08:54 AM.
    07-30-16 07:25 AM
  2. rseguro's Avatar
    No, I could never install "google play services."
    I have the equipment to a factory reset because before installed "google play store" with the following files and according to the following sequence:
    1 - cobalt.blackberry.googleid-2.8.apk
    2 - com.android.vending-6.0.0-cobalt-build1.apk
    3 - com.google.android.gsf.login-4.3.3-cobalt.apk
    But the file (com.google.android.gms-4.8.89-cobalt-build5) was unable to install before, so I did a factory reset and tried again following the steps of the first page.
    Step 1: Install Google Play Services;
    Step 2: Add a Google system account to your device;
    Step 3: Register your device with Google Play;
    Step 4: Install Google Play Store;
    BD_BB_8520 likes this.
    07-30-16 07:28 AM
  3. BD_BB_8520's Avatar
    Hi Conite / Cobalt

    how to use the patcher file available in Cobalts fileshare? thank you.
    07-30-16 08:56 AM
  4. conite's Avatar
    Hi Conite / Cobalt

    how to use the patcher file available in Cobalts fileshare? thank you.
    Use it on your PC.
    BD_BB_8520 likes this.
    07-30-16 09:54 AM
  5. BD_BB_8520's Avatar
    Google Play Store for BlackBerry 10 [OUTDATED]-1.pngGoogle Play Store for BlackBerry 10 [OUTDATED]-2.pngHi Conite / Cobalt

    Used the patcher fileshare in my PC.

    Downloaded Java.
    Still getting 'Java.exe not found' Please advise. Do I need to 'patch' for WhatsApp?

    Edit : 1st pic is to show that path is correct [ie. java.exe.]
    2nd pic is to show the error I receive
    07-30-16 10:45 AM
  6. conite's Avatar
    Hi Conite / Cobalt

    Used the patcher fileshare in my PC.

    Downloaded Java.
    Still getting 'Java.exe not found' Please advise. Do I need to 'patch' for WhatsApp?

    Edit : 1st pic is to show that path is correct [ie. java.exe.]
    2nd pic is to show the error I receive
    Just navigate to java.exe again, because every time it gets updated, it moves to a new folder.

    You only need to patch WhatsApp if you want to get rid of the splash screen. Otherwise it will run OK.
    BD_BB_8520 likes this.
    07-30-16 11:13 AM
  7. rseguro's Avatar
    Did you ever have a previous version installed on your device at any time in the past?
    Sorry to insist Conite, but is there any problem with the phone? I am not familiar with these things but I always try to do as described in the forums.
    Is strange, the phone allow you to install other files less "google play services".
    BD_BB_8520 likes this.
    07-30-16 11:19 AM
  8. conite's Avatar
    Sorry to insist Conite, but is there any problem with the phone? I am not familiar with these things but I always try to do as described in the forums.
    Is strange, the phone allow you to install other files less "google play services".
    Launch BlackBerry Google ID app. Tap on 3 dots at the top right, select Android settings, then apps. Do you see Google Play Services listed there?
    07-30-16 11:24 AM
  9. BD_BB_8520's Avatar
    Hi Conite,

    " Just navigate to java.exe again, because every time it gets updated, it moves to a new folder.

    Sorry, I did not understand. I read on the forum that I should put the exe file of patch 1.5 in the exe of 1.4...sorry can you please explain what you meant by " navigate to java.exe again? thank you


    You only need to patch WhatsApp if you want to get rid of the splash screen. Otherwise it will run OK.

    'Splash screen'? I cannot seem to install WhatsApp, it sends me the code then gives me the device not supported msg. What should i do?

    "
    07-30-16 11:38 AM
  10. conite's Avatar
    Hi Conite,

    " Just navigate to java.exe again, because every time it gets updated, it moves to a new folder.

    Sorry, I did not understand. I read on the forum that I should put the exe file of patch 1.5 in the exe of 1.4...sorry can you please explain what you meant by " navigate to java.exe again? thank you

    "
    These are two entirely different things.

    Make sure the Play Services Patcher 1.5beta executable is in the Play Services Patcher 1.4 folder. Make sure you select "update framework" in the app the first time you use it.

    Go to the paths tab, select Java, and navigate to the jave.exe file on your PC.
    BD_BB_8520 likes this.
    07-30-16 11:43 AM
  11. BD_BB_8520's Avatar
    Hi rseguro,

    I have been reading your posts in the thread. I have similar problems, can you tell me how you overcame the 'cannot find java.exe ' issue? I have the same issue, I am trying to patch WhatsApp.

    I wanted to suggest, deleting everything from Cobalt, and then starting fresh. I have been trying for the last couple of days and I did this today. I deleted everything and then started from step 1.

    Good news is that (finally) I have been able to get the play store open. but I cannot seem to get any downloaded apps working. Thats is why I am asking about your patching experiance.

    Wish you good luck
    07-30-16 11:48 AM
  12. rseguro's Avatar
    Hi rseguro,

    I have been reading your posts in the thread. I have similar problems, can you tell me how you overcame the 'cannot find java.exe ' issue? I have the same issue, I am trying to patch WhatsApp.

    I wanted to suggest, deleting everything from Cobalt, and then starting fresh. I have been trying for the last couple of days and I did this today. I deleted everything and then started from step 1.

    Good news is that (finally) I have been able to get the play store open. but I cannot seem to get any downloaded apps working. Thats is why I am asking about your patching experiance.

    Wish you good luck
    ------

    Hello BD_BB_8520,
    I use the "PS_Patcher 1.4-win v1.4-end" and the steps I made were:
    1 - I installed the "PS_Patcher 1.4-win v1.4-final" program;
    2 - I updated the java version "Version 8 Update 101"
    3 - Open the program "Pather-1.4" and the tab "Paths" - "Application path" - click "Browse" field, "Java exe";

    Google Play Store for BlackBerry 10 [OUTDATED]-patch_1.4.png

    3 - Then I looked at the PC disk which was installed the program and selected "Java.exe";

    Google Play Store for BlackBerry 10 [OUTDATED]-patch_1.4_2.png

    4 - Then I did the "patch" and resulted in my case;
    I hope this information is useful and sufficient to get to work, good luck.
    Thank you.
    BD_BB_8520 likes this.
    07-30-16 04:54 PM
  13. rseguro's Avatar
    Launch BlackBerry Google ID app. Tap on 3 dots at the top right, select Android settings, then apps. Do you see Google Play Services listed there?
    Hi Conite,

    I did the steps indicated, but unable to find the "google play services" in the apps.
    Will it work with the older file "google play services" ???
    I say this because my phone also does not let to install the file "com.google.android.gsf.login-4.4.4-cobalt" I have to install the previous file "com.google.android.gsf.login-4.3.3- cobalt " to work fine;
    Thanks for the support Conite.
    07-30-16 05:16 PM
  14. conite's Avatar
    Hi Conite,

    I did the steps indicated, but unable to find the "google play services" in the apps.
    Will it work with the older file "google play services" ???
    I say this because my phone also does not let to install the file "com.google.android.gsf.login-4.4.4-cobalt" I have to install the previous file "com.google.android.gsf.login-4.3.3- cobalt " to work fine;
    Thanks for the support Conite.
    Installation of 4.4.4 requires Google Play Services, so I would understand why you can't install it.

    Try downloading Cobalt's Google Play Services again. Maybe something was corrupted in your first download. There is no reason why it shouldn't install.
    07-30-16 05:29 PM
  15. rseguro's Avatar
    Installation of 4.4.4 requires Google Play Services, so I would understand why you can't install it.

    Try downloading Cobalt's Google Play Services again. Maybe something was corrupted in your first download. There is no reason why it shouldn't install.
    Hi Conite,
    I re-downloaded the file and installed perfectly ... many thanks Conite.
    I do the same with the 4.4.4 file ????
    it automatically updated 4.3.3 ???

    Thanks again for the help Conite
    07-30-16 05:43 PM
  16. conite's Avatar
    Hi Conite,
    I re-downloaded the file and installed perfectly ... many thanks Conite.
    I do the same with the 4.4.4 file ????
    it automatically updated 4.3.3 ???

    Thanks again for the help Conite
    Yes. 4.4.4 will install right over 4.3.3.
    07-30-16 05:46 PM
  17. rseguro's Avatar
    Yes. 4.4.4 will install right over 4.3.3.
    Hi Conite,
    4.3.3 updated with the file 4.4.4
    Now when asked to add a Google Account, do I enter my account details and gives me error, says he has problems on Google's servers ...
    Is there any way to fix this ???
    07-30-16 06:01 PM
  18. conite's Avatar
    Hi Conite,
    4.3.3 updated with the file 4.4.4
    Now when asked to add a Google Account, do I enter my account details and gives me error, says he has problems on Google's servers ...
    Is there any way to fix this ???
    You are not supposed to mess with it. Just install overtop. No need to sign in.
    07-30-16 06:31 PM
  19. rseguro's Avatar
    You are not supposed to mess with it. Just install overtop. No need to sign in.
    Thanks Conite, I have my BB working fine...
    07-30-16 06:35 PM
  20. BD_BB_8520's Avatar
    Thank you Conite , Cobalt & rseguro. Apps patched!

    Now problem is that it is saying whatsapp version is not right, pls download new version from play store :/

    Update : Prisma App patched, working!
    tried to patch Instagram, said patch not required
    so Instagram working thru Cobalts mod apps
    thank you Cobalt, Contie rseguro, and the Forum
    Last edited by BD_BB_8520; 07-31-16 at 06:32 AM.
    07-31-16 01:27 AM
  21. cpapou's Avatar
    Hi, can anyone help me with the first step? I am downloading the file but I get an error saying unable to open file. Is there a solution for this?
    07-31-16 01:28 AM
  22. Smokeaire's Avatar
    Hi, can anyone help me with the first step? I am downloading the file but I get an error saying unable to open file. Is there a solution for this?
    Look at the file name using File Manager. Does the file end with the .APK extension? If not add it.
    DreadPirateRegan likes this.
    07-31-16 03:26 AM
  23. DreadPirateRegan's Avatar
    Look at the file name using File Manager. Does the file end with the .APK extension? If not add it.
    Just had to do this with showbox tonight. Great tip.

    Posted via CB10
    07-31-16 05:12 AM
  24. KAVIYARASAN S's Avatar
    Thank you so much
    07-31-16 06:15 AM
  25. adrian mangoting's Avatar
    please update the google play service and google play game for BlackBerry z10..thank you Mr.cobalt..
    07-31-16 07:31 AM
6,718 ... 229230231232233 ...

Similar Threads

  1. Looking for an app: Task Reports S4BB
    By Lilysterra in forum BlackBerry Bold Series
    Replies: 12
    Last Post: 12-10-19, 06:58 PM
  2. Storage full on BlackBerry Z3
    By Jobin m vadath in forum Ask a Question
    Replies: 20
    Last Post: 11-08-19, 08:42 PM
  3. Chinese KEY2 and Google Play Store and Service?
    By FallStaff in forum Ask a Question
    Replies: 1
    Last Post: 11-06-19, 05:20 PM
  4. BlackBerry Motion software update ACF202 now available
    By CrackBerry News in forum CrackBerry.com News Discussion & Contests
    Replies: 0
    Last Post: 11-06-19, 04:40 PM
  5. Downgrade OS on BlackBerry Z3?
    By Jobin m vadath in forum Ask a Question
    Replies: 3
    Last Post: 11-06-19, 01:50 PM
LINK TO POST COPIED TO CLIPBOARD