09-02-16 10:38 AM
111 1234 ...
tools
  1. Brit6's Avatar
    I have been running the August door lock using my Passport on 10.3.0.908 since October 29th, 2014 thanks to Sally! I have had no issues at all with the patched app, my door works every time!

    My friend works at Apple and bought the lock for me from the USA and brought it over the border.

    August does ship to Canada now but be careful of the shipping, brokerage, taxes.
    02-18-15 09:49 PM
  2. Brit6's Avatar
    Thanks Sally! August just updated the Android app to version 2.0.16.1 on February 13th, 2015

    I will download that .apk and post it here when I get a minute.
    02-18-15 09:50 PM
  3. Brit6's Avatar
    Did you download the patched .apk from this thread eman8567?
    02-18-15 09:51 PM
  4. Brit6's Avatar
    Sally here is the latest version, can you please patch it

    For fun I tried to run it on 10.3.1 and it gives the same error. It must be patched for it to work.

    http://storage.evozi.com/apk/dl/15/0...Q&t=1425595243
    Last edited by Brit6; 03-05-15 at 04:08 PM.
    03-05-15 03:45 PM
  5. Brit6's Avatar
    I downloaded the GMaps Patcher from Sallys link. I am trying right now to patch it myself!
    Sally Mack likes this.
    03-05-15 05:19 PM
  6. Brit6's Avatar
    Here is the patched version incase anyone wants it. I am going to try and install it now.

    http://we.tl/RKURd3ytWY
    Sally Mack likes this.
    03-05-15 06:10 PM
  7. Brit6's Avatar
    So i'm going to post this problem here, but I don't believe it is app related.

    I have a feeling that since 10.3.1 there has been an update to the Bluetooth radio and now it is taking forever to authenticate with the lock, it used to take anywhere from 1-10seconds. Now it can take anywhere from 20-60seconds. It was doing this same problem before I updated the app but can't remember if it was doing it before I updated to 10.3.1.

    Software Release: 10.3.1.1779
    OS Version: 10.3.1.2576
    Radio Version: 10.3.1.2577
    Last edited by Brit6; 03-17-15 at 12:34 PM.
    03-17-15 12:05 PM
  8. Sally Mack's Avatar
    Anyone else using the same version of this apk (I'm assuming it's the latest brit6?), on a different os version? That'll help isolate the issue.
    03-19-15 08:55 PM
  9. Brit6's Avatar
    Correct, it is the latest version.

    I think I've narrowed it down to possible 2 things. I have tried it on my friends Z10 running 10.3.1 and it has the same issue.
    I do not have the problem with my iPhone 6+ or my Samsung Galaxy S3 Mini running Lollipop.

    1) Bluetooth radio version
    2) Didn't 10.3.1 upgrade the android runtime to 4.3?
    03-26-15 08:17 AM
  10. Sally Mack's Avatar
    1) Same version as 10.3.0... but of course it's possible BlackBerry made some core changes to the BT radio.

    2) 4.3 has been in place since 10.3.0
    03-26-15 12:04 PM
  11. Sally Mack's Avatar
    http://forums.crackberry.com/showthread.php?p=11389447

    I'd try to side load the bars in that Post. It's an older version of the android runtime that is more compatible with certain apps. See if it works
    03-26-15 12:16 PM
  12. Brit6's Avatar
    Thanks Sally. I tried installing an older android runtime 10.3.124 (from OS 938) and it has the same result.

    Is it worth trying to install a old BT radio file?

    I kind of look stupid standing outside my door for 1 minute waiting for my app to connect lol.
    03-28-15 12:21 PM
  13. Sally Mack's Avatar
    Not sure which file that would be, but I wouldn't recommend messing with the BT files, unless you're prepared to wipe and reload if things go south. Too much can go wrong imo.
    03-28-15 01:52 PM
  14. Sally Mack's Avatar
    Just to add some more info on the BT radios... if you do indeed want to mess with that (maybe try the one from 10.3.0 that worked fine? Though I'm a tad weary of jumping branches like that)...

    For reference, the filename structure for the bluetooth radio file is: bluetooth-10.3.2.483-nto+armle-v7+signed.bar
    The user quoted above has side loaded different bt radio bars successfully, so perhaps there may be a solution there.

    Also, when patching, did you use cobalt's latest version of the windows patcher? (I think 1.3.1) And did you apply all patches detected? Sometimes leaving one out helps -- I believe it's the protectionLevel=signature one.
    04-02-15 10:59 PM
  15. anon(1852343)'s Avatar
    What happens if your cell phone dies, are you locked out?

    Blackberry Passport running 10.3.2.281
    04-02-15 11:17 PM
  16. Sally Mack's Avatar
    You can still use a plain old key, or borrow someone else's phone.
    anon(1852343) likes this.
    04-02-15 11:35 PM
  17. Rezwrld's Avatar
    No problem...So I did some amateur patch work:

    1. Modified the minSdkVersion = 18 (jellybean)
    The app originally was set to 19 (kitkat), so I can't guarantee that everything will work right, but it's worth a shot.

    2. Patched the google play services dependency. To avoid any unexpected "google play services required" errors, you'll also need to install the patched google play services 5.0.89 apk cobalt kindly provided in this thread http://forums.crackberry.com/android...g-page-965257/

    3. Tried to remove some extra protection that detects "tampered" apk files for google play services. Not sure if it'll make any difference, but the protection is tied to location and geofencing.

    I've installed the apk, and ran it (but didn't sign in or anything) and it at least starts up. Give it a shot, and let us know how it goes! I've been looking at getting one of these for awhile, and would be curious to hear how the lock works with a hacked up apk on a blackberry 10 device.

    https://app.box.com/s/1nkz3dl1afuffnv9wn2h
    Sally I read about this miracle that you worked out for Brit. Is it possible you can figure out the Kevo lock app?? It is basically the same problem. It says unable to install app. Here is a link to the apk.
    https://app.box.com/s/zyqjzym3x1dsofv25vdagdxjr9p6unlx

    If so I will post it to the Kevo google group.

    You can go anywhere with a Passport <3
    04-04-15 10:44 PM
  18. Sally Mack's Avatar
    Check out post # 16 of this thread for info and an easy tool to patch the apk yourself.
    04-05-15 01:36 AM
  19. Rezwrld's Avatar
    I followed the instructions to the T. But when I select the file and click rebuild it doesn't move to the next screen with that particular file. It works fine with others. I figured it was something a bit more advanced necessary.

    You can go anywhere with a Passport <3
    04-05-15 02:15 AM
  20. Sally Mack's Avatar
    I followed the instructions to the T. But when I select the file and click rebuild it doesn't move to the next screen with that particular file. It works fine with others. I figured it was something a bit more advanced necessary.

    You can go anywhere with a Passport <3
    Strange... will have a look tomorrow.
    04-05-15 02:57 AM
  21. Brit6's Avatar
    I actually tried the whole radio file from 10.3.0.908 and it made my radio not work anymore and the phone wouldn't boot, so I had to restore my passport to a backup I just made before I did it.

    I am thinking of just trying the Bluetooth .bar from the same release if I can sort it out.

    I did use the latest version of the patcher and I patched everything, I can always try leaving that one out as well.

    On another note, I ended up patching the new version of August from Mar 26th, 2015 from the Google play store and it installed and opened, but as soon as I tried to unlock the lock the app would crash every time.

    I had to go back to the Feb 13th, 2015 version of the patched app which still works but takes 30-60secs to authenticate with the lock. I thought about purchasing the August Connect which will connect to the August Smart lock and enable it over wifi which should technically fix the problem since you will be connecting via wifi to the August Connect and then it will connect via Bluetooth to the lock.

    Just to add some more info on the BT radios... if you do indeed want to mess with that (maybe try the one from 10.3.0 that worked fine? Though I'm a tad weary of jumping branches like that)...



    The user quoted above has side loaded different bt radio bars successfully, so perhaps there may be a solution there.

    Also, when patching, did you use cobalt's latest version of the windows patcher? (I think 1.3.1) And did you apply all patches detected? Sometimes leaving one out helps -- I believe it's the protectionLevel=signature one.
    04-08-15 12:28 PM
  22. Sally Mack's Avatar
    I'm not sure taking any bars from the 10.3.0 branch will yield you much luck... perhaps the early 10.3.1 leaks? Depending on how much backing up and restoring you want to do, I'm sure you can try all sorts of combinations
    04-08-15 11:17 PM
  23. Sally Mack's Avatar
    Sally I read about this miracle that you worked out for Brit. Is it possible you can figure out the Kevo lock app?? It is basically the same problem. It says unable to install app. Here is a link to the apk.
    https://app.box.com/s/zyqjzym3x1dsofv25vdagdxjr9p6unlx

    If so I will post it to the Kevo google group.

    You can go anywhere with a Passport <3
    Well, it worked for me flawlessly... here's a link to the patched apk https://app.box.com/s/7n0hqofr5l2l8vpeiluatg58igzlozlc
    04-08-15 11:20 PM
  24. Wigley458's Avatar
    Has anyone been able to get the most current patched file working proper yet. Also I c the link for patch Apk is down.
    04-11-15 10:45 PM
  25. Brit6's Avatar
    Just an update for everyone. My app is back to normal now, and I have not changed anything! It will authenticate within 8-10seconds every single time no hesitation! I am running the old version from Feb 13th, 2015. My feeling is they changed something on the server end!

    I noticed that August released a new Android version 2.0.36.4 on April 10th, 2015. I have not tried this version yet, since mine is working normally again. It does say that this version must be installed by May 7th, 2015, so maybe the old ones will stop working after then!

    Thanks everyone for their comments/assistance.
    04-13-15 09:42 AM
111 1234 ...

Similar Threads

  1. Android App Lag
    By frankiej in forum BlackBerry Z30
    Replies: 14
    Last Post: 09-08-17, 02:09 AM
  2. Android runtime
    By Ab Rebello in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 10-28-14, 06:43 PM
  3. Connect to Dropbox needs % when transferring files
    By spikesolie in forum General BlackBerry News, Discussion & Rumors
    Replies: 4
    Last Post: 10-27-14, 11:09 PM
  4. Replies: 3
    Last Post: 10-27-14, 01:51 PM
  5. The Keys to Executing a Turnaround the Right Way by John Chen (LinkedIn post by him)
    By mtaylor in forum General BlackBerry News, Discussion & Rumors
    Replies: 1
    Last Post: 10-27-14, 11:04 AM
LINK TO POST COPIED TO CLIPBOARD