1. lucarossisp's Avatar
    I have a Q10 recently updated to 10.3.3.1463 and noticed that some apk give the error in title when trying to install them. I guess some app are not supported anymore on BB10 OS.
    For example: install google maps. I search for the last version (9.69.1) and find that akmirror has 23 variants of the same version, e.g.:

    969103030 (variant)
    universal (architeture)
    Android 4.4+ (Minimum Version)
    nodpi (Screen DPI)

    969103040 (variant)
    universal (architeture)
    Android 5.0+ (Minimum Version)
    nodpi (Screen DPI)

    969103131 (variant)
    arm (architeture)
    Android 4.4+ (Minimum Version)
    120-160dpi (Screen DPI)

    969103241 (variant)
    arm64 (architeture)
    Android 5.0+ (Minimum Version)
    120-160dpi (Screen DPI)

    969103332 (variant)
    x86 (architeture)
    Android 4.4+ (Minimum Version)
    213-240dpi (Screen DPI)

    969103441 (variant)
    x86_64 (architeture)
    Android 5.0+ (Minimum Version)
    120-160dpi (Screen DPI)

    all the variants here: https://www.apkmirror.com/apk/google...-69-1-release/

    I downloaded the first variant, but I got "unable to install this app".

    So which version should I install not to get the error ?

    p.s. "allow apps from other sources to be installed" in ON in the settings
    Last edited by lucarossisp; 01-17-18 at 10:09 AM. Reason: forgot something
    01-17-18 10:06 AM
  2. thurask's Avatar
    The Android runtime mimics Android 4.3, so none of those will work. Moreover, unless you do some voodoo, any app that needs Google Play Services (like Maps) will hit a wall.
    lucarossisp likes this.
    01-17-18 10:29 AM
  3. lucarossisp's Avatar
    Oh thank you for the info, i'm gonna try that.
    01-17-18 02:36 PM
  4. lucarossisp's Avatar
    The Android runtime mimics Android 4.3, so none of those will work. Moreover, unless you do some voodoo, any app that needs Google Play Services (like Maps) will hit a wall.
    Which architecture should I choose between arm and x86 ?

    Because I saw that google maps version 9.64.1 has some variants for android 4.3+, but I don't know if I have to download arm or x86 variant
    Last edited by lucarossisp; 01-17-18 at 03:11 PM.
    01-17-18 02:59 PM
  5. conite's Avatar
    Which architecture should I choose between arm and x86 ?

    Because I saw that google maps version 9.64.1 has some variants for android 4.3+, but I don't know if I have to download arm or x86 variant
    Arm (NOT arm64). Also, 320dpi is usually best. 480dpi for Passport.
    lucarossisp likes this.
    01-17-18 03:37 PM
  6. lucarossisp's Avatar
    Thank you very much sir
    01-17-18 03:48 PM
  7. Imran Khan007's Avatar
    Hi can anyone please solve my issue,imo apk installed but after giving my phone number, it stuck with the page!!!!
    Showing "one moment please"


    Posted via CB10
    03-18-18 09:02 AM
  8. 7mike9's Avatar
    Hi can anyone please solve my issue,imo apk installed but after giving my phone number, it stuck with the page!!!!
    Showing "one moment please"


    Posted via CB10
    The last working version for BB10 is 9.8.000000007501

    Posted via CB10
    03-18-18 12:40 PM

Similar Threads

  1. :( Where's PayPal? It's supposed to be embedded in BBM.
    By WiseEyes in forum General BBM Chat
    Replies: 8
    Last Post: 01-30-18, 12:56 PM
  2. How can I install the Google Settings app?
    By ofure in forum Ask a Question
    Replies: 8
    Last Post: 01-19-18, 03:17 AM
  3. Amazon App glitch?
    By FishhPoohh in forum BlackBerry Motion
    Replies: 2
    Last Post: 01-17-18, 10:08 AM
  4. Replies: 1
    Last Post: 01-17-18, 09:31 AM
  5. Error reporting window?
    By Emaderton3 in forum BlackBerry Android OS
    Replies: 1
    Last Post: 01-17-18, 08:42 AM
LINK TO POST COPIED TO CLIPBOARD