1. hikerbiker75's Avatar
    My Bold 9700 will not change ringtones or text alert/email alert sounds. I have reinstalled the OS twice, disconnected the battery twice, restarted it several times, and of course have tried changing ringtones contact by contact and in sound profiles. Nothing. This is a new problem--just started a couple of days ago. Any advice or ideas would help.
    12-29-10 06:32 PM
  2. starchit's Avatar
    Man how frustrating. When you say it won't let you change them, do you mean you can select a different tone from the drop-down list but it doesn't change it? Or do you mean there's no different tones listed in the drop-down list? Also, are the tones on SD card or device memory? Do the tones play using the Media Player? Just trying to narrow down the problem.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-29-10 06:57 PM
  3. hikerbiker75's Avatar
    All of my ringtones are there. It shows that I have "Harry Potter" set to be my ringtone in the sounds/ringtones options, but it will only play the T-Mobile Jingle. I have tried to use several other of my ringtones, including the ones that came with the Blackberry, but it won't play them. It always plays the ringtone it has chosen for me. I think the ringtones are on the device memory, and they do play on the media player.
    12-29-10 07:06 PM
  4. starchit's Avatar
    Hmmm, always plays the carrier's default, no matter what's selected. Like you, I'm lost here. What keeps coming to mind is insufficent memory. But, if that was the case you would be having more problems. Have you tried moving a tone to the SD card to see if it'll work from there?

    I use TMO and the only time my device reverts to the T-Jingle is when I've assigned a tone from the SD card and I have the device plugged in to a PC with mass storage on. Thus, the SD card isn't available to the device.

    Sure hope others chime (no pun intended) in here with ideas.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-29-10 07:24 PM
  5. hikerbiker75's Avatar
    You mentioned mass storage being enabled, and I remember seeing that it was for reason enabled. I went in and disabled it, and sure enough, the ringtone I want is back. Thank you. You are a rockstar.
    12-29-10 07:49 PM
  6. starchit's Avatar
    Thank you. That means your ring tones are on the SD card. Glad I could help.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-29-10 08:06 PM
  7. Rootbrian's Avatar
    You mentioned mass storage being enabled, and I remember seeing that it was for reason enabled. I went in and disabled it, and sure enough, the ringtone I want is back. Thank you. You are a rockstar.
    Remember to enable mass storage support if you need to transfer media to and from the SD card. I remember forgetting to change that setting back and got super frustrated and went to my carrier to see why it wouldn't work (had a pearl then) and they pointed it out to me. Now it's the norm

    Posted from my CrackBerry at wapforums.crackberry.com
    12-29-10 09:39 PM
LINK TO POST COPIED TO CLIPBOARD