1. Matic386's Avatar
    Hey. I decided to put some full length movies on my Storm2. I downloaded a few of them from mp4pig.webs.com and the first one is OK, plays nice, overall good.
    Then I downloaded a few more, and not one of them will play on my storm(they all play on computer). On Storm I would get green screen and only sound, now I don't know what to do, they just won't play, no matter what I do.
    Few extra notes:
    -I converted another move myself from mp4 to avi, and it works just fine(funny thing is that .avi is 640mb and after conversion the .mp4 is around 760mb in size )
    -I updated my BB via DM, restarted it multiple times, but without success
    -Tried putting movies on SD card, over card reader and by cable(computer-cable-BB) but it's the same, green screen and sound only
    -I think there is a codec problem, but I have absolutely no idea about how to install extra codecs on Storm
    -The movies that I recorded with phone work well too
    04-27-10 10:37 AM
  2. bad_boy321's Avatar
    I use a converter program. Seach the web for some free ones and you shoul dbe pretty happy. I noticed it is a codec problem for some movies. I know I've gotten the green screen as well and just reconverted it and it fixed the issue. this forum has TONS of free movies already formatted and ready for download. this is where I go for my initial search.

    happy hunting.
    04-27-10 10:56 AM
  3. dkingsf's Avatar
    I never use MP4 format on mine, I rip DVD's to AVI because the size issue. AVI files for full length movies are all under 600K. I have 20 full length movies on my SD card and they all play fine in AVI format. But, have to say I also have some MP4 movie trailers that I downloaded via Poynt and they all work fine as well. I had problems with playing movies at all with .607 OS, both the leak and official and had to go back to 517 (now using the 517 as base for OOAK hybrid). If you're on 607 OS, try downgrading to the 517 and see how that goes.
    04-27-10 04:26 PM
  4. Matic386's Avatar
    Heh, lol I had no idea that I can put .avi movies on BB too, and it will play. Now I tried and it worked quite good(FFS, yea it worked good for the first 10s, then it started to "pixelate", I can see these squares jumping on the screen while playing move, and yes, I'm back at the begginig, I'm gonna start to give up on BB playing movies)
    Now I used also handbrake program to convert .avi to mp4, again the 1.st one that was converted works, and the last 2(converted separately) don't.
    What settings are you using for converting movies with handbrake, so that movies play nicely on BB?

    Yea, I'm on 607 OS, but I think I'll wait for the next one rather than downgrading to 517.
    Last edited by Matic386; 04-28-10 at 04:13 AM.
    04-28-10 04:07 AM
  5. saoirse73's Avatar
    I found 517 to play avi's the best. 320 was crap, and 607 is pot luck. I use a few converters for this but when I test I use only one and settings known by me to work (at least on 517).

    I have some shows and movies but even when they do play, when I decide to play something else it sometimes just pixelates into error... sometimes not!

    I now use my ipod touch for movies because I know that it will play everytime and never ever pixelate or error...ever. I spend time every afternoon at a train station waiting for my wife (not worth going home from work) and nothing is more annoying than than finding out something will not play...

    I plan on putting 517 back on because I had almost no problems with the way I convert but I am having screen problems and dont se the point in messing with it if Im gonna replace it.
    04-28-10 07:05 AM
  6. Nedooo's Avatar
    All useless replies :0
    First check resolution of videos. Wont do wider than the resolution of Storm screen that's 480, second encoding of video, beacouse you have for example DIVX in .AVI and .MP4 container (extension). There is verry good converter caled any video converter just set resolution 480x320, and you can even embed subtitles with all sort of font encoding.
    Also, under edit -> options -> video just check expand to frame size to have fullscreen video (almost) on Storm.
    Enjoy.
    04-28-10 08:03 AM
  7. zkyevolved's Avatar
    I like:
    Videora BlackBerry Storm Converter

    it's easy to use.
    04-28-10 02:26 PM
  8. blkbryluva's Avatar
    I use mobile video for 3GP converter for mine and you can choose to convert them for the storm automaticly. It has worked with all the os's I've had perfectly fine...
    04-28-10 02:42 PM
  9. Matic386's Avatar
    I've tried the any video converter, it is much better than handbrake, so if anyone else is "newb" in video converting for his/her phone, I would recommend using ANY VIDEO CONVERTER!

    Now I'm so far I started adding subtitles, and here I have an question. Do subtitles have to be in NATIVE/ORIGINAL/NOT CONVERTED/... movie's framerate OR in CONVERTED movie's framerate to be aligned with the speech? Let's say I have movie with 25fps, and then I convert it for BB, the converted movie then has(by default) 24fps, which .srt file should I choose, the one made for 25fps or the one made for 24fps?
    05-03-10 01:07 PM
  10. madz777's Avatar
    Hi
    I have a torch and I'm getting green/pink lines screen on all my downloaded videos both mp4 and 3gp that used to play fine and also getting it on my video camera when I try to record?
    I don't think this can be because of file type. My camera is working fine and still pictures are unaffected. It's just video.
    Any help much appreciated
    Madeleine x
    03-20-11 05:12 AM
LINK TO POST COPIED TO CLIPBOARD