1. snowsquirrel's Avatar
    Just trying to upgrade my 8900 from .114 to .168. Running the loader.exe, progress halts after uploading ram image, and devices seems to power itself off, until batter pull/replace.

    I am not sure if it is just .168, or other os versions would have this.

    Has anyone else had this problem upgrading OS's on vmware? Backing up and restoring seems to work no problem, through VMware.

    Thanks,
    ~S
    03-04-09 11:18 PM
  2. trunk's Avatar
    had any of the same problems on normal OS? im not sure why it wouldnt work on vmware though, but you never know. try re-downloading and installing the OS your trying to install. also, have you tried upgrading with DM?
    Last edited by trunk; 03-04-09 at 11:43 PM.
    03-04-09 11:39 PM
  3. snowsquirrel's Avatar
    I actually don't have a windows computer to try it on. They ones at work are totally locked down. My other computers in house are an ubuntu box, and a solaris sparc server.

    I doubt it is worth my time to try and get a different os version for the phone, as it is likely a vmware problem.

    NOTE: I did do it in full screen, so make sure I didn't lose focus, and disconnect my usb ports.

    Maybe I'll try at a friends house some time.

    ~S
    03-04-09 11:52 PM
  4. osturrock's Avatar
    This is not just a VMWARE issue - I am having exactly same problem on Windows 7. My 8900 powers off after the loader says "connecting to Boot ROM", then says "Uploading RAM image" forever. Planning to try it on Windows XP later today.
    03-06-09 03:16 AM
  5. snowsquirrel's Avatar
    Hmmm, I was using XP on VMware. Let me know if it works for you today. Maybe I should try a different version, like .152 or something, but I there are a few issues with .152 like broken youtube that I would like to avoid.
    03-06-09 07:39 AM
  6. Ti-Mike's Avatar
    i have the same issue with the 8900 and 174 software

    i once upgraded with success, when the software was direcly available thru t Mobile and the upgrade has been dedected thru the desktop manager.........

    since then nothing no way
    03-09-09 07:48 AM
  7. patelvishaal's Avatar
    Hey i am also a mac user and a new to blackberry. I also have a 8900 and was trying to update trough vmware fusion. I had the same problem thank god i came through thread, cause i just ended up pulling the battery and doing a backup, although i would love to find out how u guys got around this problem. Currently i'm on the stock 4.6.1.94 os, but am looking to go on to the .168
    Your help would be much appreciated =D
    03-11-09 07:41 PM
  8. tmarkt's Avatar
    This is not just a VMWARE issue - I am having exactly same problem on Windows 7. My 8900 powers off after the loader says "connecting to Boot ROM", then says "Uploading RAM image" forever. Planning to try it on Windows XP later today.
    I'm getting the exact error messages on my 8330 curve. I've tried doing this in Sun's virtual box with Windows 7 and no luck. Now I've loaded boot camp in my son's computer and loaded windows 7 in it and still get the same errors (but the DM and BB work better under boot camp than virtualbox).

    I disabled USB selective suspend and even tried compatibility mode (for Vista, I may try Windows xp compatibility mode next).
    03-11-09 07:47 PM
  9. patelvishaal's Avatar
    well from what ive read windows 7 is a no no
    I guess ur best bet is windows xp
    but so far no one seems to have an answer ive looked everywhere
    03-11-09 07:54 PM
  10. ydaraishy's Avatar
    The Blackberry presents itself as a *different* device string when it reboots after the RAM image upload, which VMware doesn't know about. You need to add the USB device *again* once it reboots; or reboot your device before you upgrade in the VMware session so it knows both device strings.
    03-11-09 08:08 PM
  11. snowsquirrel's Avatar
    I never did get it working. I was going to wait until next time I had access to a windows box to do it.
    03-11-09 08:16 PM
  12. tmarkt's Avatar
    Well, I've either got the upgrade process working or I bricked my BB. The DM is saying it's doing things but the BB's screen is dark. Is this normal?
    03-11-09 08:26 PM
  13. patelvishaal's Avatar
    if the DM is saying connect to the device rom and is stuck in one spot for the longest time
    that is where it does nothing and ydaraishy said u have to add it agian
    i ended up booting up my windows machine that has been collecting dust and guess what it works no problems
    03-11-09 08:29 PM
  14. ydaraishy's Avatar
    Further note: if you add it again, the process will probably fail, you need to repeat it, or reboot your phone yourself and add it before you ebgin the upgrade process.
    03-11-09 08:44 PM
  15. tmarkt's Avatar
    It worked!

    For the record, you can update your BB running windows 7 in boot camp.

    My settings:
    -The DM and the "Blackberry Device Manager" were in Windows xp SP3 compatibility mode.
    -I disabled USB selective suspend

    Now I've got to figure out how to unlock some of the themes that are on it...
    03-11-09 08:49 PM
LINK TO POST COPIED TO CLIPBOARD