1. skwij's Avatar
    This is a copy/paste of a thread I started over at Macrumors.

    I've posted it here, in case anyone knows an answer. There's also an odd behaviour I noted today that seems to have "fixed" this issue:

    Original post:

    I'm running XPpro and Vista Ultimate in VM. As much as I hate Windoze, I have to use it to update the OS of the Blackberry, and to have a good backup of the phone.

    The Mac options (Missing Sync and PocketMac) for syncing and backing up and application installation are just not good enough or stable enough for me. I've not had the phone long, and haven't used Windoze in the virtual environment much before this.


    Here's my problem. In both Vista and XP, I get the USB icons on the lower right of the window, with the option to "connect RIM device" but nothing happens when I click that. Opening the Desktop Manager software shows NONE when listing devices. I've run VMware tools over and over again, for both versions of Windoze. The Blackberry will NOT connect!

    I thought I had it last night in the Vista install, as the device was seen, connected, and getting the latest device drivers. After the device drivers were installed, Nada. Again with the inability of Windows to connect to the BB, or even see it.

    I've installed Desktop Manager 4.3 from the disk, downloaded 4.6 from the BB site, and still no joy.

    Restarted/rebooted each Windoze VM multiple times, restarted VMware multiple times, and even rebooted the Macbook multiple times.

    All other hardware works fine, ie the Superdrive. I have NOT tested the iPod Touch or the iPhone in the Windoze environment.

    Running VMware 1.1.1 and am not eligible for a FREE upgrade.

    Just in case this is pertinent, I do have a 4GB microSD card in the BB.

    What's the deal here? How do I get Windoze to "see" the BB, so that I can use the Desktop Manager software?

    Thanks for any help. I'm usually pretty tech-savvy, but this has me stumped.

    And my reply to myself:

    Just an update.

    I logged into Windows today to transfer the DM and the new BB OS to a thumb drive to take to a friend's, who runs a Win PC. Lo and behold, the BB showed up, and was able to connect once I inserted the thumb drive into the second USB port.

    Odd, but hey, I'm good with it. Got the BB backed up just fine, but didn't have an hour and a half to do the OS install and restore of the 3rd party apps.

    Oh, and just a FYI, I didn't bootcamp my install of either Windoze install; it's ALL via VMware Fusion.

    Anyways, I thought I'd post this here, in case someone else has a USB issue with VMware. Any hint or workaround helps, right?

    03-01-09 09:57 PM
  2. ScandaLeX's Avatar
    I havent a clue what the answer to your problem is but I'm glad you were able to get done some of what you were trying to do- even if it meant going to a friends house.

    I posted this in your other thread. You may want to go to that post and delete it yourself. Click on edit and it will allow you to delete it. Posting the same thing can become screwy!!
    Last edited by ScandaLeX; 03-02-09 at 03:23 AM.
    03-02-09 03:21 AM
  3. stassi's Avatar
    I had that problem for a few days. I'm using a BootCamp install, and Parallels had stopped seeing my Blackberry. This was about 2 weeks ago, and they still haven't resolved the issue. BUT, there was a deal in which, after rebates, VMWare Fusion 2 would end up costing me $10!

    First attempts with Fusion were perfect, but after actually booting into bootcamp for something else, Fusion wouldn't recognize the BB (Storm). I found that deleting the USB connection from the configuration of the VM, then recreating it resolved the problem.

    Now, if I could only get past the constant Windows Reauthorization when booting from boot camp to Fusion, I'll be okay.

    P.S. - for everything else, I've preferred Parallels, but Fusion's just more reliable for the BB.
    03-03-09 02:07 AM
  4. lajaro's Avatar
    Do you have Missing Sync installed on your Mac by any chance? If so, it's hijacking the USB connection.

    Run Activity Monitor, find the Missing Sync processes, kill both of them and then try to connect to the virtual Windows session.
    03-03-09 03:53 PM
  5. skwij's Avatar
    Do you have Missing Sync installed on your Mac by any chance? If so, it's hijacking the USB connection.

    Run Activity Monitor, find the Missing Sync processes, kill both of them and then try to connect to the virtual Windows session.
    As a matter of fact, I do have MS installed. I don't know if it was running though, at the time.

    Thanks for the hint, though! Definitely one to keep in mind if this happens again.


    Interesting. Just checked Activity Monitor and there are 3 MS processes running, and they ARE listed in my startup items. Good to know they're running in the background, even though not "authorised" by me. That must happen by default in the install process.
    03-03-09 11:11 PM
  6. nikolous's Avatar
    i had the exact same problem in mine... i just ended up booting into bootcamp instead and it worked. I also tried plugging the usb cable into the mac first and THEN plugging into the fone. That worked as well. I'm not sure if it's an actual fix but it worked for me
    03-07-09 06:56 AM
  7. pilotcap#AC's Avatar
    Had the same trouble when trying to connect to Vmware Fusion/WinXP. MissingSync installs a startup item interfering with the Fusion usb connection. I had a ticket with MarkSpace about it and the "official" advice was: "Kill the running MS processes, if required".
    Shame that they charge you 30 Dollars for the upgrade that does not work as it should...
    03-08-09 10:29 AM
  8. bodisaffa's Avatar
    Yeah I just had same trouble this weekend, to solve I opened activity monitor on my mac and deleted the missing processes that were running, as soon as these were gone it picked it up straight away. Still couldn't update the OS though..... fatal error message

    Hope this helps.
    03-08-09 01:22 PM
  9. stassi's Avatar
    Geez, I never woulda thought of that! I was so annoyed, 'cause previously, Fusion was working great. I can't wait to try this, by killing the MS activities. I'm about to revert to 1.0.3 - does anyone know if that version had hidden startup items?
    03-10-09 01:48 AM
  10. stassi's Avatar
    Just a follow-up. I've uninstalled MissingSync 2.0, in preparation to revert to 1.0.3, and before installing the old version of MS, I tried connecting my Storm to Fusion 2.0.2. It saw the device right away! I hope MarkSpace fixes this problem, along with the others, when I finally want to reinstall MS2 again...
    03-11-09 12:48 AM
  11. stassi's Avatar
    So, it appears that MS Blackberry 2.0.1 came out today. It explicitly says to use Activity Monitor to disengage their background software, when using Parallels or VMWare Fusion. Looks like they didn't fix that particular problem. I'm sticking with my old 1.0.3 until I get more feedback on the new update.
    03-12-09 12:40 AM