01-07-10 01:26 PM
172 1234 ...
tools
  1. Fabmaclover's Avatar
    i tried pretty much everything i have read on this thread but it doenst work.... few questions:

    - i see that pretty who tried have a storm and with verizon,, any body tried with a bold and rogers by chance?
    - will it work via bluetooth, or any boddy tried?
    05-06-09 12:29 PM
  2. theboyk's Avatar
    ok, its working great now!
    What did you do?
    I had the same problem *first couple times it appeared, but TB didn't work. Then, after some uninstalls and reinstalls, adapter 2 stopped appearing so, would love to know how you got it working.

    That aside, when it did appear, it never showed as "connected" and the TB GUI reported "Failed to load the BB Interface".

    I have Mass Storage auto-enabled/yes.

    Any help would be appreciated!
    k.
    05-06-09 12:29 PM
  3. marckatz's Avatar
    On my BB is says connection was successful. On my Mac it says no network adapter found. Looked in my Network Preferences and saw no new adapters. Can't figure out where to set the adapter to DHCP
    05-06-09 12:30 PM
  4. msgreenf's Avatar
    On my BB is says connection was successful. On my Mac it says no network adapter found. Looked in my Network Preferences and saw no new adapters. Can't figure out where to set the adapter to DHCP
    Try adding a new adapter of the "type" network adapter 2. then relaunch the app on the mac. That is what fixed it for me.
    05-06-09 12:32 PM
  5. theboyk's Avatar
    I assume you're talking about Interface type?
    If so, I don't have an option for "network adapter 2" — my options are:

    FireWire
    Ethernet Adapter (en6)
    Ethernet Adapter (en5)
    Ethernet Adapter (en4)
    Ethernet 2
    Ethernet 1

    I'm using Ethernet 1 & 2 already (Cat53 plugged in).

    !?!?
    k.
    05-06-09 12:35 PM
  6. msgreenf's Avatar
    yeah, add a new adapter of type "Ethernet 2"
    05-06-09 12:49 PM
  7. drewam07's Avatar
    yeah, add a new adapter of type "Ethernet 2"
    Then what? Mine still isn't working.
    05-06-09 12:57 PM
  8. Jester23's Avatar
    same here, not working... can someone who has this working please do up a step by step from start to finish so that those of us who are having problems can see what we are doing wrong???
    05-06-09 12:58 PM
  9. theboyk's Avatar
    Well, on my machine, Ethernet 2 is a physical port (I have two ethernet ports). I had both Ethernet ports in use when I first installed TB, so it wouldn't have been able to use "Ethernet 2" it created its own entry/port. Shouldn't TB be creating some sort of virtual port that USB connects to or something
    05-06-09 12:59 PM
  10. drewam07's Avatar
    I think the problem is in the program itself, not the mac's. The program automatically opens up saying "Failed to load the Blackberry Device"
    05-06-09 01:01 PM
  11. piwh1000's Avatar
    Hey Guys,

    Patrick here from TetherBerry. Just want to see if we can help resolve your problems.

    What type of phones are you guys using and what version of OSX?
    05-06-09 01:11 PM
  12. marckatz's Avatar
    I'm using the Storm (9530) and running OS X ver 10.5.6
    I using a PowerBook G4
    I get no network adapter on my PC when I install. the BB says I have a successful connection.

    Thanks
    05-06-09 01:15 PM
  13. Jester23's Avatar
    blackberry storm 9530. Intel MacBook OSX version 10.5.6

    Blackberry says connection successful but mac program says Failed to Load the Blackberry Interface
    05-06-09 01:16 PM
  14. AtomicFireball's Avatar
    Hi! I am on a Mac OS X 10.5.6. I use a Blackberry Storm 9530 on Verizon Network. I am getting the Failed to... Network is showing cable unplugged. Thanks!
    05-06-09 01:19 PM
  15. jappadod's Avatar
    Hey guys, I'm the developer of the Mac version of TetherBerry.

    For the one that has the PowerBook G4, it will not work on those processors yet. We forgot to add that to our post. My main problem with getting that going is I don't have access to a Mac with one of those processors and there is the whole Big Endian/Little Endian conversion that needs to be looked at to make it work. I'll try and get one once I get back from WES.

    For everyone else can you open a terminal and run the following command and let me know the output you get?...
    sudo kextload -v /System/Library/Extensions/TetherBerry.kext

    That will try to load the ethernet adapter. You can also unload the adapter with the following command
    sudo kextunload /System/Library/Extensions/TetherBerry.kext

    Thanks
    05-06-09 01:23 PM
  16. theboyk's Avatar
    BlackBerry Storm 9530.
    Mac Pro running OS X 10.5.6

    Same for me, the Storm says everything is OK, but it's the Mac side failing in the following ways:

    1 - TB isn't creating any network interface in my network settings, thus there's nothing I can do to set up a connect via DHCP

    2 - TBGui says "Failed to Load the Blackberry Interface", I assume because of this issue with #1?

    k.
    05-06-09 01:24 PM
  17. Jester23's Avatar
    kextload: extension /System/Library/Extensions/TetherBerry.kext appears to be loadable
    kextload: loading extension /System/Library/Extensions/TetherBerry.kext
    kextload: extension /System/Library/Extensions/TetherBerry.kext is already loaded




    is what I get
    05-06-09 01:26 PM
  18. theboyk's Avatar
    Ok, ran the first command (kextload) and got:

    kextload: extension /System/Library/Extensions/TetherBerry.kext appears to be loadable
    kextload: loading extension /System/Library/Extensions/TetherBerry.kext
    kextload: extension /System/Library/Extensions/TetherBerry.kext is already loaded

    But, the adapter doesn't show.
    So, I tried to unload and got:

    kextunload: unload kext /System/Library/Extensions/TetherBerry.kext succeeded

    Tried to load again and got:

    kextload: extension /System/Library/Extensions/TetherBerry.kext appears to be loadable
    kextload: loading extension /System/Library/Extensions/TetherBerry.kext
    kextload: /System/Library/Extensions/TetherBerry.kext loaded successfully
    kextload: sending personalities to kernel:
    kextload: from extension /System/Library/Extensions/IONetworkingFamily.kext:
    kextload: IONetworkStack
    kextload: Kernel Debugging Driver
    kextload: from extension /System/Library/Extensions/TetherBerry.kext:
    kextload: TetherBerry
    kextload: sending 3 personalities to the kernel
    kextload: matching started for /System/Library/Extensions/TetherBerry.kext

    But still, I'm not seeing any ethernet adapter loaded?
    What should the name of the ethernet adapter that gets loaded be called?

    k.
    05-06-09 01:29 PM
  19. jappadod's Avatar
    kextload: extension /System/Library/Extensions/TetherBerry.kext appears to be loadable
    kextload: loading extension /System/Library/Extensions/TetherBerry.kext
    kextload: extension /System/Library/Extensions/TetherBerry.kext is already loaded

    is what I get
    Let me take a quick look through the code again to see what the last thing it tries before it prints the error you mentioned above...
    05-06-09 01:29 PM
  20. jappadod's Avatar
    Ok, ran the first command (kextload) and got:

    kextload: extension /System/Library/Extensions/TetherBerry.kext appears to be loadable
    kextload: loading extension /System/Library/Extensions/TetherBerry.kext
    kextload: extension /System/Library/Extensions/TetherBerry.kext is already loaded

    But, the adapter doesn't show.
    So, I tried to unload and got:

    kextunload: unload kext /System/Library/Extensions/TetherBerry.kext succeeded

    Tried to load again and got:

    kextload: extension /System/Library/Extensions/TetherBerry.kext appears to be loadable
    kextload: loading extension /System/Library/Extensions/TetherBerry.kext
    kextload: /System/Library/Extensions/TetherBerry.kext loaded successfully
    kextload: sending personalities to kernel:
    kextload: from extension /System/Library/Extensions/IONetworkingFamily.kext:
    kextload: IONetworkStack
    kextload: Kernel Debugging Driver
    kextload: from extension /System/Library/Extensions/TetherBerry.kext:
    kextload: TetherBerry
    kextload: sending 3 personalities to the kernel
    kextload: matching started for /System/Library/Extensions/TetherBerry.kext

    But still, I'm not seeing any ethernet adapter loaded?
    What should the name of the ethernet adapter that gets loaded be called?

    k.
    Hi,

    Can you send the output of ifconfig?
    05-06-09 01:30 PM
  21. Jester23's Avatar
    I ran the unload then the load again and got this

    kextload: extension /System/Library/Extensions/TetherBerry.kext appears to be loadable
    kextload: loading extension /System/Library/Extensions/TetherBerry.kext
    kextload: /System/Library/Extensions/TetherBerry.kext loaded successfully
    kextload: sending personalities to kernel:
    kextload: from extension /System/Library/Extensions/IONetworkingFamily.kext:
    kextload: IONetworkStack
    kextload: Kernel Debugging Driver
    kextload: from extension /System/Library/Extensions/TetherBerry.kext:
    kextload: TetherBerry
    kextload: sending 3 personalities to the kernel
    kextload: matching started for /System/Library/Extensions/TetherBerry.kext


    Edit: I see in the post after my last that someone is getting the same as I am so it looks like it's not just because of my computer itself.

    And this is what the Mac program shows when started up
    Last edited by Jester23; 05-06-09 at 01:34 PM.
    05-06-09 01:31 PM
  22. AtomicFireball's Avatar
    kextload: extension /System/Library/Extensions/TetherBerry.kext appears to be loadable
    kextload: loading extension /System/Library/Extensions/TetherBerry.kext
    kextload: extension /System/Library/Extensions/TetherBerry.kext is already loaded

    When I unloaded it it seemed to succeed, but on my Tetherberry Gui it now says: Could not find the network adapter.
    Last edited by AtomicFireball; 05-06-09 at 01:36 PM. Reason: Add on more info
    05-06-09 01:33 PM
  23. jappadod's Avatar
    The "Failed to Load the Blackberry Interface" would happen if it can't find the correct USB endpoints from your BlackBerry. Do any of you have USB Prober installed?

    Thanks
    05-06-09 01:34 PM
  24. Jester23's Avatar
    The "Failed to Load the Blackberry Interface" would happen if it can't find the correct USB endpoints from your BlackBerry. Do any of you have USB Prober installed?

    Thanks
    Never heard of this... is it required?
    05-06-09 01:35 PM
  25. marckatz's Avatar
    Hey guys, I'm the developer of the Mac version of TetherBerry.

    For the one that has the PowerBook G4, it will not work on those processors yet. We forgot to add that to our post. My main problem with getting that going is I don't have access to a Mac with one of those processors and there is the whole Big Endian/Little Endian conversion that needs to be looked at to make it work. I'll try and get one once I get back from WES.

    For everyone else can you open a terminal and run the following command and let me know the output you get?...
    sudo kextload -v /System/Library/Extensions/TetherBerry.kext

    That will try to load the ethernet adapter. You can also unload the adapter with the following command
    sudo kextunload /System/Library/Extensions/TetherBerry.kext

    Thanks
    I'd be happy to beta test once you get back from WES and look at the conversion. I'll keep checking the thread or you can shoot me an email at marckatz@charter.net.
    Thanks
    05-06-09 01:35 PM
172 1234 ...
LINK TO POST COPIED TO CLIPBOARD