1. akathephoenix's Avatar
    Everytime I try to upgrade form 4.7... to 5.0... I get an error message saying that my device has been disconnected. It has now "bricked" (or whatever you call it) my Storm. The phone now reads "reload software: 507"... what does this mean and how do i fix it so that my phone at least works.
    10-26-09 04:48 PM
  2. metalman009's Avatar
    upgrading to 0s 5.0 with mac will not work. working for verizon rim has said it will brick your phone
    10-26-09 04:50 PM
  3. AGAV13's Avatar
    same happened to me i tried again and after a few tries it worked but everything on my blackberry was lost all apps, contacts, prefrences. I had my phone backed up so i got most of it back on except for BBM i lost it and cannot get it back.
    10-26-09 04:50 PM
  4. akathephoenix's Avatar
    How do I fix it... I just need a working phone at this point... I can connect to Mac DM and have tried to reload 4.7..., but it wont reload.
    10-26-09 04:54 PM
  5. Veritas89's Avatar
    Too bad it doesn't working using a PC either!
    10-26-09 04:54 PM
  6. Apollonas13's Avatar
    That happened when I upgraded to .328 this afternoon. I unplugged my phone and plugged it back it in and it worked.

    It happened while DM was waiting for my phone to reboot. For whatever reason, when my phone finished rebooting, it gave me the 507 error instead of telling DM that it had rebooted. Needless to say, DM didn't recognize that my phone had finished rebooting. Unplugging and plugging the phone back in forced DM to recognize that the phone had finished rebooting and DM was able to continue loading the OS.
    Last edited by Apollonas13; 10-26-09 at 04:58 PM.
    10-26-09 04:56 PM
  7. tallyviperz's Avatar
    if you guys would not of unplugged your phones, you would of been fine, i did it, got the message, didn't do anything, it pushed through, finished the install, all im missing is facebook
    10-26-09 05:04 PM
  8. Shelikenoother's Avatar
    had the same problem with 5.0 on mac just to much of a hassle went back to 4.7 i just kept pulling the battery and it finally loaded back to 4.7
    10-26-09 08:48 PM